OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> Openoffice With Pocketworkstation?
ShiroiKuma
post Aug 3 2005, 01:10 PM
Post #16





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



Is the OpenOffice included with your JumboXQt package broken somehow, Meanie?

I can't open any Word files with it.

For instance, I just created a file with the text: "Test test test".

This is how the OpenOffice opens it: attchmnt screen002.jpg

Yet Abiword opens it fine, even my desktop OpenOffice has no problem.

And it's not a font issue, no matter which font I try, it's still all garbled up.

What's the problem here?
Attached File(s)
Attached File  scrn002.jpg ( 31.74K ) Number of downloads: 256
 
Go to the top of the page
 
+Quote Post
Stubear
post Aug 3 2005, 05:10 PM
Post #17





Group: Members
Posts: 1,164
Joined: 17-December 03
From: Melbourne, AUSTRALIA
Member No.: 1,219



QUOTE(rehorrericha @ Aug 4 2005, 06:10 AM)
Is the OpenOffice included with your JumboXQt package broken somehow, Meanie?

I can't open any Word files with it.

For instance, I just created a file with the text: "Test test test".

This is how the OpenOffice opens it: attchmnt screen002.jpg

Yet Abiword opens it fine, even my desktop OpenOffice has no problem.

And it's not a font issue, no matter which font I try, it's still all garbled up.

What's the problem here?
*


The problem is that you have used MS Mincho as the font and probably don't have Japanese support activated in openoffice. Are you changing the font in Word or in openoffice?

If you are using a Japanese system to write the word doc, make sure you are using single char alpha and not double char as this would give the garbledness you are seeing

stu
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Aug 5 2005, 10:36 AM
Post #18





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(Stubear @ Aug 4 2005, 02:10 AM)
The problem is that you have used MS Mincho as the font and probably don't have Japanese support activated in openoffice. Are you changing the font in Word or in openoffice?

If you are using a Japanese system to write the word doc, make sure you are using single char alpha and not double char as this would give the garbledness you are seeing
*

This is actually not the case. I have Japanese support activated in OpenOffice and there was only plain text, using the Times font.

However I have experimented with it and found out that if I save the file as Word 97 format, OpenOffice opens it no problem.

Conversely also, if I create a document in OpenOffice on the Z, Word won't open it, it complains about incorrect path to the document (?)

Anyway if I save it as Word 97 in OpenOffice then Word opens it no prob.

Surely there must be something with OpenOffice on the Z that does it, since my desktop OpenOffice doesn't suffer from any of these problems, i.e. it opens the docs no prob and the documents it creates can be opened in Word no prob.

Why's this?
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Aug 5 2005, 04:52 PM
Post #19





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



I have one more question.

Why can't I select some fonts in OpenOffice.

For instance I have ttf-kochi-gothic and ttf-kochi-mincho installed. In Abiword I can select them and type text with them. In OpenOffice though the dropdown list in the font selection doesn't show them as options, so I can't select them.

Why?
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Aug 6 2005, 09:07 AM
Post #20





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



Edit: Updated the insallation instructions here, to not have broken dependencies in debian.

I've solved the issue with OpenOffice not recognizing installed fonts. It seems to me something is wrong with the way OpenOffice is installed using the OOo_SRX645_linuxarm_install.tar.gz file or using Meanie's cramfs image. On top of not recognizing fonts, I couldn't switch the locale of OpenOffice to Japanese.

So I've fiddled with it and this is how I installed OpenOffice that uses all the fonts on the system and that has a Japanese locale, i.e. all the menus in Japanese...

From the page of the author who compiled OpenOffice for arm download the file:
openoffice.org-bin_1.1.4-1_arm.deb

From Debian OpenOffice page download the following files:
openoffice.org-l10n-en_1.1.4-7_all.deb
openoffice.org-l10n-ja_1.1.4-7_all.deb
openoffice.org_1.1.4-7_all.deb
ttf-opensymbol_2.0.0-2_all.deb


From Debian OpenOffice Debian files page download the file:
openoffice.org-debian-files_1.1.4-6+1_all.deb

From the attachment to this message download libneon23_0.23.9.dfsg.3_arm.zip and unzip it.

Put all the above files in one directory. I use /mnt/cf/InstallDebian/OpenOffice

Then, run the following:
CODE
apt-get install dpkg-multicd
cd /mnt/cf/InstallDebian/OpenOffice
dpkg-scanpackages . /dev/null | gzip -9 > Packages.gz


You should see something like this:
CODE
** Packages in archive but missing from override file: **
...

Wrote 8 entries to output Packages file.


Then edit the /etc/apt/sources.list file and at the end add a line
CODE
deb file:/mnt/cf/InstallDebian/OpenOffice ./


Then run the following:
CODE
apt-get update
apt-get upgrade
apt-get install openoffice.org openoffice.org-l10n-ja
dpkg-reconfigure openoffice.org-l10n-ja


And that's it, it'll run no prob now.

Then start OpenOffice by typing
CODE
ooffice


When it comes up go to Tools => Options => Language Setting => Languages
There select Japanese for locale setting and hit OK
Then exit OpenOffice.

Done.

Now when you start it again, it'll come up in Japanese.

Furthermore, you can use all the fonts that you have installed in Debian, unlike with the OpenOffice from Meanie's file, where I couldn't...

The only issue which seems to be permanent with OpenOffice for arm is that you must save the documents in Word 97 format to be able to open them in Word and vice versa, from Word you also have to save in Word 97 to be able to open in OpenOffice.

At least I haven't found a way to fix this. And the prob doesn't exist in my desktop OpenOffice version, so it's somehow connected with this...
Attached File(s)
Attached File  libneon23_0.23.9.dfsg.3_arm.zip ( 76.97K ) Number of downloads: 62
 
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th October 2014 - 11:00 AM