OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3  
Reply to this topicStart new topic
> Openbsd 4.2 Beta Issues
adf
post Aug 26 2007, 05:30 PM
Post #31





Group: Members
Posts: 2,821
Joined: 13-September 04
From: Wasilla Ak.
Member No.: 4,572



QUOTE(ZDevil @ Aug 26 2007, 02:58 PM)
adf, I think you can find some of the answers here: http://www.oesf.org/forums/index.php?showtopic=17871

One thing may be different now: the system and the packages are now generally built with optimization settings.

Rereading Andy's text makes me think of the progress of work on bluetooth and SD support: Is GPL the main reason not to implement Bluez and the SD solution in other "roms"? But I see lardman's reply in the same thread. If he's right, then why not? Or if the implementation is problematic, then how? rolleyes.gif
*

Thanks-that answered most of my questions. given that I rely on SD and Bluetooth it would be better if Ididn't consider openbsd as my main os on the Z--though popping it on a cf for fun might be in the future. Given at least the potential for working-but-unofficial binary hardwre drivers this situation may not be permanent
Go to the top of the page
 
+Quote Post
mathemajikian
post Aug 26 2007, 05:55 PM
Post #32





Group: Members
Posts: 304
Joined: 8-July 06
From: United Kingdom for now....
Member No.: 10,349



QUOTE(ZDevil @ Aug 27 2007, 01:02 AM)
Just out of curiosity: the latest snapshots feel snappier than 4.1. Is the whole systems built with optimization or is it just my illusion?  smile.gif

I think the GENERIC kernel and base system are built with CPUFLAGS="-mcpu=xscale" only.

I've added the following to my Kernel:

makeoptions CPUFLAGS="-mtune=xscale -mcpu=xscale -O2 -pipe"

However; if you've setup the CFLAGS, and CXXFLAGS optimization flags in /etc/mk.conf, then your entire system will be built with "-mtune=xscale -mcpu=xscale -O2 -pipe" when you build from source. smile.gif
Go to the top of the page
 
+Quote Post
ZDevil
post Aug 29 2007, 03:48 AM
Post #33





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Ok, here is another issue about xrandr.

I tried xrandr -q to find out the correct size and got
CODE
Xlib: extension "RANDR" missing on display ":0.0"


And then I tried xrandr with some flags, e.g. -o -s etc, and got
CODE
Can't open display 0


Is there something we have to set in /etc/X11/xorg.conf? Or something else?

Thanks!
Go to the top of the page
 
+Quote Post
mathemajikian
post Sep 15 2007, 10:41 AM
Post #34





Group: Members
Posts: 304
Joined: 8-July 06
From: United Kingdom for now....
Member No.: 10,349



QUOTE(ZDevil @ Aug 29 2007, 11:48 AM)
I tried xrandr -q to find out the correct size and got
CODE
Xlib: extension "RANDR" missing on display ":0.0"

And then I tried xrandr with some flags, e.g. -o -s etc, and got
CODE
Can't open display 0


Is there something we have to set in /etc/X11/xorg.conf? Or something else?

If you look in /var/log/Xorg.0.log you'll see this:

QUOTE
(II) wsfb(0): Enabling Driver Rotation, disabling RandR
(==) wsfb(0): Backing store disabled
(--) RandR disabled

So the wsfb driver disables it by default. Currently, the rotation of the screen can be changed by editing the "InputDevice" section of the Xorg.conf:

QUOTE
Option "Rotate" "string"
              Enable  rotation of the display. The supported val­
              ues are "CW" (clockwise, 90 degrees), "UD"  (upside
              down,  180  degrees)  and "CCW" (counter clockwise,
              270 degrees). Implies use of the shadow framebuffer
              layer.


However, it's not on the fly rotation. sad.gif
Go to the top of the page
 
+Quote Post

3 Pages V  < 1 2 3
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 05:00 AM