OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Bluetooth Works On Ångström
ShiroiKuma
post Apr 8 2007, 09:01 AM
Post #1





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



I've spent many days trying to get bluetooth to work under Ångström with an Anycom card that worked under OZ. Figured it out finally.

Bluetooth works under Ångström
Go to the top of the page
 
+Quote Post
jpmatrix
post Apr 9 2007, 10:13 AM
Post #2





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(ShiroiKuma @ Apr 8 2007, 07:01 PM)
I've spent many days trying to get bluetooth to work under Ångström with an Anycom card that worked under OZ. Figured it out finally.

Bluetooth works under Ångström
*


well
i'm afraid that doesn't work with my belkin ft0820 bt cf card...
here is my dmesg output

http://matrixmen.free.fr/zaurus/angstrom/dmesg.err

would you help me please? smile.gif
Go to the top of the page
 
+Quote Post
ant
post Apr 13 2007, 05:00 AM
Post #3





Group: Members
Posts: 163
Joined: 11-March 04
From: IT
Member No.: 2,270



The problem is here...

...kobject_add failed for ttySx with -EEXIST, don't try to register things with the same name in the same directory.


Seems you're stuck like here (this was with kernel 2.6.18, though)

http://bugs.openembedded.org/show_bug.cgi?id=1802

The bug is not yet closed...
Go to the top of the page
 
+Quote Post
jpmatrix
post Apr 13 2007, 05:34 AM
Post #4





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(ant @ Apr 13 2007, 03:00 PM)
The problem is here...

...kobject_add failed for ttySx with -EEXIST, don't try to register things with the same name in the same directory.


Seems you're stuck like here (this was with kernel 2.6.18, though)

http://bugs.openembedded.org/show_bug.cgi?id=1802

The bug is not yet closed...
*


yeah i saw that.... really a pity....
i've to wait...
Go to the top of the page
 
+Quote Post
jpmatrix
post Apr 17 2007, 03:16 PM
Post #5





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



gotcha!
i finally succeed in having bluetooth dialup to work ! not with my belkin bluetooth cf but with my bt USB dongle !

have a look there:
http://matrixmen.free.fr/zaurus/
Go to the top of the page
 
+Quote Post
jpmatrix
post Jul 1 2007, 08:53 AM
Post #6





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



it seems CF troubles are now fixed in Angstrom !
now my CF BT is working and i can dialup thru my Nokia with BT ! great!
Go to the top of the page
 
+Quote Post
olipage
post Nov 3 2008, 01:29 AM
Post #7





Group: Members
Posts: 10
Joined: 31-October 08
Member No.: 23,292



QUOTE(ShiroiKuma @ Apr 8 2007, 06:01 PM) *
I've spent many days trying to get bluetooth to work under Ångström with an Anycom card that worked under OZ. Figured it out finally.

Bluetooth works under Ångström


Hey guys,

I ran over plenty of dicussions and info over bluetooth cf cards an angstrom. this post from 2007 was pretty positive on bluetooth, since i already tried various kernels, and chip sets. now i installed your kernel 2.6.20 but using my bt2000e card, which uses the serial_cs i couldn't get it working since i have no appropriate kernel-modules.

i just wonder, whether this patch (pdax-patch) has been excluded in the meantime from angstrom (kernel 2.6.26).

if so, i would not need to make any efforts to build the missing kernel-modules, because your solution would not work for me.

basically i have an already documented hciattach error, because my card using serial_cs, and 8250 (in angstrom 2.6.24 module 8250 actually gets loaded without error - in controverse to your solution mentioned above).

does any one have a running bt2000e card with recent angstrom?

i used hciattach with ericsson chip set and it worked without error, but hciconfig up retournes as already stated in discussions and howtos a timeout. i tried plenty of solutions, but before continueing i'd like to know whether someone has this card running on angstrom, if so, using which kernel.

my system recognizes the card properly and initializes needed modules. i tried manual modprobe, but hciattach did not succed, even though trying different setserial speeds, because this was an error in history.

thanks a lot

Oliver
Go to the top of the page
 
+Quote Post
olipage
post Nov 3 2008, 06:28 AM
Post #8





Group: Members
Posts: 10
Joined: 31-October 08
Member No.: 23,292



hey guys,

so in fact in the meantime i am searching for either bt2000e_cs compiled for 2.6.24/26 angstrom, (from iral.com...)

i know it should work with serial_cs - but it doesn't.

does anyone have one of those driver modules?

for a full picture of my problem:

pccardctl info => btcard bound to serial_cs
dmesg states that gets initialized as ttyS4
hci_uart, serial_cs,8250, all bluetooth modules are loaded

when doing
hciattach /dev/ttyS4 ericsson (using speed statements, or not, flow or not, using different chipsets)
works
but
hciconfig -a results in
Type UART
BD Adress: 00:00:00:00:00:00
Down

on hciconfig hci0 up
can't init device hci0: connection timed out (110)

actually i can't believe that the card is not working: worked outofthebox with pdaxrom running 2.4.20 Kernel.

ok, the card is a ambicom BT2000E, identification works fine using pccardctl


cheers, Oliver
Go to the top of the page
 
+Quote Post
olipage
post Nov 7 2008, 12:05 AM
Post #9





Group: Members
Posts: 10
Joined: 31-October 08
Member No.: 23,292



To all BT-Support Searchers,

Try to get a Nokia Card. Nokia Connectivity Pack is more spread in Ebay, cheaper in Ebay and it Works out of the box with the latest angstrom Kernel (2.6.24).

Cheers,

Oliver
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th October 2014 - 12:45 AM