OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Building Openoffice.org 2.0.3 Natively
ShiroiKuma
post Apr 11 2007, 07:24 AM
Post #1





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



I'm referring to Koen's guide on building OpenOffice.org 2.0.3.

Got as fas as when he mentions unbreaking the set_soenv, where the make fails with "Use of uninitialized value in concatenation..."

I don't know how to unbreak it. Has anyone compiled OpenOffice 2.0.3 successfully on the Zaurus? How do I unbreak it and proceed?
Go to the top of the page
 
+Quote Post
Meanie
post Apr 11 2007, 05:43 PM
Post #2





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(ShiroiKuma @ Apr 12 2007, 01:24 AM)
I'm referring to Koen's guide on building OpenOffice.org 2.0.3.

Got as fas as when he mentions unbreaking the set_soenv, where the make fails with "Use of uninitialized value in concatenation..."

I don't know how to unbreak it. Has anyone compiled OpenOffice 2.0.3 successfully on the Zaurus? How do I unbreak it and proceed?
*


you must enjoy pain. compiling firefox 2.0 natively on the Z took like 3 days straight compiling, plus the many unsuccessful attempts after which I had to restart the long compile...

now openoffice is significantly larger than firefox. my estimate would be minimum one month straight compile assuming no hickups and restart....

don't want to discurage you, but just letting you know what you are in for....

good luck!
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 11 2007, 06:26 PM
Post #3





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



QUOTE(Meanie @ Apr 11 2007, 08:43 PM)
QUOTE(ShiroiKuma @ Apr 12 2007, 01:24 AM)
I'm referring to Koen's guide on building OpenOffice.org 2.0.3.

Got as fas as when he mentions unbreaking the set_soenv, where the make fails with "Use of uninitialized value in concatenation..."

I don't know how to unbreak it. Has anyone compiled OpenOffice 2.0.3 successfully on the Zaurus? How do I unbreak it and proceed?
*

you must enjoy pain. compiling firefox 2.0 natively on the Z took like 3 days straight compiling, plus the many unsuccessful attempts after which I had to restart the long compile...
*


Wait...You have FF2 compiled and we didn't know/don't have a package?!?!?! Or did I miss something?

EDIT: If no package, maybe a how-to?

This post has been edited by Capn_Fish: Apr 11 2007, 06:32 PM
Go to the top of the page
 
+Quote Post
desertrat
post Apr 11 2007, 07:09 PM
Post #4





Group: Members
Posts: 742
Joined: 15-October 05
From: Gulag, Siberia
Member No.: 8,322



ShiroiKuma make sure you have plenty of free disk space, the build uses about 3GB of space. And good luck, I think you'll need it tongue.gif
Go to the top of the page
 
+Quote Post
Meanie
post Apr 11 2007, 11:07 PM
Post #5





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Capn_Fish @ Apr 12 2007, 12:26 PM)
QUOTE(Meanie @ Apr 11 2007, 08:43 PM)
QUOTE(ShiroiKuma @ Apr 12 2007, 01:24 AM)
I'm referring to Koen's guide on building OpenOffice.org 2.0.3.

Got as fas as when he mentions unbreaking the set_soenv, where the make fails with "Use of uninitialized value in concatenation..."

I don't know how to unbreak it. Has anyone compiled OpenOffice 2.0.3 successfully on the Zaurus? How do I unbreak it and proceed?
*

you must enjoy pain. compiling firefox 2.0 natively on the Z took like 3 days straight compiling, plus the many unsuccessful attempts after which I had to restart the long compile...
*


Wait...You have FF2 compiled and we didn't know/don't have a package?!?!?! Or did I miss something?

EDIT: If no package, maybe a how-to?
*



http://www.tyrannozaurus.com/?q=node/478
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 11 2007, 11:56 PM
Post #6





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(Meanie @ Apr 12 2007, 02:43 AM)
you must enjoy pain. compiling firefox 2.0 natively on the Z took like 3 days straight compiling, plus the many unsuccessful attempts after which I had to restart the long compile...
*

Yeah, I do smile.gif

Well, maybe I was optimistic. I thought it'd take like a week or two straight compiling...

Anyhow, maybe I won't get far no matter what. Have been trying to figure out what the problem with set_soenv, maybe in conjunction with tcsh is, but can't get it going...

So maybe, this is the final stop sad.gif

It'd be cool to have OO2 optimized for Angstrom though, as it'd be faster than OO1 under debian, so thought it'd be worth it...
Go to the top of the page
 
+Quote Post
koen
post Apr 12 2007, 12:13 AM
Post #7





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(Meanie @ Apr 12 2007, 01:43 AM)
QUOTE(ShiroiKuma @ Apr 12 2007, 01:24 AM)
I'm referring to Koen's guide on building OpenOffice.org 2.0.3.

Got as fas as when he mentions unbreaking the set_soenv, where the make fails with "Use of uninitialized value in concatenation..."

I don't know how to unbreak it. Has anyone compiled OpenOffice 2.0.3 successfully on the Zaurus? How do I unbreak it and proceed?
*


you must enjoy pain. compiling firefox 2.0 natively on the Z took like 3 days straight compiling, plus the many unsuccessful attempts after which I had to restart the long compile...

now openoffice is significantly larger than firefox. my estimate would be minimum one month straight compile assuming no hickups and restart....

don't want to discurage you, but just letting you know what you are in for....

good luck!
*



That's why I borrowed an arm machine with a microdrive and 256MB RAM smile.gif
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 12 2007, 12:40 AM
Post #8





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(koen @ Apr 12 2007, 09:13 AM)
That's why I borrowed an arm machine with a microdrive and 256MB RAM smile.gif
*

Did you succeed in compiling it? Does it work under Angstrom?
Go to the top of the page
 
+Quote Post
koen
post Apr 12 2007, 12:58 AM
Post #9





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(ShiroiKuma @ Apr 12 2007, 08:40 AM)
QUOTE(koen @ Apr 12 2007, 09:13 AM)
That's why I borrowed an arm machine with a microdrive and 256MB RAM smile.gif
*

Did you succeed in compiling it? Does it work under Angstrom?
*



No, I gave up and installed abiword.
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 12 2007, 03:00 AM
Post #10





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(koen @ Apr 12 2007, 09:58 AM)
No, I gave up and installed abiword.
*

LOL ohmy.gif)

So that's probably the solution...
Go to the top of the page
 
+Quote Post
radiochickenwax
post Apr 13 2007, 04:22 PM
Post #11





Group: Members
Posts: 158
Joined: 21-November 04
Member No.: 5,548



In the meantime, there's debian, as suggested:

http://shiroikuma.com/index.php?cmd=%E7%9B...0OpenOffice.org

However, the debian packages for open office are missing. Particularly:


http://people.debian.org/~rene/openoffice....1.1.4-1_arm.deb

Gives a 404 (not found) error.

Could someone please provide a new download link if possible?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st September 2014 - 03:21 AM