OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

4 Pages V  « < 2 3 4  
Reply to this topicStart new topic
> Howto Load Usb Driver(s) To Get Usbd0?, OZ/GPE 3.5.4 + on C860 (boxer)
grog
post Aug 9 2006, 09:31 AM
Post #46





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



QUOTE(grog @ Aug 8 2006, 11:30 AM)
I think the pc is now confused. I recognized the Z as a new device, even though I had previously tried this with rc4. I had to point it at the usb8023k.sys driver again & the new network icon now says it's "Linux USB Ethernet/RNDIS Gadget #2". When I set the ip address, it complained that it had the same address as the "Linux USB Ethernet/RNDIS Gadget", but that isn't shown anywhere so I can delete or change it's settings. So I think this may be an address conflict problem between the two devices, but I can't see any way of removing the first one.
*

No headway yet. Haven't had time to test on XP, the 2000 box isn't able to ping 192.168.129.201, even though it shows the device attached & the network icon shows connected.
Go to the top of the page
 
+Quote Post
lardman
post Aug 11 2006, 04:59 AM
Post #47





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
I think the pc is now confused. I recognized the Z as a new device, even though I had previously tried this with rc4. I had to point it at the usb8023k.sys driver again & the new network icon now says it's "Linux USB Ethernet/RNDIS Gadget #2". When I set the ip address, it complained that it had the same address as the "Linux USB Ethernet/RNDIS Gadget", but that isn't shown anywhere so I can delete or change it's settings. So I think this may be an address conflict problem between the two devices, but I can't see any way of removing the first one.


This is standard, I get this warning whenever I create a new connection with the same IP address.

After your ping has failed, I'd be interested to see the output of:

on the Windows machine: 'ipconfig' and 'route print'
and on the Zaurus: 'ifconfig' and 'route'


Si
Go to the top of the page
 
+Quote Post
grog
post Aug 11 2006, 06:50 AM
Post #48





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



QUOTE(lardman @ Aug 11 2006, 06:59 AM)
QUOTE
I think the pc is now confused. I recognized the Z as a new device, even though I had previously tried this with rc4. I had to point it at the usb8023k.sys driver again & the new network icon now says it's "Linux USB Ethernet/RNDIS Gadget #2". When I set the ip address, it complained that it had the same address as the "Linux USB Ethernet/RNDIS Gadget", but that isn't shown anywhere so I can delete or change it's settings. So I think this may be an address conflict problem between the two devices, but I can't see any way of removing the first one.

This is standard, I get this warning whenever I create a new connection with the same IP address.

After your ping has failed, I'd be interested to see the output of:

on the Windows machine: 'ipconfig' and 'route print'
and on the Zaurus: 'ifconfig' and 'route'
*


Windows:

CODE
C:\>ping 192.168.129.201

Pinging 192.168.129.201 with 32 bytes of data:

Request timed out.
Request timed out.

Ping statistics for 192.168.129.201:
   Packets: Sent = 2, Received = 0, Lost = 2 (100% loss),
Approximate round trip times in milli-seconds:
   Minimum = 0ms, Maximum =  0ms, Average =  0ms
Control-C
^C
C:\>ipconfig

Windows 2000 IP Configuration

Ethernet adapter zaurus:

       Connection-specific DNS Suffix  . :
       IP Address. . . . . . . . . . . . : 192.168.129.200
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : federated.ca
       IP Address. . . . . . . . . . . . : 172.28.14.63
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . : 172.28.10.3

C:\>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x1000004 ...00 0f 1f 88 76 df ...... Broadcom NetXtreme Gigabit Ethernet Driver

0x3000002 ...e6 6d e4 94 22 ad ...... Linux 2.6.16/pxa2xx_udc
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
         0.0.0.0          0.0.0.0      172.28.10.3    172.28.14.63       1
       127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      172.28.0.0      255.255.0.0     172.28.14.63    172.28.14.63       1
    172.28.14.63  255.255.255.255        127.0.0.1       127.0.0.1       1
  172.28.255.255  255.255.255.255     172.28.14.63    172.28.14.63       1
   192.168.129.0    255.255.255.0  192.168.129.200  192.168.129.200      1
 192.168.129.200  255.255.255.255        127.0.0.1       127.0.0.1       1
 192.168.129.255  255.255.255.255  192.168.129.200  192.168.129.200      1
       224.0.0.0        224.0.0.0     172.28.14.63    172.28.14.63       1
       224.0.0.0        224.0.0.0  192.168.129.200  192.168.129.200      1
 255.255.255.255  255.255.255.255     172.28.14.63    172.28.14.63       1
Default Gateway:       172.28.10.3
===========================================================================
Persistent Routes:
 None


Z

CODE
+ ifconfig
lo        Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:13 errors:0 dropped:0 overruns:0 frame:0
         TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:1192 (1.1 KiB)  TX bytes:1192 (1.1 KiB)

usb0      Link encap:Ethernet  HWaddr 46:9E:7A:D5:9C:1D  
         inet addr:192.168.129.201  Bcast:192.168.129.255  Mask:255.255.255.0
         inet6 addr: fe80::449e:7aff:fed5:9c1d/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:3 errors:1 dropped:0 overruns:0 frame:1
         TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:84 (84.0 B)  TX bytes:2196 (2.1 KiB)

+ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.129.0   *               255.255.255.0   U     0      0        0 usb0
default         192.168.129.200 0.0.0.0         UG    0      0        0 usb0
Go to the top of the page
 
+Quote Post
Da_Blitz
post Aug 11 2006, 11:30 PM
Post #49





Group: Members
Posts: 1,565
Joined: 7-April 05
From: Sydney, Australia
Member No.: 6,806



QUOTE
192.168.129.200  255.255.255.255        127.0.0.1      127.0.0.1      1
192.168.129.255  255.255.255.255  192.168.129.200  192.168.129.200      1


looks to me as if the interface is set up incorectly on the windows PC, the broadcast address below it seems to be fine but the other just points back to itself
Go to the top of the page
 
+Quote Post

4 Pages V  « < 2 3 4
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 11:51 AM