OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> ettercap on 1.21b
caleb
post Jun 14 2004, 07:12 PM
Post #1





Group: Members
Posts: 9
Joined: 28-May 04
Member No.: 3,477



I've been trying to get ettercap working for a while now, tried about 4 different versions, each one is giving me this error:

ettercap: /lib/libc.so.6: version `GLIBC_2.3' not found (required by ettercap)

Not sure what this means exactly, I'm using the 1.21b rom btw.

Is there any workaround for this error, or could I recompile ettercap from source using a certain version of gcc? I gather by reading other posts about this error that I can't install the newer libc thing, and need to find a version of ettercap compiled with 2.2 or some lower version maybe?

Anyway, I'm still learning, only had my c860 for 2 days now =P .. any tips would be appreciated =)
Go to the top of the page
 
+Quote Post
datajerk
post Jun 14 2004, 07:58 PM
Post #2





Group: Members
Posts: 219
Joined: 14-February 04
Member No.: 1,861



Try http://packages.debian.org/stable/non-US/ettercap
Go to the top of the page
 
+Quote Post
caleb
post Jun 14 2004, 10:01 PM
Post #3





Group: Members
Posts: 9
Joined: 28-May 04
Member No.: 3,477



Thanks, I got that one to run at least, but it is a little messed up.
The ip#s are backwards and I can't move the cursor left or up for some reason =
Go to the top of the page
 
+Quote Post
datajerk
post Jun 14 2004, 11:23 PM
Post #4





Group: Members
Posts: 219
Joined: 14-February 04
Member No.: 1,861



Try this one: http://www.sense.net/zc/files/ettercap_NG-...7.0_rc1_arm.ipk

I just built it from the latest sources including library sources. It runs with -C, but that is about all I tested. Let me know if this works or not. Never using it before I cannot tell.
Go to the top of the page
 
+Quote Post
caleb
post Jun 15 2004, 07:22 AM
Post #5





Group: Members
Posts: 9
Joined: 28-May 04
Member No.: 3,477



It runs nicely, but doesn't work right still, the ips are still backwards as far as I can tell, and because of that it won't really get much accurate information..

Might it be a big/little endian problem?

Just out of curiosity, what do you use to cross compile for this particular rom? I want to give it a try sometime...
Go to the top of the page
 
+Quote Post
datajerk
post Jun 15 2004, 07:47 AM
Post #6





Group: Members
Posts: 219
Joined: 14-February 04
Member No.: 1,861



Yeah i working on that, dunno the problem yet, i also get it to crash with libnet errors. Never using the tool i am not sure exactly what to do with it.

I checked the big/little stuff, i may have missed it somewhere.

There in an FAQ somewhere on this site with x-compile notes. Bottom line its gcc 2.95, Qt 1.5.x, and I also have installed the Xqt devel package so that I can build X binaries. All in all x-compiling sucks. All 4 libs and ettercap has required hacks just to get configured.

I have done some cleanup, still backwards.
Go to the top of the page
 
+Quote Post
datajerk
post Jun 15 2004, 08:26 AM
Post #7





Group: Members
Posts: 219
Joined: 14-February 04
Member No.: 1,861



BTW if you are just looking for a sniffer I do have ethereal packaged to work with Cacko 1.21 and Xqt. I just took the ethereal from here: http://zaurus.spy.org/feeds/davonz/ and repackaged it as an ipkg sans a few files and added a default startup file to fix the geometry at 640x480.
Go to the top of the page
 
+Quote Post
caleb
post Jun 15 2004, 08:57 AM
Post #8





Group: Members
Posts: 9
Joined: 28-May 04
Member No.: 3,477



Ethereal would be nice too, can you post a link to your ipkg of it?

I think using some other tools like ethereal, hunt, and dsniff would probably be able to replace ettercap for the most part...

if you have the time, let me know if you can compile this:
http://naughty.monkey.org/~dugsong/dsniff/...niff-2.3.tar.gz
or this:
http://ftp.localareasecurity.com/pub/wiret...nt/hunt-1.5.tgz

I haven't tried Xqt yet, so I will go find that and give it a try..
Thanks for the help =)
Go to the top of the page
 
+Quote Post
datajerk
post Jun 15 2004, 09:07 AM
Post #9





Group: Members
Posts: 219
Joined: 14-February 04
Member No.: 1,861



http://www.sense.net/zc/files/xqt-ethereal..._0.10.2_arm.ipk

I will try to build the others tonight if I have time.
Go to the top of the page
 
+Quote Post
clofland
post Jun 16 2004, 05:07 AM
Post #10





Group: Members
Posts: 245
Joined: 30-October 03
Member No.: 813



Oh datajerk, YOU ARE THE MAN! This is REALLY cool. Ethereal in my pocket!

I'm also grateful to all of you for xQt. I didn't even really know about it until I saw this thread.

Sylpheed on xQt is the answer to my email problem that I've had since day one! It is awesome! (I do use and like QTMail for most of my day to day email stuff, but my "archive" IMAP repository was too big for QTMail to handle, so I could never access it from my Z.)

Thanks all, and any other packages you want to wrap for us datajerk, we'll be sure to take a peek at! smile.gif
Go to the top of the page
 
+Quote Post
datajerk
post Jun 16 2004, 05:44 AM
Post #11





Group: Members
Posts: 219
Joined: 14-February 04
Member No.: 1,861



I cannot take credit for ethereal, I just took it from here (http://zaurus.spy.org/feeds/davonz/), made an ipk and created a config to correct geometry problems.
Go to the top of the page
 
+Quote Post
datajerk
post Jun 16 2004, 05:47 AM
Post #12





Group: Members
Posts: 219
Joined: 14-February 04
Member No.: 1,861



As you run in to Xqt problems you may want to run .8 instead of .9. There are issues with .9 and some applications that require correct results from DisplayWidthMM and DisplayHeightMM. The only difference from .8 to .9 that I can see is for rotation support.
Go to the top of the page
 
+Quote Post
clofland
post Sep 8 2004, 07:59 AM
Post #13





Group: Members
Posts: 245
Joined: 30-October 03
Member No.: 813



ethereal "suddenly" quit on me.

Always worked fine, then today this.

If I start it as normal user, of course, I don't have permission to open the network card to sniff, but otherwise it opens up and appears to run fine.

If I start as root (SU) or "sudo" then it says:
etheral: /lib/libc.so.6: version 'GLIBC_2.2.3' not found (required by /usr/lib/libgtk-1.2.so.0)

Why would I get that error as root, but not get it when I am not root?

Any ideas? Thanks.
Go to the top of the page
 
+Quote Post
clofland
post Sep 17 2004, 08:29 AM
Post #14





Group: Members
Posts: 245
Joined: 30-October 03
Member No.: 813



I fixed the problem of ethereal running as a user but not as root for myself.

As an FYI to Linux neophytes like me (who've been using Linux off and on for over a decade, and yet still don't know some of these things that probably should be simple):

strace ethereal 2>&1 | grep open | more
(you can download an IPK for strace if you don't have it here http://kozmikaze.com/tools/index.html)

showed that as zaurus it was using: /home/QtPalmtop/lib/libgtk-1.2.so.0
but as root it was using: /usr/lib/libgtk-1.2.so.0 which is actually /home/root/usr/lib/libgtk-1.2.so.0

/home/QtPalmtop/lib/libgtk-1.2.so.0 was 1514968 dated Jan 31 2004
/home/root/usr/lib/libgtk-1.2.so.0 was 1438940 dated Apr 29 16:56
(anyone know why sometimes I get a year and sometimes a time? I'm sure it is, again, something simple that I never noticed before)

so I:
mv /home/root/usr/lib/libgtk-1.2.so.0 /home/root/usr/lib/libgtk-1.2.so.0OLD
cp /home/QtPalmtop/lib/libgtk-1.2.so.0 /home/root/usr/lib/libgtk-1.2.so.0

and all is happy!

I feel like it is odd that as root one lib was used and as zaurus another was used.

I noticed that as zaurus LD_LIBRARY_PATH=/home/QtPalmtop/lib
however under root, the setting does not appear at all.

I tried adding this setting while being root, but it would not take, it just never showed up, at least not in qtX. Maybe I did the command wrong.

The copy worked, but I wonder why the oddness anyway.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th August 2014 - 10:29 AM