OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3  
Reply to this topicStart new topic
> Pdaxqtrom Updates, version 0.7.9
alee16
post Jun 19 2006, 09:21 AM
Post #31





Group: Members
Posts: 113
Joined: 30-May 06
Member No.: 10,009



Meanie, I installed your pdaxqtrom, and xmms, gimp, and a few other apps work great, but I can't get Abiword of Firefox to load. How long should it take Firefox to load?

Abiword gives the following output:
abiword: error while loading shared libraries: /opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-png.so: undefined symbol: png_create_read_struct_2

I think I see the answer earlier in this thread: uninstall libpng and try again from the top, but how do you uninstall libpng?
Go to the top of the page
 
+Quote Post
danboid
post Jun 19 2006, 05:37 PM
Post #32





Group: Members
Posts: 682
Joined: 26-December 05
From: Rochdale, Lancashire
Member No.: 8,789



error while loading shared libraries: /opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-png.so: undefined symbol: png_create_read_struct_2

I'm getting this same error under this latest pdaxqtrom

I'd ran the homefix tool or whatever its called- that made no difference. Tried doing a xqtcleanup and then re-installing with pdaXqtrom-base-setup and the apps one too but I still get the same error as these guys. I haven't installed any version of libpng, but one may come with cacko 1.23b as standard? I'm not next to my Z..
Go to the top of the page
 
+Quote Post
Meanie
post Jun 19 2006, 05:48 PM
Post #33





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(alee16 @ Jun 20 2006, 03:21 AM)
Meanie, I installed your pdaxqtrom, and xmms, gimp, and a few other apps work great, but I can't get Abiword of Firefox to load.  How long should it take Firefox to load? 

Abiword gives the following output:
abiword: error while loading shared libraries: /opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-png.so: undefined symbol: png_create_read_struct_2

I think I see the answer earlier in this thread: uninstall libpng and try again from the top, but how do you uninstall libpng?
*


you should be able to just uninstall it from the Package Manager similar to the freetype library, but if that's not available then do:

CODE
su
rm /opt/QtPalmtop/lib/libpng*


also do

QUOTE
rm /etc/gtk-2.0/*


so the new config files can be generated.
Go to the top of the page
 
+Quote Post
alee16
post Jun 19 2006, 06:33 PM
Post #34





Group: Members
Posts: 113
Joined: 30-May 06
Member No.: 10,009



Thanks! It works just fine now. I was also wondering, is abiword kind of slow in response to taps? Is there a way to make it faster? I think it is because it is getting into the area of swap memory, which drastically slows it down, can I "un-cache" some programs to make it still be within the SDRAM and speed it up, or is abiword just slow because of the different platform it is running on?
Go to the top of the page
 
+Quote Post
Raul
post Jun 19 2006, 08:56 PM
Post #35





Group: Members
Posts: 133
Joined: 10-February 06
Member No.: 9,110



QUOTE(Meanie @ Jun 19 2006, 03:50 AM)
did you rerun pdaXqtrom-base-setup after you run the xqtcleanup script?

If you mean runing install script I have done that. If not, I'm not sure what pdaXqtrom-base-setup do you mean.

Kind regards,
Raul
Go to the top of the page
 
+Quote Post
danboid
post Jun 19 2006, 10:13 PM
Post #36





Group: Members
Posts: 682
Joined: 26-December 05
From: Rochdale, Lancashire
Member No.: 8,789



If you're getting the same error message I was then delete the two sets of files Meanie mentioned and then run pdaXqtrom-base-setup which is under

/home/system/var/mnt/pdaXqtrom-base/

on my installation, at least, that fixed it

I've only had a quick go but Abiword does seem to work, with spell check, in embedded mode but it takes about a minute to load and is very sluggish in operation. You will be amazed at how much faster it loads and how much more responsive X apps like Abiword and Gnumeric are under OZ/GPE or 'real' pdaXrom.

Now I need to know if its possible to install CUPS under Cacko/pdaXqtrom?

dan
Go to the top of the page
 
+Quote Post
Raul
post Jun 20 2006, 06:47 AM
Post #37





Group: Members
Posts: 133
Joined: 10-February 06
Member No.: 9,110



QUOTE(danboid @ Jun 20 2006, 08:13 AM)
/home/system/var/mnt/pdaXqtrom-base/
on my installation, at least, that fixed it

I'm not getting the same error. I tried with pdaXqtrom-base-setup after runing pdaxqtrom-install.sh but it still give the same error. And I did the steps Meanie wrote.
Go to the top of the page
 
+Quote Post
bolbit
post Jun 24 2006, 04:02 AM
Post #38





Group: Members
Posts: 111
Joined: 6-September 05
From: Aix en Provence/Paris
Member No.: 8,048



Hi all,
I recently switch to cako 1.23 full, and intall pdaxqtrom ,i had the same trouble as you about libpng,libgobject and pixbuff.
if you look at the /home/QtPalmtop/lib you should have something like this for these libs :
CODE
lrwxrwxrwx    1 root     root           57 Jun 19 08:27 libgmodule-1.2.so.0 -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libgmodule-1.2.so.0
lrwxrwxrwx    1 root     root           62 Jun 19 08:27 libgmodule-1.2.so.0.0.10 -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libgmodule-1.2.so.0.0.10
lrwxrwxrwx    1 root     root           55 Jun 19 08:27 libgmodule-2.0.so -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libgmodule-2.0.so
lrwxrwxrwx    1 root     qpe            45 Jun 23 16:58 libgmodule-2.0.so.0 -> /home/QtPalmtop/lib/libgmodule-2.0.so.0.800.1
-rwxr-xr-x    1 root     qpe         11332 Aug  9  2003 libgmodule-2.0.so.0.200.1
lrwxrwxrwx    1 root     root           63 Jun 19 08:27 libgmodule-2.0.so.0.800.1 -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libgmodule-2.0.so.0.800.1
lrwxrwxrwx    1 root     qpe            25 Nov  5  2005 libgmodule-2.0.so.0.back -> libgmodule-2.0.so.0.200.1
lrwxrwxrwx    1 root     root           51 Jun 19 08:27 libgmodule.so -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libgmodule.so

for example,there is a existing lib in cacko rom name libgmodule-2.0.so.0.200.1 and libgmodule-1.2.so.0 is linked to this one, pdaxqtrom seems to add libgmodule-2.0.so.0.800.1 but libgmodule-1.2.so.0 stay linked to the cacko one after the pdaxqtrom install. So for the 3 or 4 libs in this case, where an update lib is added by pdaxqtrom (look if the same lib with a .800 or .600 exists linked to the cramfs) i have add .back to the cacko link and linked manualy the pdaxqtrom one. So now everything works under pdaxqtrom. note that if you run ldconfig the original config is restored (for exemple when you install a new app). maybe it is better to remove the cako lib and keep only the one from pdaxqtrom,but i'm not sure about the other qt apps...
Another point is that now opera is not working anymore...
finally,there was this thing in another thread about gdk-pixbuf.loaders
CODE
su
ln -sf /opt/QtPalmtop/lib/gtk-2.0 /usr/lib/gtk-2.0
gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

hope this can help.
any idea why opera is no more working ?
Go to the top of the page
 
+Quote Post

3 Pages V  < 1 2 3
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 07:28 PM