OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> An 802.11 Intermittent Failure Solved, My access point is buggy, but it's OK
post Dec 23 2005, 01:53 AM
Post #1

Group: Members
Posts: 15
Joined: 7-June 05
Member No.: 7,282

I was having strange intermittent problems when using my Zarus with 802.11. It would mostly work, but sometimes communications apps would hang when trying to talk.

The nastiest problem was that I couldn't use TLS with my mailserver -- when I tried, opiemail would hang during the TLS handshake.

The problem turned out to be my access point (I use a Linksys BEF-W11). The access point would sometimes send frames that were too large to fit into the frame size the Z was expecting (1504 bytes, when they should have been 1500). I discovered this when I ran the "dmesg" command on the Z after opiemail hung, so if you suspect something similar is happening, take a look there.

My solution was to add a line to the /etc/network/interfaces file, in the iface wlan0 stanza:

iface wlan0 inet dhcp
       # blah blah blah configuration stuff here

       up ifconfig wlan0 mtu 1508   # This is the line I added

This changes the size of the frame the Z expects to 1508. Shouldn't have to do it. It's not the Z's fault. But it makes everything work.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th November 2017 - 01:34 AM