OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> A Problem With Xfce4
diedwater
post Oct 31 2006, 10:28 AM
Post #1





Group: Members
Posts: 50
Joined: 18-June 06
Member No.: 10,189



my xfce4 seems to be broken or something...at first i set the main menu bar to be auto hide, and it worked pretty nice. but after i restarted the machine, I can't bring up the menu bar anymore...I tried to hook up a mouse, so i can get the curse to the edge of the screen...but the bar still won't show up. and even right click on the desktop won't bring up the menu....this is crazy. anyone know any way to fix this?
Go to the top of the page
 
+Quote Post
InSearchOf
post Oct 31 2006, 11:23 AM
Post #2





Group: Admin
Posts: 1,210
Joined: 20-January 06
From: York, Pennsylvania
Member No.: 8,961



do you use Rox... if so use Rox filer... and navigate to you favorite shell app... once in there... run... killall xf.... crap I forgot and I dont have my Z with me...

Someone with one on hand run a ps -ef | grep xf and determine which on of the app running is the panel menu and post... or just wait till I get home from work... and I will post it...

Late
Go to the top of the page
 
+Quote Post
Chero
post Oct 31 2006, 12:43 PM
Post #3





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



once you have a terminal do a

CODE
ps -ef | grep xf


If "xfce4-panel" is running, you could try to start the "panel manager" from the menu.
CODE
xfdesktop -menu
will bring up the menu, the panel manager is in "settings".

If it's not running, try tro launch it :
CODE
xfce4-panel &

Don't close the terminal, quit the session while saving for next sessions, startxfce4 again. Now you can close the terminal.

Tip : I don't use autohide (no good with stylus) but if I want full-screen, I use "alt-f" which toggles fullscreen/non fullscreen for me. (settings->window manager->keyboard)

Have fun,
Chero.
Go to the top of the page
 
+Quote Post
diedwater
post Oct 31 2006, 04:40 PM
Post #4





Group: Members
Posts: 50
Joined: 18-June 06
Member No.: 10,189



QUOTE(Chero @ Oct 31 2006, 12:43 PM)
once you have a terminal do a

CODE
ps -ef | grep xf


If "xfce4-panel" is running, you could try to start the "panel manager" from the menu.
CODE
xfdesktop -menu
will bring up the menu, the panel manager is in "settings".

If it's not running, try tro launch it :
CODE
xfce4-panel &

Don't close the terminal, quit the session while saving for next sessions, startxfce4 again. Now you can close the terminal.

Tip : I don't use autohide (no good with stylus) but if I want full-screen, I use "alt-f" which toggles fullscreen/non fullscreen for me. (settings->window manager->keyboard)

Have fun,
Chero.
*


once i typed

CODE
Xfce4-panel &


it tells me i need menustart.so cannot be opened, and missing libdbh-1.0.so.1

where can i get those files?
Go to the top of the page
 
+Quote Post
Capn_Fish
post Oct 31 2006, 04:49 PM
Post #5





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Chero's Feed
Go to the top of the page
 
+Quote Post
diedwater
post Nov 1 2006, 03:41 PM
Post #6





Group: Members
Posts: 50
Joined: 18-June 06
Member No.: 10,189



i downloaded couple files from that feed and installed them, and now it just keep poping up things that are missing. i m wondering, if i just reinstall the entire xfce4, would be easier to fix the problem? I don't really want to lose all the settings tho...


btw, whats the command to type when i wanna exist xfce4 to the command line interface?
Go to the top of the page
 
+Quote Post
Chero
post Nov 2 2006, 11:59 AM
Post #7





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



I'm not sure what you are asking right now, but

There are 2 (incompatible) versions of xfce4 around here.
My feed has become a mix of them and therefore not very usefull.

The most recent files are over here. (it's not a feed - download and install)

If you want to add thunar, it's in the "parent dir" of the directory pointed to above - make sure you add libexo as well.

If you installed other things (probably a mixture of both versions), you'd better uninstall them all and restart.

Plugins compiled for xfce4 4.2.2 are not compatible with xfce4 4.4 !!

Your settings : they are saved in ~/.config , backup this dir to save them.

Have fun,
Chero.
Go to the top of the page
 
+Quote Post
svs57
post Nov 21 2006, 06:43 AM
Post #8





Group: Members
Posts: 108
Joined: 7-November 05
From: Russia
Member No.: 8,481



QUOTE(Chero @ Nov 2 2006, 10:59 PM)
I'm not sure what you are asking right now, but

There are 2 (incompatible) versions of xfce4 around here.
My feed has become a mix of them and therefore not very usefull.

The most recent files are over here. (it's not a feed - download and install)

If you want to add thunar, it's in the "parent dir" of the directory pointed to above - make sure you add libexo as well.

If you installed other things (probably a mixture of both versions), you'd better uninstall them all and restart.

Plugins compiled for xfce4 4.2.2 are not compatible with xfce4 4.4 !!

Your settings : they are saved in ~/.config , backup this dir to save them.

Have fun,
Chero.
*

I tried to install xfce4 4.4 from your URL http://users.telenet.be/zaurususer/ipkgs/e...fce4-4.4-beta2/
Only I get white screen smile.gif
(xfce-mcs-manager:19089): xfce-mcs-manager-WARNING **: Module /usr/lib/xfce4/mcs-plugins/exo-preferred-applications-settings.so cannot be opened (libxfce4util.so.2: cannot open shared object file: No such file or directory
....
Next msg a lot times:
(xfce4-tips:19101): Gtk-WARNING **: Loading module theme not found in module_path: "xfce"

( "Loading module theme not found in" I translated from russian)
....
Thunar: error while loading shared libraries: libxfce4util.so.2: cannot open shared object file: No such file or directory
Go to the top of the page
 
+Quote Post
Chero
post Nov 21 2006, 06:52 AM
Post #9





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



QUOTE(svs57 @ Nov 21 2006, 03:43 PM)
QUOTE(Chero @ Nov 2 2006, 10:59 PM)
I'm not sure what you are asking right now, but

There are 2 (incompatible) versions of xfce4 around here.
My feed has become a mix of them and therefore not very usefull.

The most recent files are over here. (it's not a feed - download and install)

If you want to add thunar, it's in the "parent dir" of the directory pointed to above - make sure you add libexo as well.

If you installed other things (probably a mixture of both versions), you'd better uninstall them all and restart.

Plugins compiled for xfce4 4.2.2 are not compatible with xfce4 4.4 !!

Your settings : they are saved in ~/.config , backup this dir to save them.

Have fun,
Chero.
*

I tried to install xfce4 4.4 from your URL http://users.telenet.be/zaurususer/ipkgs/e...fce4-4.4-beta2/
Only I get white screen smile.gif
(xfce-mcs-manager:19089): xfce-mcs-manager-WARNING **: Module /usr/lib/xfce4/mcs-plugins/exo-preferred-applications-settings.so cannot be opened (libxfce4util.so.2: cannot open shared object file: No such file or directory
....
Next msg a lot times:
(xfce4-tips:19101): Gtk-WARNING **: Loading module theme not found in module_path: "xfce"

( "Loading module theme not found in" I translated from russian)
....
Thunar: error while loading shared libraries: libxfce4util.so.2: cannot open shared object file: No such file or directory
*



What are you running on what machine ?

I haven't tested this one on r121, so maybe someone else could lighten things ?

Chero.
Go to the top of the page
 
+Quote Post
diesel1
post Nov 23 2006, 07:53 PM
Post #10





Group: Members
Posts: 94
Joined: 10-December 03
From: Leeds, West Yorkshire.
Member No.: 759



Chero, could this be missing libraries as in this post?


http://www.oesf.org/forums/index.php?showt...254&hl=ldconfig

Diesel1.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 08:25 PM