OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Rotate.sh Ceased Working
Tron
post Mar 27 2007, 05:10 AM
Post #1





Group: Members
Posts: 47
Joined: 28-February 06
Member No.: 9,244



Hello all,

not having used the portrait mode for a while (Borzoi, pdaxii13 with openbox and ROX), I noticed that the screen is no longer rotated. I'm pretty sure it worked before, but I might have changed something I'd better had not done.

Calling "rotate.sh -force" should always rotate the screen, no matter what position is is, right? Well, it flickers a bit but that's it. The only peculiarity I found is when calling chkhinge. I get:

chkhinge: Case open landscape (so far, so good)
Gdk-WARNING **; locale not supported by Xlib
Gdk-WARNING **; cannot set locale modifiers

What does locale have to do with rotating the screen? And if it really does, might I just be missing a certain package?

Thanks in Advance!
Go to the top of the page
 
+Quote Post
jpmatrix
post Mar 27 2007, 06:10 AM
Post #2





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



i already got a problem with rotation not working
it was resolved by a zaurus reboot smile.gif

hth
Go to the top of the page
 
+Quote Post
zi99y
post Mar 27 2007, 07:41 AM
Post #3





Group: Members
Posts: 282
Joined: 9-August 06
Member No.: 10,709



can you rotate with "xrandr -o X" where X is 0 - 3?

Sometimes Xfree gets confused though so quitting and restarting X fixes it.
Go to the top of the page
 
+Quote Post
Tron
post Mar 27 2007, 10:05 AM
Post #4





Group: Members
Posts: 47
Joined: 28-February 06
Member No.: 9,244



QUOTE(zi99y @ Mar 27 2007, 05:41 PM)
can you rotate with "xrandr -o X" where X is 0 - 3?

No, that does nothing. Running it with "--verbose" it claims it is setting the rotation, but doesn't.

QUOTE
Sometimes Xfree gets confused though so quitting and restarting X fixes it.

I already did a reboot, but that did not help either.
Go to the top of the page
 
+Quote Post
svs57
post Mar 27 2007, 11:26 PM
Post #5





Group: Members
Posts: 108
Joined: 7-November 05
From: Russia
Member No.: 8,481



QUOTE(Tron @ Mar 27 2007, 09:05 PM)
QUOTE(zi99y @ Mar 27 2007, 05:41 PM)
can you rotate with "xrandr -o X" where X is 0 - 3?

No, that does nothing. Running it with "--verbose" it claims it is setting the rotation, but doesn't.

QUOTE
Sometimes Xfree gets confused though so quitting and restarting X fixes it.

I already did a reboot, but that did not help either.
*


try
xrandr -o left
xrandr -o normal
Go to the top of the page
 
+Quote Post
Tron
post Apr 4 2007, 06:39 AM
Post #6





Group: Members
Posts: 47
Joined: 28-February 06
Member No.: 9,244



QUOTE(svs57 @ Mar 28 2007, 09:26 AM)
try
xrandr -o left
xrandr -o normal


Nope. However, I really did not hope for it as it is basically the same as 0-3.

Is there any other way I can troubleshoot this? xrandr duly reports that is has set the rotation, but does nothing.

I'm pretty sure it's not a problem of the X system but of the window manager. When I alternatively start up xfce4, it works. It doesn't in openbox.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 11:26 AM