OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )


..bk..
Posted on: Oct 16 2006, 03:32 PM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE
hmm, I set mine to "xterm" in /etc/profile and MidnightCommander works fine, also Kismet runs in color as well.

Cheers
*


hm, i think "xterm" vs "rxvt" doesn't quite make a difference...
  Forum: Angstrom & OpenZaurus · Post Preview: #144135 · Replies: 6 · Views: 2,880

..bk..
Posted on: Oct 16 2006, 08:24 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(Da_Blitz @ Oct 16 2006, 10:15 AM)
i have min set as TERM=linux (i use bootstarp with no X) and it works great with ncmpc with a config to enable color
*


with commenting out the TERM=vt100 line in /etc/profile, TERM is set to "rxvt" by, ha, rxvt. (i use gpe) this works quite ok.

PS: for some console apps the default font size is still to big (vi for instance), so you get garbeld output when wrapping lines around. i have it set to 14, this seems small enough for vi and big enough for me ;-)
  Forum: Angstrom & OpenZaurus · Post Preview: #144102 · Replies: 6 · Views: 2,880

..bk..
Posted on: Oct 16 2006, 08:14 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(Wildherb @ Oct 8 2006, 12:11 PM)
I'm re-installing my apps to an SD card as there is not much space in root but this is taking a very long time (slower memory?) and I'm taking care to do an ipkg-link add for each package. Here is what I get when I try to run kismet. Has anybody got kismet working or is there a version of wellenreiter? There must be some way for GPE users to sniff out wireless networks!

CODE
root@spitz:~# kismet
Server options:  none
Client options:  none
Starting server...
Waiting for server to start before starting UI...
*** glibc detected *** /usr/bin/kismet_server: double free or corruption (!prev): 0x000c2968 ***
======= Backtrace: =========
/lib/libc.so.6[0x40245f18]
/usr/bin/kismet_server[0x8cea4]
/lib/libc.so.6(__libc_start_main+0xbc)[0x401fbc10]
======= Memory map: ========
00008000-000ae000 r-xp 00000000 fe:01 8152       /media/card/usr/bin/kismet_server
000b6000-000b8000 rw-p 000a6000 fe:01 8152       /media/card/usr/bin/kismet_server
000b8000-000e3000 rwxp 000b8000 00:00 0          [heap]
40000000-40019000 r-xp 00000000 03:01 17995      /lib/ld-2.3.90.so
4001c000-4001e000 rw-p 4001c000 00:00 0
40020000-40022000 rw-p 00018000 03:01 17995      /lib/ld-2.3.90.so
40022000-4003b000 r-xp 00000000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
4003b000-40042000 ---p 00019000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
40042000-40044000 rw-p 00018000 fe:01 10156      /media/card/usr/lib/libuClibc++.so.0.1.9
40044000-40048000 rw-p 40044000 00:00 0
40048000-40114000 r-xp 00000000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
40114000-4011b000 ---p 000cc000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
4011b000-40121000 rw-p 000cb000 fe:01 10145      /media/card/usr/lib/libstdc++.so.6.0.3
40121000-40127000 rw-p 40121000 00:00 0
40127000-401cb000 r-xp 00000000 03:01 17992      /lib/libm-2.3.90.so
401cb000-401d2000 ---p 000a4000 03:01 17992      /lib/libm-2.3.90.so
401d2000-401d4000 rw-p 000a3000 03:01 17992      /lib/libm-2.3.90.so
401d4000-401dd000 r-xp 00000000 03:01 18019      /lib/libgcc_s.so.1
401dd000-401e4000 ---p 00009000 03:01 18019      /lib/libgcc_s.so.1
401e4000-401e5000 rw-p 00008000 03:01 18019      /lib/libgcc_s.so.1
401e5000-402e8000 r-xp 00000000 03:01 17988      /lib/libc-2.3.90.so
402e8000-402ef000 ---p 00103000 03:01 17988      /lib/libc-2.3.90.so
402ef000-402f0000 r--p 00102000 03:01 17988      /lib/libc-2.3.90.so
402f0000-402f4000 rw-p 00103000 03:01 17988      /lib/libc-2.3.90.so
402f4000-402f6000 rw-p 402f4000 00:00 0
bec2e000-bec43000 rwxp bec2e000 00:00 0          [stack]
[1] + Aborted                    ${BIN}/kismet_server --silent ${server}
root@spitz:~#

*



the kismet package from the upgrades feed is broken since being linked to _two_ different c++ libs instead of just one. i put a notice in the 3.5.4.x upgrades thread to ask hrw to rebuild it. in the meantime you can use my homebuilt kismet package located here. this is only temporary till the package in the official upgrades feed is fixed...

EDIT: this is now fixed in the upgrades feed, thanks hrw!
  Forum: Angstrom & OpenZaurus · Post Preview: #144101 · Replies: 13 · Views: 3,772

..bk..
Posted on: Oct 16 2006, 08:05 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(Hrw @ Sep 29 2006, 05:26 PM)
Updated:
- scummvm 0.9.0
- kismet 2006-04-R1


hrw,
the kismet package from the upgrades feed is broken. won't start because the binaries are linked to libuclibc++0 _and_ libstdc++6.

here's what happens:
CODE
root@zoe:~# ./kismet_server
*** glibc detected *** ./kismet_server: double free or corruption (!prev): 0x000c2968 ***
======= Backtrace: =========
/lib/libc.so.6[0x40245f18]
./kismet_server[0x8cea4]
/lib/libc.so.6(__libc_start_main+0xbc)[0x401fbc10]
======= Memory map: ========
00008000-000ae000 r-xp 00000000 1f:03 13608      /home/root/kismet_server
000b6000-000b8000 rw-p 000a6000 1f:03 13608      /home/root/kismet_server
000b8000-000e3000 rwxp 000b8000 00:00 0          [heap]
40000000-40019000 r-xp 00000000 1f:02 712        /lib/ld-2.3.90.so
4001d000-4001f000 rw-p 4001d000 00:00 0
40020000-40022000 rw-p 00018000 1f:02 712        /lib/ld-2.3.90.so
40022000-4003b000 r-xp 00000000 1f:02 28870      /usr/lib/libuClibc++.so.0.1.9
4003b000-40042000 ---p 00019000 1f:02 28870      /usr/lib/libuClibc++.so.0.1.9
40042000-40044000 rw-p 00018000 1f:02 28870      /usr/lib/libuClibc++.so.0.1.9
40044000-40048000 rw-p 40044000 00:00 0
40048000-40114000 r-xp 00000000 1f:02 6572       /usr/lib/libstdc++.so.6.0.3
40114000-4011b000 ---p 000cc000 1f:02 6572       /usr/lib/libstdc++.so.6.0.3
4011b000-40121000 rw-p 000cb000 1f:02 6572       /usr/lib/libstdc++.so.6.0.3
40121000-40127000 rw-p 40121000 00:00 0
40127000-401cb000 r-xp 00000000 1f:02 725        /lib/libm-2.3.90.so
401cb000-401d2000 ---p 000a4000 1f:02 725        /lib/libm-2.3.90.so
401d2000-401d4000 rw-p 000a3000 1f:02 725        /lib/libm-2.3.90.so
401d4000-401dd000 r-xp 00000000 1f:02 724        /lib/libgcc_s.so.1
401dd000-401e4000 ---p 00009000 1f:02 724        /lib/libgcc_s.so.1
401e4000-401e5000 rw-p 00008000 1f:02 724        /lib/libgcc_s.so.1
401e5000-402e8000 r-xp 00000000 1f:02 718        /lib/libc-2.3.90.so
402e8000-402ef000 ---p 00103000 1f:02 718        /lib/libc-2.3.90.so
402ef000-402f0000 r--p 00102000 1f:02 718        /lib/libc-2.3.90.so
402f0000-402f4000 rw-p 00103000 1f:02 718        /lib/libc-2.3.90.so
402f4000-402f6000 rw-p 402f4000 00:00 0
bec47000-bec5c000 rwxp bec47000 00:00 0          [stack]
Aborted


i re-built the kismet package myself using the org.openembedded.oz354x branch (but had to add a dependency to ncurses to get it built...) and it works perfectly (since not being linked to two c++ libs).

so could you just rebuild the package, so that other users don't end up with a broken kismet package?

thanks...
  Forum: Angstrom & OpenZaurus · Post Preview: #144099 · Replies: 215 · Views: 58,082

..bk..
Posted on: Oct 10 2006, 05:53 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(iamphet @ Oct 3 2006, 08:43 AM)
Is there a terminfo definition for the OZ console? I tried to keep TERM unset, set it to linux, xterm, rxvt; Midnight Commander doesn't work correctly in any case.
*


there's a line in/etc/profile setting TERM=vt100, comment that out...
  Forum: Angstrom & OpenZaurus · Post Preview: #143626 · Replies: 6 · Views: 2,880

..bk..
Posted on: Oct 8 2006, 07:22 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


can you update the firefox package, please?

see here:
http://www.oesf.org/forums/index.php?showtopic=21570

and here:
http://bugs.openembedded.org/show_bug.cgi?id=1436

thanks for solving this!
  Forum: Angstrom & OpenZaurus · Post Preview: #143454 · Replies: 215 · Views: 58,082

..bk..
Posted on: Sep 27 2006, 06:13 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


hey there,

i'm wondering a bit that noone else came across that issue, since firefox seems to be the only ssl-capable browser for GPE (or am i wrong here ?!?)

firefox is the only app i came to try that refuses fn-key combinations as its input (e.g ':' on a c760). works well if started on a remote display ...

am i the only one? any hints to fix this?

seen on a c760 running OZ 3.5.4.1. GPE ...
  Forum: Angstrom & OpenZaurus · Post Preview: #142460 · Replies: 2 · Views: 3,527

..bk..
Posted on: Aug 30 2006, 03:38 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(zedkatuf2 @ Aug 9 2006, 11:47 AM)
Sorry to be thck, but could you post details of more or less exactly what you did, as I'm slightly at a loss as to which firmware I need for my Ambicom 1100C.

Cheers,

zedkatuf
*


just read http://linux.junsun.net/intersil-prism/ _toroughly_ ;-)
  Forum: Angstrom & OpenZaurus · Post Preview: #140161 · Replies: 9 · Views: 4,839

..bk..
Posted on: Jul 28 2006, 11:35 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(koen @ Jul 21 2006, 10:15 PM)
Yes it does, it uses a different cpu, so I would be surprised if it worked.
*

be suprised, it works ;-)

i just downloaded the modified modules from http://zaurus.aircrack-ng.org/akita , unpacked the ipkgs and copied hostap.ko and hostap_cs.ko over to my z.
made a backup of the original modules and overwrote them. a quick depmod -a did not complain, also the drivers loaded without problems. the rest is described under http://linux.junsun.net/intersil-prism/

happy flashing ;-)
  Forum: Angstrom & OpenZaurus · Post Preview: #136775 · Replies: 9 · Views: 4,839

..bk..
Posted on: Jul 21 2006, 12:30 PM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(koen @ Jul 21 2006, 10:15 PM)
QUOTE(..bk.. @ Jul 21 2006, 08:09 PM)
cool!

i already started to setup my own OE env to build the modded drivers myself, but as it turned out, building sth with OE is a quite nice stress test and after 1,5 days one of my hard drives went into nirvana... i'll give the akita modules a try, despite me owning a c760, but that shouldn't make much of a difference.
*


Yes it does, it uses a different cpu, so I would be surprised if it worked.
*



hm, i thought strongarm (collie) vs. xscale (c7x0) was _really_ different (as it's a different architecture && instruction set), but to me the difference between pxa255 and pxa 270 is more like between i586 and i686, or am i getting sth wrong ?

btw, the *.conf files in OE for c7x0 and akita seem very similar too, both inherit zaurus-clamshell.conf (and in there only some sound stuff is different) ...
  Forum: Angstrom & OpenZaurus · Post Preview: #136040 · Replies: 9 · Views: 4,839

..bk..
Posted on: Jul 21 2006, 12:09 PM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


cool!

i already started to setup my own OE env to build the modded drivers myself, but as it turned out, building sth with OE is a quite nice stress test and after 1,5 days one of my hard drives went into nirvana... i'll give the akita modules a try, despite me owning a c760, but that shouldn't make much of a difference.

thanks a lot...
  Forum: Angstrom & OpenZaurus · Post Preview: #136038 · Replies: 9 · Views: 4,839

..bk..
Posted on: Jul 12 2006, 10:26 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


hi there,

as http://wiki.openzaurus.org/FAQ#WiFi_related_questions states under WPA encryption support, the card's station firmware must be at least 1.7.0 to do WPA.

it further links to a page ( http://linux.junsun.net/intersil-prism ) describing how to update your card's firmware, but not without saying that oz doesn't provide a hostap driver with support for flashing firmwares.

unfortunately, this appears to really be the case: the userspace tool (prism2_srec) is available and able to check for firmware compatibility, but it seems the kernel driver (is this hostap.ko ? or hostap_cs.ko ?) isn't compiled with support for fw flashing.

i can understand this: "we do not want to hear that users bricked their cards by mistake", but in some other way it reduce the freedom of users to willingly update their cards or brick them (if they really like to ;-) ).

i was a bit unsure to report this as a bug, as its a mere feature wish, and i'm not sure if this would ever qualify as a candidate for the 3.5.4.x upgrade feed, so i started a new topic.

to sum this up, i think the most probable solution is someone building a special hostap kernel module with this feature enabled. as i don't have an OE environment and fear a bit setting it up, i carefully ask people that have one to do this. if you have some spare computation time, i (and probably others) would be quite delighted to be able to update their cards to do WPA.

muchas gracias in advance...

PS: i have a c760 with (by now) 3.5.4 installed. think the situations is the same in 3.5.4.1. (at least according to pacthes in OE repo).
  Forum: Angstrom & OpenZaurus · Post Preview: #134883 · Replies: 9 · Views: 4,839

..bk..
Posted on: Jul 9 2006, 01:16 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(zedkatuf2 @ Jul 9 2006, 09:11 AM)
..thanks for the link. Do you have a tar file of the icons you downlaoded, as the only way to get them from the site, it seems is individually sad.gif
*


what about
> wget -r
?
  Forum: Angstrom & OpenZaurus · Post Preview: #134407 · Replies: 44 · Views: 19,301

..bk..
Posted on: May 6 2006, 03:38 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


QUOTE(gepeto @ May 5 2006, 09:44 PM)
I seem to have problems with my SD..
Let's say I am downloading something to it using wget..

Wget just hung on me..
And if I just try to do ls in /media/card - that hangs too...maybe I should use ext2 instead of ext3 right? For speed...I just thought ext3 was a pretty good idea for removable storage..
*


actually the filesystem on your card shouldn't really matter (in terms of functionality), but ext2 is indeed the better choice because a journalling fs like ext3 wears out the flash much faster (and doesn't gain you any real benefits).
  Forum: Angstrom & OpenZaurus · Post Preview: #125940 · Replies: 10 · Views: 2,949

..bk..
Posted on: May 4 2006, 09:05 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


hey,
what about playing doom or zak mac kracken on your zaurus ?
(there's prboom and scummvm...)
ain't that nothing ;-) ?
  Forum: Angstrom & OpenZaurus · Post Preview: #125738 · Replies: 17 · Views: 5,750

..bk..
Posted on: May 1 2006, 07:08 AM





Group: Members
Posts: 16
Joined: 20-March 06
From: /dev/null
Member No.: 9,404


hola!

could you please recompile totem without lirc support or add lirc package ?
totem is only installable with -force-depends, but then complains about missing liblirc.
would be quite nice to have a _gui_ media player for gpe (i know there's mplayer...)

btw: where went gxine ?

thanks a lot !
  Forum: Angstrom & OpenZaurus · Post Preview: #125293 · Replies: 215 · Views: 58,082


New Posts  New Replies
No New Posts  No New Replies
Hot topic  Hot Topic (New)
No new  Hot Topic (No New)
Poll  Poll (New)
No new votes  Poll (No New)
Closed  Locked Topic
Moved  Moved Topic
 

RSS Lo-Fi Version Time is now: 21st November 2017 - 01:37 PM