OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

4 Pages V  < 1 2 3 4 >  
Reply to this topicStart new topic
> Cf Card, Changing the type II for I
baptista
post May 15 2007, 07:59 AM
Post #31





Group: Members
Posts: 53
Joined: 21-July 03
Member No.: 283



Hi sdjf
Thanks for your answer.
I know that I have a long way to go (as the song...) I income in tyranozaurus.com but still donīt have the password they promise...
I would like, in order, to know:
How can I eject the CF card when the applet do not permit.
Why my Targus modem card donīt function now, how to set it
Many other things Iīll go to learn as the time is going, thanks to your patience and the ways you are opening to me.
As a joke: in Brazil the language is portuguese not spanish but really my first language is Spanish...
So long!
Regards from your friend
baptista

PS What is the difference in our time?
Go to the top of the page
 
+Quote Post
sdjf
post May 15 2007, 08:36 AM
Post #32





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



I said one question. We can't solve them both at the same time.

Please be patient, and wait for the next instructions before doing something that might make things worse.

1. I need to know what you have in your CF slot right now, and whether you have your Z attached to your PC now.

2. Run the following tests for me, and copy everything that appears on your screen, including the commands you entered, into a file and post it all here:

cardctl ident
cardctl status

cat /var/lock/LCK..ttyS3

for i in `find /proc -name fd 2>/dev/null`;do p=${i%%/fd} ;q=`basename $p`;cmd=`cat $p/cmdline 2>/dev/null`; ls -l $i 2>/dev/null | grep tty | sed "s|^l.*>|$q $cmd:|" ;done
(there are 4 commands to enter. the final one must be on one long line, starting with "for" and ending with "done"
3. Don't do anything else to the CF card until I see what the output is and can study the situation. I'm sorry I can't solve it all at once, but if I can't see that output, I can't tell you what I would do. And if you take the card out somehow, the situation will change and I will need answers to all of the above all over again. We have to study your problem carefully IMO if we are going to solve it or them in a way you can depend on, instead of always guessing.

I'll check back in a few hours. I'm running behind today.

sdjf

This post has been edited by sdjf: May 15 2007, 12:12 PM
Go to the top of the page
 
+Quote Post
sdjf
post May 15 2007, 12:16 PM
Post #33





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



Any time you cannot eject a card using the GUI, that means that something is holding on to the card. The Zaurus thinks the card is in use and will not let you take it out because of that.

That can happen no matter what kind of CF card is in the slot, but what you can do about it depends on whether it is a data card or a network device, and on the exact nature of the hold it has to the card.

That's why we need to study the situation, to decide why and make an appropriate plan of action. wink.gif

sdjf

p.s. 2-4 hours difference, I'm not sure. this is GMT -700. I can go to chat evening time here, but usually not before 8 or 9 pm. my time, and that's very late for you. I am usually too busy for chat earlier in the evening.
Go to the top of the page
 
+Quote Post
baptista
post May 16 2007, 09:55 AM
Post #34





Group: Members
Posts: 53
Joined: 21-July 03
Member No.: 283



Hi sdjf:Once thanks,Iīm pasting here the answer to the things you asked me in the prior mail.

Opening the documents tab for CF there are 5 folders: Applications,Documents, local, QtPalmtop, Screen files.It has also some books in PDF, musics,and 2 backups I ever have, also appears a file(journal) belonging to Kopi and 2 icons of text Editor:my calendar and std (belonging to Kapi, that is addresses), as I said to you the Kopi and Kapi where installed in the SD card, so I think that this are older files
The folder Applications is empty
The folder Documents have the following folders: Applications,Audio,Chemical,Install_files,Image,Textfiles,Text, have also some files about theSharp Motion Art.

The folder Application have the folders: Excel, Hancomword, Ipkg, msword,octet-stream, portabase, rtf, x-gzip, x-htest, x-msdos-programs.

If you want I can send everythings is on each folder, but you can suppose that is a long list perhaps not interesting for you.

I think is interesting the folder chemical, it was created by a book that a friend of mine send by IRDA ,from their PalmTreo content a file in pdb not possible to open.

Think that you want to know the folder QtPalmtop: it has this others folders:apps, help, pics, bdicty, i-ching, pics 144, bin, i18n, plugins, demo, java, qtmail, dtm, lib, share, etc, man.

About the commands:
Cardctl ident:
Response: Socket0:
Product info: “SanDisk”, “SDP”, “5/3 0,6”
Manfid: 0x0045, 0x0401
Function: 4 (fixed disk)
Socket 1:
No product info available

Cardctl status
Response: Socket 0:
3,3 V 16 bit PC Card
Function 0: (ready), (bat dead), (bat low)
Socket 1:
No card

cat/var/lock/LCK...ttyS3
Response: no such file or directory

About the long command that I repeat many times
Response
>

Excuse me if I delay a little, Iīm learning as never. I passed the hole yesterday working in this

Best regards
baptista
Go to the top of the page
 
+Quote Post
sdjf
post May 16 2007, 12:12 PM
Post #35





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



So, is the problem now that you cannot eject the CF data card?

I am wondering what is holding on to the card. I must see the complete output of "ps ax". I am suspicious that kopi/kapi is using that journal file [EDIT:], and whatever other kopi/kapi files are on your CF card. Can you exit from kopi/kapi (whichever that was) and then try to use the icon to eject the card.

Also, whether or not the card will eject now, I recommend that you install the "lsof" command if you do not have it.

You can see if you have it by entering the "type" command:

bash-2.05# type lsof
lsof is /usr/bin/lsof
bash-2.05#

If you do not have it, the output will be:

bash: type: lsof: not found

You can find information about "lsof" at:

http://www.sdjf.esmartdesign.com/ipks/lsof.html

This post has been edited by sdjf: May 16 2007, 12:26 PM
Go to the top of the page
 
+Quote Post
sdjf
post May 16 2007, 12:22 PM
Post #36





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



I ran out of lines to type on. wink.gif

I need to see "ps ax" run just before you try to eject the card. That will contain the names of any applications that are holding on to it.

Even though kopi/kapi is installed to your SD card, if there is kopi/kapi file on the CF card, kopi/kapi will be reading that file and not let you eject the card.

you have several possible solutions. You can close kopi/kapi (and have to anyhow, I think). Then if you want to prevent the same problem in the future, you should either delete that file or move it to the SD card.

Do you know how to do that? There are many ways and I'm hoping you know how so I don't have to explain.

Will kopi/kapi let you move or delete the file from inside the application before you exit? I think that is the most preferred way.

take care,
sdjf
Go to the top of the page
 
+Quote Post
baptista
post May 16 2007, 12:33 PM
Post #37





Group: Members
Posts: 53
Joined: 21-July 03
Member No.: 283



Hi sdjf:
I donīt have lsof, will see your site. What means "ps ax"?
Tomorrow will delete the file journal, and will write again
Regards from
baptista
Go to the top of the page
 
+Quote Post
sdjf
post May 16 2007, 01:04 PM
Post #38





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



QUOTE(baptista @ May 16 2007, 01:33 PM)
Hi sdjf:
I donīt have lsof, will see your site. What means "ps ax"?
Tomorrow will delete the file journal, and  will write again
Regards from
baptista
*

"ps ax" is the command you gave me the output from in post #14 in this current thread on page 1. I tried to put the url in but the board wouldn't accept it. Anyhow, it's just a command:
bash-2.05# ps ax

I have less time for the next 3 days but I'll try to check back at least once or twice each day.

You don't have to post the results of "ps ax" unless the card still does not eject after removing all kopi/kapi files from the CF card.

sdjf
Go to the top of the page
 
+Quote Post
baptista
post May 17 2007, 11:11 AM
Post #39





Group: Members
Posts: 53
Joined: 21-July 03
Member No.: 283



Hi sdjf:
As ever till now you had the reason...well I deleted the 2 famous files relationed with kopi and kapi, and everything is going ok. Also I installed the lsof command and chek the CF card, nothing open. Excuse me how many headache i gave to you, but I learned many things.
Now donīt strange the fact that I visit your site frequently for learning more.

Again a thing more, the question of modem card, as I said to you is a Pocket modem card 56K V.90 brand TARGUS In the userīs Guide they say that work with Windows CE and Pocket PC. In fact I use it, perhaps with 2.38 ROM, I donīt remember, and receive many mails. Iīll try to use again now changing the settings of the modem, now are ATDT.

You said to me that only use the collie for everythings, and what happens with the battery?

Hope you had time enough for solving your questions. Nevertheless I feel that I win a friend in USA,would like to know the city.Anything that you want from São Paulo, Brazil, take me in account.
My best regards from your friend
baptista
Go to the top of the page
 
+Quote Post
sdjf
post May 17 2007, 03:24 PM
Post #40





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



If the modem worked on 2.38, I'm sure you can get it to work on 3.13, but it may be difficult because you also want to be able to sync to your windows box. Again, you ask so many questions, I am needing to focus on just one.

I think the modem is the next important thing. But I need to know the current status of your collie, and what goes wrong, and get all the same information all over again before and after you try the modem.

But one more thing. If it is your dialup modem, I also need to see the output of an "cat /tmp/qpe-pppd-log" to figure out what is wrong. But also all the other answers I will need again as well so that we can study the situation.

take care,
sdjf
Go to the top of the page
 
+Quote Post
baptista
post May 18 2007, 11:59 AM
Post #41





Group: Members
Posts: 53
Joined: 21-July 03
Member No.: 283



Hi sdjf:
I think everythyng is ok with the collie now.
The response of the terminal to the command you said is
"no such file or directorie"
Regards
baptista
Go to the top of the page
 
+Quote Post
sdjf
post May 18 2007, 01:30 PM
Post #42





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



Here is a tip for you and anyone else who posts output from a command.

IMNSHO, it is very helpful and important to show exactly what the command you entered is, as well as the results. It makes debugging a lot easier for those of us trying to problem solve with you.

So, although I can guess what command you entered to get "no such file or directory", I cannot be sure, and if you made a typo in entering the command (and we all do sometimes wink.gif ), the readers have no way to determine that.

So Please, next time, make your output something more like:

bash-2.05# cat myfile
cat: myfile: No such file or directory
bash-2.05#

Your collie is fine now, but I have a hunch you may have trouble with it a couple times after the next time you use Opera, so be prepared to post all the output I've asked for before, the next time there is a problem with your WIFI or modem (if there is one).

Have a good weekend,
sdjf
Go to the top of the page
 
+Quote Post
baptista
post May 19 2007, 11:48 AM
Post #43





Group: Members
Posts: 53
Joined: 21-July 03
Member No.: 283



Hi sdjf:
Excuse me again, I don't make well the things as you say, I don't leave a space between the cat and the following commands. Well I do

bash-2.05$ cat /tmp/qpe-pppd-log
May 18 18:53:50 localhost pppd[2274]: pppd 2.4.0 started by root, uid 0
May 18 18:53:51 localhost chat[2276]: abort on (NO CARRIER)
May 18 18:53:51 localhost chat[2276]: abort on (NO DIALTONE)
May 18 18:53:51 localhost chat[2276]: abort on (BUSY)
May 18 18:53:51 localhost chat[2276]: send (ATZ^M)
May 18 18:53:51 localhost chat[2276]: expect (OK)
May 18 18:53:51 localhost chat[2276]: ATZ^M^M
May 18 18:53:51 localhost chat[2276]: OK
May 18 18:53:51 localhost chat[2276]:
-- got it
May 18 18:53:51 localhost chat[2276]: send (ATZG^M)
May 18 18:53:51 localhost chat[2276]: expect (OK)
May 18 18:53:51 localhost chat[2276]: ^M
May 18 18:53:51 localhost chat[2276]: ATZG^M^M
May 18 18:53:51 localhost chat[2276]: OK
May 18 18:53:51 localhost chat[2276]:
-- got it
May 18 18:53:51 localhost chat[2276]: send (ATDT9,30095007^M)
May 18 18:53:51 localhost chat[2276]: expect (CONNECT)
May 18 18:53:51 localhost chat[2276]: ^M
May 18 18:54:22 localhost chat[2276]: ATDT9,30095007^M^M
May 18 18:54:22 localhost chat[2276]: CONNECT
May 18 18:54:22 localhost chat[2276]:
-- got it
May 18 18:54:22 localhost pppd[2274]: Serial connection established.
May 18 18:54:22 localhost pppd[2274]: using channel 9
May 18 18:54:22 localhost pppd[2274]: Using interface ppp0
May 18 18:54:22 localhost pppd[2274]: Connect: ppp0 <--> /dev/ttyS3
May 18 18:54:41 localhost pppd[2274]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x7f5589f8> <pcomp> <accomp>]
May 18 18:54:41 localhost pppd[2274]: Timeout 0x20084bc:0x203b440 in 3 seconds.
May 18 18:54:44 localhost pppd[2274]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x7f5589f8> <pcomp> <accomp>]
May 18 18:54:44 localhost pppd[2274]: Timeout 0x20084bc:0x203b440 in 3 seconds.
May 18 18:54:47 localhost pppd[2274]: rcvd [LCP ConfReq id=0x1 < 00 04 00 00> <mru 1100> <asyncmap 0xa0000> <auth pap> <pcomp> <accomp> <mrru 1100> <endpoint [MAC:00:d0:52:03:b7:c8]>]
May 18 18:54:47 localhost pppd[2274]: lcp_reqci: rcvd unknown option 0
May 18 18:54:47 localhost pppd[2274]: lcp_reqci: returning CONFREJ.
May 18 18:54:47 localhost pppd[2274]: sent [LCP ConfRej id=0x1 < 00 04 00 00> <mrru 1100>]
May 18 18:54:47 localhost pppd[2274]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x7f5589f8> <pcomp> <accomp>]
May 18 18:54:47 localhost pppd[2274]: rcvd [LCP ConfReq id=0x2 <mru 1100> <asyncmap 0xa0000> <auth pap> <pcomp> <accomp> <endpoint [MAC:00:d0:52:03:b7:c8]>]May 18 18:54:47 localhost pppd[2274]: lcp_reqci: returning CONFACK.
May 18 18:54:47 localhost pppd[2274]: sent [LCP ConfAck id=0x2 <mru 1100> <asyncmap 0xa0000> <auth pap> <pcomp> <accomp> <endpoint [MAC:00:d0:52:03:b7:c8]>]May 18 18:54:47 localhost pppd[2274]: Untimeout 0x20084bc:0x203b440.
May 18 18:54:47 localhost pppd[2274]: sent [PAP AuthReq id=0x1 user="f.burgos" password=<hidden>]
May 18 18:54:47 localhost pppd[2274]: Timeout 0x200ebbc:0x203b6e0 in 3 seconds.
May 18 18:54:47 localhost pppd[2274]: rcvd [PAP AuthNak id=0x1 ""]
May 18 18:54:47 localhost pppd[2274]: PAP authentication failed
May 18 18:54:47 localhost pppd[2274]: sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]
May 18 18:54:47 localhost pppd[2274]: Timeout 0x20084bc:0x203b440 in 3 seconds.
May 18 18:54:47 localhost pppd[2274]: rcvd [LCP TermAck id=0x2]
May 18 18:54:47 localhost pppd[2274]: Untimeout 0x20084bc:0x203b440.
May 18 18:54:47 localhost pppd[2274]: Connection terminated.
May 18 18:54:48 localhost pppd[2274]: Exit.

As you can see I'll try by myself to connect via modem card.....I beg your pardon, still don't know how to set the modem. Well I think is better no speak more...wait your words. But it is interesting to know that I don't sync the mails wit windows box.

My best regards
baptista
Go to the top of the page
 
+Quote Post
sdjf
post May 19 2007, 09:07 PM
Post #44





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



[QUOTE=baptista] As you can see I'll try by myself to connect via modem card.....I beg your pardon, still don't know how to set the modem. [/QUOTE=baptista]

Hmmm. Didn't you say that you have used the modem before with this ROM? It sounds like it didn't like your password. Did you use the Internet Wizard GUI to set it up? Are you sure you have your login ID and password correct?

I sometimes have this kind of Authentication problem when not enough time is allowed, but I don't see any timeouts. Also, sometimes there is a problem at the ISP end, or once they didn't get my payment. Did you pay your bill on time? wink.gif

[QUOTE=baptista] But it is interesting to know that I don't sync the mails wit windows box. [/QUOTE=baptista]

Please explain. I don't understand what you're trying to tell me about syncing.

Oh, no problem with the spaces. Your pasting was fine, except you left out the final bash$ afterwards. I like to see that too, so I'm sure I've got all the output. wink.gif

sdjf
Go to the top of the page
 
+Quote Post
sdjf
post May 19 2007, 10:15 PM
Post #45





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



Hi baptista!

I'm sorry. I was too tired and didn't study your output carefully enough. There was a timeout problem, so we need to change some settings so that doesn't happen. 3 seconds is not enough time for a sloww ISP. wink.gif

If your networking configuration files are the same on 3.13 as on 2.38, then the following should help me see your settings. I used "grep -Ev password" so you would not post your password publicly. Be sure that it doesn't appear in anything you post, so examine your post before you push the button here. smile.gif

grep -l 30095007 /etc/ppp/peers/* | tee greppeersfiles | xargs cat
cat greppeersfiles
grep -l 30095007 Applications/Network/modules/* | tee modulesfile | xargs cat | grep -Ev password
cat modulesfile
rm greppeersfiles modulesfile # removes unnecessary files you just created

I want to compare your dialup settings with mine.

Also, do you know how to use vi? It may be easier to explain the changes than with the GUI if you do know how to use it. If you don't, do not worry. I'll figure out which GUI setting to change if we need to do it that way.

sdjf

EDIT: Please I also need to see the output from step #2 commands in post #32, that you get just before the next time you try to use the modem. You could try it again and run these commands without changing any settings.

This post has been edited by sdjf: May 19 2007, 10:33 PM
Go to the top of the page
 
+Quote Post

4 Pages V  < 1 2 3 4 >
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 07:05 AM