OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Gpsdrive And Gpe-shield Packaged, Try them please.
Xromer
post Mar 1 2006, 02:43 PM
Post #1





Group: Members
Posts: 178
Joined: 25-February 06
From: Rome Italy
Member No.: 9,229



Tonight i'm working on cross-compiling to try to understand and fix many PRGS of GPE and GTK.
Hope could help. laugh.gif
Let me know related issues.
BYEZ!

P.S. Remember to install pcre_5.0_armv5tel.ipk from the PDAXROM FEED before gpsdrive
Attached File(s)
Attached File  gpsdrive_2.10pre2_armv5tel.ipk ( 1.58MB ) Number of downloads: 345
Attached File  gpe_shield_0.9_armv5tel.ipk ( 21.58K ) Number of downloads: 149
 
Go to the top of the page
 
+Quote Post
Antikx
post Mar 1 2006, 03:42 PM
Post #2





Group: Members
Posts: 1,156
Joined: 5-January 05
From: Winnipeg, Manitoba
Member No.: 6,127



Cool. I wish I had a GPS unit.
What is gpe-shield? Googling it gives me squat.
Go to the top of the page
 
+Quote Post
Xromer
post Mar 2 2006, 03:46 AM
Post #3





Group: Members
Posts: 178
Joined: 25-February 06
From: Rome Italy
Member No.: 9,229



QUOTE(Antikx @ Mar 2 2006, 12:42 AM)
Cool. I wish I had a GPS unit.
What is gpe-shield? Googling it gives me squat.
*

GPE-Shield is a firewall manager for GPE, logically you have to install iptables first otherwise it segfaults.
Look at gpsd support first buying a GPS gadget, as GPSDRIVE is GPSD daemon based.
Have fun!
BYEZ!! laugh.gif
Go to the top of the page
 
+Quote Post
Glorin
post Mar 2 2006, 04:10 AM
Post #4





Group: Members
Posts: 23
Joined: 16-May 05
From: Moscow
Member No.: 7,148



GPSDRIVER after 3-5 seconds go to Segmentation fault.
I run it without GPSD and my cf gps
Last string with debug mode It is night
Go to the top of the page
 
+Quote Post
Xromer
post Mar 2 2006, 12:27 PM
Post #5





Group: Members
Posts: 178
Joined: 25-February 06
From: Rome Italy
Member No.: 9,229



QUOTE(Glorin @ Mar 2 2006, 01:10 PM)
GPSDRIVER after 3-5 seconds go to Segmentation fault.
I run it without GPSD and my cf gps
Last string with debug mode It is night
*


UHM.... strange i installed it with GPSD and i played for 1 or 2 minuts.
I made GPSD start from GPSDRIVE and all worked.
After starting GPSD the arrow as changed simulating the search of a track.
Try to install GPSD too and make it start disrectly from GPSDRIVE.
Let me know, this and GPE PIM is one of the thing i want the Zaurus to run.
It' s necessary for me. Saturday afternoon i will work on this features
BYEZ!
:-)
Go to the top of the page
 
+Quote Post
Glorin
post Mar 2 2006, 01:29 PM
Post #6





Group: Members
Posts: 23
Joined: 16-May 05
From: Moscow
Member No.: 7,148



So i try run it with GSPD without GPS CARD and catch fault
And i try twice with GPSD runed from GPSDRIVE and with GPSD runed for console and get same result.
So if u compile GPE PIM i test it smile.gif
And there i get sources gpsdrive ? i try find problem
Go to the top of the page
 
+Quote Post
Xromer
post Mar 3 2006, 01:27 AM
Post #7





Group: Members
Posts: 178
Joined: 25-February 06
From: Rome Italy
Member No.: 9,229



QUOTE(Glorin @ Mar 2 2006, 10:29 PM)
So i try run it with GSPD without GPS CARD and catch fault
And i try twice with GPSD runed from GPSDRIVE and with GPSD runed for console and get same result.
So if u compile GPE PIM i test it smile.gif
And there i get sources gpsdrive ? i try find problem
*


I got it! You run as root and me not. This is the difference.
Do not tell me why but if you run as run it segfaults as your behaviour.
Try xterm and run it as a Normal User, it will not segfaults and will run gpsd wihout any problems.
This is how you can do:
1) xterm
2) export DISPLAY=:0
3) su - NormalUser -c gpsdrive
4) After that i saw gpsd looking for devices in xterm and no segfaults
5) Probably is something related on permmissions, i suppose or GPSD called as root, as it segfaults calling the daemon.
Consider i' m running all as normal user to not do errors corrupting the ROM packages.
Tomorrow i will repackage GPE PIM and all GPE related stuff working on the Family 0.8.3 sources where i found the GPSDRIVE source, I.E. FM SRC 0.8.3
If they segfault on the import again i will change the file-selection call to another from programs working.
THX for your interest and help, bye. laugh.gif
Go to the top of the page
 
+Quote Post
DaddyGeek
post Mar 10 2006, 07:05 PM
Post #8





Group: Members
Posts: 17
Joined: 10-March 06
Member No.: 9,341



QUOTE(Xromer @ Mar 3 2006, 03:27 AM)
QUOTE(Glorin @ Mar 2 2006, 10:29 PM)
So i try run it with GSPD without GPS CARD and catch fault
And i try twice with GPSD runed from GPSDRIVE and with GPSD runed for console and get same result.
So if u compile GPE PIM i test it smile.gif
And there i get sources gpsdrive ? i try find problem
*


I got it! You run as root and me not. This is the difference.
Do not tell me why but if you run as run it segfaults as your behaviour.
Try xterm and run it as a Normal User, it will not segfaults and will run gpsd wihout any problems.
This is how you can do:
1) xterm
2) export DISPLAY=:0
3) su - NormalUser -c gpsdrive
4) After that i saw gpsd looking for devices in xterm and no segfaults
5) Probably is something related on permmissions, i suppose or GPSD called as root, as it segfaults calling the daemon.
Consider i' m running all as normal user to not do errors corrupting the ROM packages.
Tomorrow i will repackage GPE PIM and all GPE related stuff working on the Family 0.8.3 sources where i found the GPSDRIVE source, I.E. FM SRC 0.8.3
If they segfault on the import again i will change the file-selection call to another from programs working.
THX for your interest and help, bye. laugh.gif
*




The other thing was I had to do a chmod a+rw /dev/ttyS3 (the device for my CF GPS) before it could read from the GPS.


So, not nice but certainly useable.

Now I just need to get the USB networking running so I can download the maps while the GPS is plugged in...

(Of course the CD is nowhere to be found...)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th July 2014 - 02:16 AM