OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

5 Pages V   1 2 3 > »   
Reply to this topicStart new topic
> Kino2 0.4.3 Series Released
maslovsky
post Sep 7 2005, 03:26 AM
Post #1





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



Visit http://cacko.biz/kino2 and remember that donations are always welcome smile.gif

Version 0.4.3c is out!

Version 0.4.3c is yet another small update, including:

* Fixed broken Double Key functionality

Version 0.4.3b is out!

Version 0.4.3b is another small update, including:

* Better handling of OGG Vorbis tags

Version 0.4.3a is a small update, including:

* Better scaling of movies, especialy small ones (less than 320x240)
* Always using direct rendering, so corresponding option is removed
* Added Software scaling option - scale movies to the screen size, performance is poor though.
* Updated smarp cropping algorithm

--------------------------
Version 0.4.3 is out!

Please, report bugs at http://cacko.biz/cacko/bugs

New features:

* Support for the latest mplayer 1.1.5 and PXA270 video driver (aka bvdd) 0.4.0
* C3000/C1000/C3100 devices support
* Kino2 can now load and play play file, playlist, folder or URL when invoked from Documents
* Kino2 now supports command line parameter - file name, URL, folder or playlist can be specified
* Multi-key support - different fuction depending on number of Remote Control button clicks (double click)
* Playback position can be controlled with silder
* Dislpay album picture if present in playlist directory
* Added font selection for the main display

New options:

* Enable position tracking
* Enable suspend when paused
* Temporarly disable suspend when closing lid (on C1000/C3000/C3100)
* Grab keyboard during playback
* Software volume control
* Enable fade effects
* Enable audio autosync
* Enable precise MP3 seeking
* Volume step is user configurable
* Save current position in playlist and in file (only when autoloading)

New keys:

* Clear Playlist
* Add All to Playlist
* LCD off

Issues resolved:

* URLs are now properly saved and loaded with playlist
* Fixed problem with suspend options not being properly restored
* File was not selected with OK/Enter button on C1000
* Refreshing Qtopia screen after mplayer video playpack is finished
* Now kino2 is using much less CPU when playback position tracking is enabled

Misc changes:

* Terminating mplayer process when too many errors are received during short time period
* Made resample audio off by default
* Prompting to restart Qtopia when remocom master is modified
* Updated handling of blank LCD when switched off externaly
* Minor updates to the Preferences dialog
* Removed some absolete options
Go to the top of the page
 
+Quote Post
the_oak
post Sep 7 2005, 07:02 AM
Post #2





Group: Members
Posts: 426
Joined: 10-February 04
From: Virginia, USA
Member No.: 1,794



Your webpage says:
QUOTE
For 5600, 6000 and C7x0/860: mplayer-bvdd_1.1.5-1_arm.ipk


But when I install that mplayer version, kino2 complains that I am missing dependency of mplayer-w100. It works fine with mplayer-w100 though. Thanks!
Go to the top of the page
 
+Quote Post
maslovsky
post Sep 7 2005, 07:45 AM
Post #3





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



QUOTE(the_oak @ Sep 7 2005, 06:02 PM)
Your webpage says:
QUOTE
For 5600, 6000 and C7x0/860: mplayer-bvdd_1.1.5-1_arm.ipk


But when I install that mplayer version, kino2 complains that I am missing dependency of mplayer-w100. It works fine with mplayer-w100 though. Thanks!
*



Disable Cacko feed before installing kino2 package.
Go to the top of the page
 
+Quote Post
Lutz-W.
post Sep 7 2005, 07:47 AM
Post #4





Group: Members
Posts: 27
Joined: 6-December 04
From: Germany
Member No.: 5,799



Hello Anton,

you make a good job. But I have a little problem with my C760.

CODE
# ipkg install kino2_0.4.3_arm.ipk
ipkg_install_file: ERROR: kino2 depends on the following uninstalled programs:
        mplayer-w100
ipkg_install_file: You may want to use `ipkg install' to install these.


The current MPlayer is also for the Zaurus C7x0/860 the file mplayer-bvdd_1.1.5-1_arm.ipk.- Or did I understand that wrongly?
In the control file from kino2_0.4.3_arm.ipk no dependence is contained.
Where is the problem?

Workaround:
In order to be able to install the current version, I installed mplayer-w100 again,
then I installed Kino2, then I removed mplayer-w100 and installed mplayer-bvdd.

And the current version of Kino2 runs.

Regards
Lutz

Edit: I was too slow, Anton have a better workaround.
Go to the top of the page
 
+Quote Post
daniel3000
post Sep 8 2005, 01:21 AM
Post #5





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



Great! Thanks, Maslovsky, for making that available!

However, still the same problem as above:
Many of my video files are not played full-screen, but probably in their original resolution (although I have the "scale to screen" feature activated).

The info windows shows for one of these videos:

Video:
Size: 384x288
Codec: 0x10000001
Bitrate: 1151200
FPS: 25

Audio:
Codec: mad
Rate: 44100
Bitrate: 224000
Channels: 2


Well, this was with some attempts before.
When I now try again to play some of such files, the screen fades white and some horizontal stripes ( lines appear and nothing happens... I have to press "Cancel" twice to exit Kino2 and return to the QTopia GUI.
What happens there?
Edit: When I reboot, the video plays again, but only once. After that, I have again that white-fading screen with lines or pixels getting black slowly. Could something break the loaded bvdd driver or something?
Any recommended mplayer options to make it work properly?


Thanks
daniel
Go to the top of the page
 
+Quote Post
ken
post Sep 8 2005, 02:05 AM
Post #6





Group: Members
Posts: 274
Joined: 17-October 04
Member No.: 5,063



Works great when it's in landscape mode, all the screens show up fine, however, when it's in portrait mode, the configuration screens are cut off on the right side.

Had hoped to have the playlist reloaded when starting up, but noticed there's no option available to have that done?

(Sharp ROM, 6K)
Go to the top of the page
 
+Quote Post
willgan
post Sep 8 2005, 04:04 AM
Post #7





Group: Members
Posts: 84
Joined: 9-December 04
From: KL, Malaysia
Member No.: 5,869



are you going to release a bvdd iwmmx version?
Go to the top of the page
 
+Quote Post
maslovsky
post Sep 8 2005, 05:23 AM
Post #8





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



QUOTE(daniel3000 @ Sep 8 2005, 12:21 PM)
Video:
Size: 384x288


Mplayer cannot scale such videos...
Go to the top of the page
 
+Quote Post
maslovsky
post Sep 8 2005, 05:25 AM
Post #9





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



QUOTE(ken @ Sep 8 2005, 01:05 PM)
Works great when it's in landscape mode, all the screens show up fine, however, when it's in portrait mode, the configuration screens are cut off on the right side.


Yes, I noticed that, but that would require to rework all preferences dialogs...
In the next verisno maybe smile.gif

QUOTE
Had hoped to have the playlist reloaded when starting up, but noticed there's no option available to have that done?



Playlist->Save current playlist
Go to the top of the page
 
+Quote Post
maslovsky
post Sep 8 2005, 05:25 AM
Post #10





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



QUOTE(willgan @ Sep 8 2005, 03:04 PM)
are you going to release a bvdd iwmmx version?
*


Have you tried installing this package?

http://cacko.oesf.org/downloads/kino2/mpla...1.1.5-1_arm.ipk
Go to the top of the page
 
+Quote Post
daniel3000
post Sep 8 2005, 06:53 AM
Post #11





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



QUOTE(maslovsky @ Sep 8 2005, 03:23 PM)
QUOTE(daniel3000 @ Sep 8 2005, 12:21 PM)
Video:
Size: 384x288


Mplayer cannot scale such videos...
*



hmmm - on my Linux desktop it can!
Or maybe it does not actively scale them but zooms them - I don't know.
What I am quite sure about is that mplayer does not switch the X-server resolution on my desktop.
(If I hit the "f" key for fullscreen, I think using -vo sdl or -vo xv on my desktop, this particular video _is_ shown in fullscreen).

So why doesn't it do it on the zaurus?

thanks


daniel
Go to the top of the page
 
+Quote Post
maslovsky
post Sep 8 2005, 12:39 PM
Post #12





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



Performance of Zaurus is incmparable to your linux desktop. You can do a software scaling (add -scale 640:480 option to the mplayer) and see the difference.

-fs and -wm options enable hardware scaling in mplayer, which can only handle videos of "proper" sizes, such as 320:240.

You can also try to enable "Smart crop" iption, it may help.
Go to the top of the page
 
+Quote Post
shreks
post Sep 8 2005, 04:05 PM
Post #13





Group: Members
Posts: 47
Joined: 12-January 05
Member No.: 6,203



QUOTE(maslovsky @ Sep 7 2005, 11:26 AM)
Visit http://cacko.biz/kino2

Version 0.4.3 is out!



I tried the latest kino2 and I think I've found one important bug about displaying the tag info of music files:

When I used kino2 to play some OGG and FLAC files, which are correctly tagged with artist, album, track, genre, year, etc informations (UTF-8 encoding of course), kino2 cannot display these information at all by showing blank at all these fileds. However these information of all MP3 songs with UTF-8 tags can be shown correctly, even for the Asian songs that I have, as long as correct font is selected.

So I think probably the display of the tag information of OGG and FLAC were left out, right? Can this bug be fixed soon?

Also I found out another minor bug: everytime when I tried to open a song, if I clicked the UP icon located at the right-most place of the open-file dialog, the directory will jump to the top Document directory. Then I had to clicked several times to go back to the place where I were before.

Thanks a lot!
Go to the top of the page
 
+Quote Post
speculatrix
post Sep 9 2005, 04:40 AM
Post #14





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



what's the best version of kino/mplayer for the 760/860, as these have the ATI W100 Imageon chip... i..e should I install the mplayer bvdd version or not?
Go to the top of the page
 
+Quote Post
daniel3000
post Sep 9 2005, 05:09 AM
Post #15





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



Hello Maslowsky,

QUOTE(maslovsky @ Sep 8 2005, 10:39 PM)
Performance of Zaurus is incmparable to your linux desktop. You can do a software scaling (add  -scale 640:480 option to the mplayer) and see the difference.

-fs and -wm options enable hardware scaling in mplayer, which can only handle videos of "proper" sizes, such as 320:240.

You can also try to enable "Smart crop" iption, it may help.
*



Thanks for the explanation, and especially thanks for the tip with smartcrop. It did the trick! Now I can view those videos full-screen without transcoding!

However, exiting mplayer caused kino and then even the QTopia GUI to not display some elements (missing buttons and icons). Even after exiting kino, the QTopia GUI is damaged. The remaining icons (taskbar icons) work. But the system tray and start menu etc. are gone.

Restarting kino shows kino correctly. QTopia still damaged.

Tapping where the start menu icon should be brings up the start menu, so function of the GUI is still intact, only display is damaged.
Clicking away the start menu again shows half of the start menu icon (where the menu overlapped the icon), so according to my GUI knowledge <g> it seems to be a missing screen refresh or something like that.
Yes: "Rotation" from the start menu rotates the GUI and all items are shown again.

Just FYI, nothing critical as it seems, but maybe it is a problem of kino.

Thanks!
daniel
Go to the top of the page
 
+Quote Post

5 Pages V   1 2 3 > » 
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 07:49 AM