OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Bitbake For Single File-----openvpn
yanyan
post Dec 4 2006, 09:35 AM
Post #1





Group: Members
Posts: 7
Joined: 27-November 06
Member No.: 12,814



I want to compile the openvpn for my SL5500. I install the OE bitbake for this purpose. When I run bitbake everything is all right.
CODE
DL_DIR="/stuff/source"
BBFILES:="/stuff/org.openembedded.dev/packages/*/*.bb"

TARGET_OS="Linux"
TARGET_ARCH="arm"
TARGET_FPU="soft"

MACHINE="collie"
#DISTRO= "openzaurus-3.5.4"
DISTRO="openzaurus-unstable"
#DISTRO_VERSION = "3.5.4"

INHERIT = "package_ipk"
IMAGE_FSTYPES= "jfffs2 tar"
BBINCLUDELOGS="yes"

PREFERRED_PROVIDERS="virtual/qte:qte virtual/libqpe:libqpe-opie"
PREFERRED_PROVIDERS+= "virtual/libsdl:libsdl-qpe"
ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"

I use DISTRO="openzaurus-unstable" because under /stuff/org.openembedded.dev/conf/dist/ there is only openzaurus-unstable.conf but not the openzaurus-3.5.4.conf. am I right?

The first time I run
bitbake -b /stuff/org.openembedded.dev/packages/openvpn/openvpn_2.0.2.bb

It generates the ipk under /stuff/build/conf/tmp/deploy. I copy to my Z, but when I use ipkg to install it responds that invalid image. How can I solve this?

so I modidied the local.conf a bit, using DISTRO= "openzaurus-3.5.4" instead of
DISTRO="openzaurus-unstable" and I also find openzaurus-3.5.4.conf from the internet and put it into the path.

but the second time I bitbake openvpn it fails. error message is

CODE
NOTE: package openvpn-2.0.2-r0: task do_configure: started
NOTE: SITE files /stuff/org.openembedded.dev/site/endian-little /stuff/org.openembedded.dev/site/arm-linux
ERROR: function do_configure failed
ERROR: log data follows (/stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/log.do_configure.4100)
| /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/run.do_configure.4100: line 565: automake: command not found
| /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/run.do_configure.4100: line 566: automake: command not found
NOTE: Task failed: /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/log.do_configure.4100
NOTE: package openvpn-2.0.2-r0: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package openvpn-2.0.2: failed
ERROR: Build of 'openvpn' failed
Build statistics:
 Attempted builds: 1
 Failed builds: 1


Thanks a lot, can someone gives me suggestions?
Go to the top of the page
 
+Quote Post
hvontres
post Dec 4 2006, 09:39 AM
Post #2





Group: Members
Posts: 118
Joined: 12-May 05
From: Oceanside,Ca
Member No.: 7,121



QUOTE(yanyan @ Dec 4 2006, 10:35 AM)
I want to compile the openvpn for my SL5500. I install the OE bitbake for this purpose. When I run bitbake everything is all right.
CODE
DL_DIR="/stuff/source"
BBFILES:="/stuff/org.openembedded.dev/packages/*/*.bb"

TARGET_OS="Linux"
TARGET_ARCH="arm"
TARGET_FPU="soft"

MACHINE="collie"
#DISTRO= "openzaurus-3.5.4"
DISTRO="openzaurus-unstable"
#DISTRO_VERSION = "3.5.4"

INHERIT = "package_ipk"
IMAGE_FSTYPES= "jfffs2 tar"
BBINCLUDELOGS="yes"

PREFERRED_PROVIDERS="virtual/qte:qte virtual/libqpe:libqpe-opie"
PREFERRED_PROVIDERS+= "virtual/libsdl:libsdl-qpe"
ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"

I use DISTRO="openzaurus-unstable" because under /stuff/org.openembedded.dev/conf/dist/ there is only openzaurus-unstable.conf but not the openzaurus-3.5.4.conf.  am I right?

The first time I run
bitbake -b /stuff/org.openembedded.dev/packages/openvpn/openvpn_2.0.2.bb

It generates the ipk under /stuff/build/conf/tmp/deploy. I copy to my Z, but when I use ipkg to install it responds that invalid image. How can I solve this?

so I modidied the local.conf a bit, using DISTRO= "openzaurus-3.5.4" instead of
DISTRO="openzaurus-unstable" and I also find openzaurus-3.5.4.conf from the internet and put it into the path.

but the second time I bitbake openvpn it fails. error message is

CODE
NOTE: package openvpn-2.0.2-r0: task do_configure: started
NOTE: SITE files /stuff/org.openembedded.dev/site/endian-little /stuff/org.openembedded.dev/site/arm-linux
ERROR: function do_configure failed
ERROR: log data follows (/stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/log.do_configure.4100)
| /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/run.do_configure.4100: line 565: automake: command not found
| /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/run.do_configure.4100: line 566: automake: command not found
NOTE: Task failed: /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/log.do_configure.4100
NOTE: package openvpn-2.0.2-r0: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package openvpn-2.0.2: failed
ERROR: Build of 'openvpn' failed
Build statistics:
 Attempted builds: 1
 Failed builds: 1


Thanks a lot, can someone gives me suggestions?
*



you might want to try using the org.openembedded.oz354x branch instead. I am not sure if openvpn is in there or not.
Go to the top of the page
 
+Quote Post
koen
post Dec 4 2006, 09:52 AM
Post #3





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(yanyan @ Dec 4 2006, 05:35 PM)
bitbake -b /stuff/org.openembedded.dev/packages/openvpn/openvpn_2.0.2.bb

*


don't use -b, use 'bitbake openvpn'
Go to the top of the page
 
+Quote Post
yanyan
post Dec 4 2006, 11:23 AM
Post #4





Group: Members
Posts: 7
Joined: 27-November 06
Member No.: 12,814



What i build up my OE i use

wget http://www.openembedded.org/snapshots/OE-t...tn-0.30.mtn.bz2


I think this contains all machines and all distors that OE supports.
Would you give me some link to downlond the the whole Metas.

I just check the http://www.openembedded.org/filebrowser/or...oz354x/packages
it contains the openvpn.

But anyway i still need to compile one route protocol for my Z, I need to compile the single file anyway. What should I do?

As my understanding I should create my own .bb file first and then still use "bitbake -b"


Now I am using the bitbake openvpn. But I saw one line
CODE
--20:13:28--  http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2


for my sl5500 it only runs kernel 2.4, I think it should be the invalid image again.

But anyway. I will wait and try.
Go to the top of the page
 
+Quote Post
koen
post Dec 4 2006, 12:34 PM
Post #5





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(yanyan @ Dec 4 2006, 07:23 PM)
As my understanding I should create my own .bb file first and then still use "bitbake -b"
*


No, I told you what you should do. Either follow the advice or stop asking for it.
Go to the top of the page
 
+Quote Post
yanyan
post Dec 4 2006, 02:17 PM
Post #6





Group: Members
Posts: 7
Joined: 27-November 06
Member No.: 12,814



OK.


Here is the error message when i use bitbake openvpn

CODE
NOTE: multiple providers are available (glibc, glibc-intermediate);
NOTE: consider defining PREFERRED_PROVIDER_virtual/arm-linux-libc-for-gcc
NOTE: multiple providers are available (linux-openzaurus, collie-kernel-24-8, poodle255-kernel-2.4-embedix, collie-kernel-48-16, a780-kernel, corgi-kernel-2.4-embedix, linux-geodegx, collie-kernel-58-6, poodle-kernel-2.4-embedix, shepherd-kernel-2.4-embedix, linux-h1940, ipod, linux-mtx-3, collie-kernel-32-0, linux-omap-2.6, xanadux-un-2.6, linux-h6300-omap1, husky-kernel-2.4-embedix, linux-geodelx, linux-xxs1500, LAB-kernel, collie-kernel-32-32, linux-bast, openzaurus-sa, xanadux-ba-2.6, collie-kernel-64-0, collie-kernel-40-24, collie-kernel-58-6-debug);
NOTE: consider defining a PREFERRED_PROVIDER to match runtime kernel-module-tun
NOTE: build 200612042308: completed
Build statistics:
 Attempted builds: 0
.

should I specify the right library for that?
Go to the top of the page
 
+Quote Post
rolf
post Dec 10 2006, 12:37 PM
Post #7





Group: Members
Posts: 108
Joined: 5-October 04
Member No.: 4,884



QUOTE(yanyan @ Dec 5 2006, 12:17 AM)
Here is the error message when i use bitbake openvpn

This is not an error message, but rather a confirmation that you have previously built openvpn successfully and that there was no reason to rebuild it again. If you want to rebuild say "bitbake -c rebuild openvpn". You can also remove the OE tmp dir and rebuild everything that way.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2014 - 07:10 AM