OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Ssh Xforwarding Problems With Hentges Rom
darmou
post Jan 2 2007, 04:35 AM
Post #1





Group: Members
Posts: 62
Joined: 17-December 04
Member No.: 5,956



I'm having problems with getting openssh with the latest snapshot of the hentges.rom to work with x forwading.


I use ssh -Y collie to get to my zaurus.

Here is my sshd_config file:



# $OpenBSD: sshd_config,v 1.59 2002/09/25 11:17:16 markus Exp $

# This is the sshd server system-wide configuration file. See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented. Uncommented options change a
# default value.

#Port 22
Protocol 2
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 3600
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 120
#PermitRootLogin yes
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys
# rhosts authentication should not be used
#RhostsAuthentication no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

#AFSTokenPassing no

# Kerberos TGT Passing only works with the AFS kaserver
#KerberosTgtPassing no

# Set this to 'yes' to enable PAM keyboard-interactive authentication
# Warning: enabling this may bypass the setting of 'PasswordAuthentication'
#PAMAuthenticationViaKbdInt yes

X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#KeepAlive yes
#UseLogin no
UsePrivilegeSeparation yes
#PermitUserEnvironment no
Compression no

#MaxStartups 10
# no default banner path
#Banner /some/path
#VerifyReverseMapping no

ClientAliveInterval 15
ClientAliveCountMax 4

# override default of no subsystems
Subsystem sftp /usr/libexec/sftp-server


Thanks for any help etc,

darmou
Go to the top of the page
 
+Quote Post
Da_Blitz
post Jan 2 2007, 05:01 AM
Post #2





Group: Members
Posts: 1,565
Joined: 7-April 05
From: Sydney, Australia
Member No.: 6,806



ssh -Y?

try ssh -X <host> <app>

sorry read the manual

another trick if you have the time to set up the "trusted" stuff or disable it is to change the DISPLAY enviremont varible by hand, you lose fowrding over ssh but that means a speedup (the Z aint that fast)

basically you need to get the "magic cookie" which ssh has a clever hack for to the Z if you dont want to disable security
Go to the top of the page
 
+Quote Post
darmou
post Jan 2 2007, 06:02 AM
Post #3





Group: Members
Posts: 62
Joined: 17-December 04
Member No.: 5,956



QUOTE(Da_Blitz @ Jan 2 2007, 01:01 PM)
ssh -Y?

yes that works fine with openzaurus on a 3100 with dropbear.

Hentges uses openssh

I tried your method no dice
tenchi:~ darmou$ ssh -X collie /usr/bin/gpe-calculator
darmou@collie's password:

(gpe-calculator:3341): Gtk-WARNING **: cannot open display:

darmou

I thought it may be something to do with the sshd_config file because, when I echo display after using -Y

I get:

tenchi:~ darmou$ ssh -Y -l root collie
root@collie's password:
Warning: No xauth data; using fake authentication data for X11 forwarding.
Last login: Tue Jan 2 23:37:57 2007 from 10.1.1.34
root@collie:~# echo $DISPLAY

root@collie:~#

with the 3100 I get
localhost:10.0

which is correct:
Go to the top of the page
 
+Quote Post
darmou
post Jan 4 2007, 04:35 AM
Post #4





Group: Members
Posts: 62
Joined: 17-December 04
Member No.: 5,956



QUOTE(darmou @ Jan 2 2007, 02:02 PM)
yes that works fine with openzaurus on a 3100 with dropbear.


DOH! I just answered my own question, removed openssh-sshd and reinstalled dropbear.

restarted and dada, xforwarding works.

darmou
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 03:04 PM