OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

8 Pages V  < 1 2 3 4 > »   
Reply to this topicStart new topic
> [new] Kernel 2.6.24.4 With Cpufreq, Updated: Jul. 16 2008
2or0
post Jan 30 2008, 02:55 AM
Post #16





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



QUOTE(qaz @ Jan 30 2008, 02:17 AM) *
QUOTE(2or0 @ Jan 29 2008, 10:45 PM) *
But I have a problem: When I suspend the system, I cannot turn it on and I should reset the system. Does anyone have this problem? This is the critical problem.

yonggun


Yes me to - resume is broken.



Ok, this kernel has something wrong. I cannot touch this problem for a while because I will have a vacation. Sorry for that.

yonggun
Go to the top of the page
 
+Quote Post
2or0
post Jan 30 2008, 03:29 AM
Post #17





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



QUOTE(2or0 @ Jan 30 2008, 02:55 AM) *
QUOTE(qaz @ Jan 30 2008, 02:17 AM) *
QUOTE(2or0 @ Jan 29 2008, 10:45 PM) *
But I have a problem: When I suspend the system, I cannot turn it on and I should reset the system. Does anyone have this problem? This is the critical problem.

yonggun


Yes me to - resume is broken.



Ok, this kernel has something wrong. I cannot touch this problem for a while because I will have a vacation. Sorry for that.

yonggun


I just fixed it. When I changed one option in the kernel, the power resume works well.
Go to the top of the page
 
+Quote Post
qaz
post Jan 30 2008, 04:00 AM
Post #18





Group: Members
Posts: 26
Joined: 6-January 06
Member No.: 8,867



QUOTE(2or0 @ Jan 30 2008, 12:29 PM) *
I just fixed it. When I changed one option in the kernel, the power resume works well.


Great! Will you upload new build to you site?
Go to the top of the page
 
+Quote Post
2or0
post Jan 30 2008, 06:08 AM
Post #19





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



QUOTE(qaz @ Jan 30 2008, 04:00 AM) *
Great! Will you upload new build to you site?


I already updated. tongue.gif
Go to the top of the page
 
+Quote Post
Dromede
post Jan 30 2008, 06:37 AM
Post #20





Group: Members
Posts: 156
Joined: 10-December 06
From: Croatia
Member No.: 13,288



2oro, can you tell us which option caused the suspend bug?
Go to the top of the page
 
+Quote Post
2or0
post Jan 30 2008, 07:03 AM
Post #21





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



QUOTE(Dromede @ Jan 30 2008, 06:37 AM) *
2oro, can you tell us which option caused the suspend bug?


I did following:

# CONFIG_TICK_ONESHOT is not set
# CONFIG_NO_HZ is not set
# CONFIG_HIGH_RES_TIMERS is not set
Go to the top of the page
 
+Quote Post
canguy247
post Feb 1 2008, 11:33 AM
Post #22





Group: Members
Posts: 70
Joined: 6-January 07
Member No.: 13,740



So, has anyone had success with a c1000?
Go to the top of the page
 
+Quote Post
Vitel
post Feb 1 2008, 01:27 PM
Post #23





Group: Members
Posts: 47
Joined: 25-April 06
Member No.: 9,703



QUOTE(canguy247 @ Feb 1 2008, 10:33 PM) *
So, has anyone had success with a c1000?

I have successfully installed the kernel.img.2.6.24-yonggun-sd1 on my C1000. No troubles with BlueTooth and suspend detected, everything is working fine. However, CF card is still required in order to boot from SD (see my first post in this topic for details).
Go to the top of the page
 
+Quote Post
canguy247
post Feb 1 2008, 04:57 PM
Post #24





Group: Members
Posts: 70
Joined: 6-January 07
Member No.: 13,740



Well, I tried flashing this kernel, but now I get:

VFS: Cannot open root device "mmcblk0p1" or unknown-block(0,0)

when holding 1, with a cf in slot.

FIXED: I removed my 16GB CF, and it booted with my 1GB card. That is kinda anoying...
Go to the top of the page
 
+Quote Post
urkden
post Feb 3 2008, 05:27 PM
Post #25





Group: Members
Posts: 63
Joined: 24-December 06
Member No.: 13,382



Which updater.sh do we need for the sharp zImage.bin?
Go to the top of the page
 
+Quote Post
qaz
post Feb 4 2008, 11:30 AM
Post #26





Group: Members
Posts: 26
Joined: 6-January 06
Member No.: 8,867



QUOTE(urkden @ Feb 4 2008, 02:27 AM) *
Which updater.sh do we need for the sharp zImage.bin?


I did that with Angstrom's updater and gnu-tar.
I have extracted modules manually before flashing.
Go to the top of the page
 
+Quote Post
judecn
post Feb 5 2008, 09:30 PM
Post #27





Group: Members
Posts: 11
Joined: 25-November 07
Member No.: 20,984



I tried to kexec -f the image on a C1000; the device froze. Normal kexec causes it to boot the original kernel (2.6.23). Any suggestions?
Go to the top of the page
 
+Quote Post
pelrun
post Feb 5 2008, 10:29 PM
Post #28





Group: Members
Posts: 369
Joined: 6-September 04
From: Brisbane, Australia
Member No.: 4,488



I've not successfully kexec'ed a 2.6 kernel yet (ok, I haven't successfully kexec'ed a 2.4 one either, but at least I get output with those.)

Oh, and kexec -f isn't the best way to use it - you're supposed to put kexec -e into /etc/init.d/reboot (just before the reboot command), load a kernel using kexec -l, then reboot normally. The kexec -e detects if a kernel has been loaded since the last reboot and starts it off, otherwise a normal reboot occurs.
Go to the top of the page
 
+Quote Post
jpmatrix
post Feb 12 2008, 01:07 PM
Post #29





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



whow!
has someone tried on a C3000 ? or will i be the first to try ? tongue.gif
Go to the top of the page
 
+Quote Post
jpmatrix
post Feb 12 2008, 01:51 PM
Post #30





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



yonggun, you're the master :

-kernel 2.6.24 (zImage.hda1) works out of the box with my C3000 !
-after rmmod mousedev : no mouse jittering at all under X !!!!
-asus CF WL110, belkin CF BT F8T020 : no problemo
-modprobe fuse ; mount my gmailfs directory ; copy files in it : no problemo !!!!!!!!

i'll try more devices later but so far THANK YOU !!!
Go to the top of the page
 
+Quote Post

8 Pages V  < 1 2 3 4 > » 
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th August 2014 - 09:18 PM