OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Vim And Qkonsole
terryleung83
post Jan 17 2006, 07:49 AM
Post #1





Group: Members
Posts: 68
Joined: 1-August 05
Member No.: 7,753



i want to ask anyone here can get vim display color(syntax highlight) with qkonsole?
qkonsole dont even display any color(except black and write)
i download the vim full from cacko feed and the vim setting there as well
Go to the top of the page
 
+Quote Post
terryleung83
post Jan 17 2006, 09:26 AM
Post #2





Group: Members
Posts: 68
Joined: 1-August 05
Member No.: 7,753



add a little bit more detail
i try vim in qpe terminal and it has least has some different color
i suspect that it's the problem of the terminal rather than vim
but i am not very sure if there is anyway to make qkonsole work
Go to the top of the page
 
+Quote Post
tml
post Jan 18 2006, 12:39 AM
Post #3





Group: Members
Posts: 105
Joined: 3-August 05
Member No.: 7,766



Maybe TERM is set to a non-color terminal?
Go to the top of the page
 
+Quote Post
terryleung83
post Jan 18 2006, 12:41 AM
Post #4





Group: Members
Posts: 68
Joined: 1-August 05
Member No.: 7,753



QUOTE(tml @ Jan 18 2006, 12:39 AM)
Maybe TERM is set to a non-color terminal?
*


i have tried to set this
export TERM=xterm
but it doesnt work
Go to the top of the page
 
+Quote Post
tml
post Jan 18 2006, 01:49 AM
Post #5





Group: Members
Posts: 105
Joined: 3-August 05
Member No.: 7,766



QUOTE(terryleung83 @ Jan 18 2006, 10:41 AM)
export TERM=xterm
*


TERM=linux works for me.
Go to the top of the page
 
+Quote Post
terryleung83
post Jan 18 2006, 03:35 AM
Post #6





Group: Members
Posts: 68
Joined: 1-August 05
Member No.: 7,753



QUOTE(tml @ Jan 18 2006, 01:49 AM)
QUOTE(terryleung83 @ Jan 18 2006, 10:41 AM)
export TERM=xterm
*


TERM=linux works for me.
*



thx
finally , i can make it syntax on by adding "syntax=on" in the .vimrc
Go to the top of the page
 
+Quote Post
climber
post Jan 20 2006, 01:11 AM
Post #7





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



@terryleung83

I´ve the same problem. I have a SL-C3100 Zaurus using vim via qkonsole and no syntax higlighting possible.

Do you really add "syntax=on" in the .vimrc or "syntax on". The version "syntax on" is actuall set at my .vimrc but it doesn`t work.


Maybe i try "export TERM=linux" this hopefuly it work.



Thanks,
climber
Go to the top of the page
 
+Quote Post
terryleung83
post Jan 20 2006, 01:59 AM
Post #8





Group: Members
Posts: 68
Joined: 1-August 05
Member No.: 7,753



QUOTE(climber @ Jan 20 2006, 01:11 AM)
@terryleung83

I´ve the same problem. I have a SL-C3100 Zaurus using vim via qkonsole and no syntax higlighting possible.

Do you really add "syntax=on" in the .vimrc or "syntax on".  The version "syntax on" is actuall set at my .vimrc but it doesn`t work.


Maybe i try  "export TERM=linux" this hopefuly it work.



Thanks,
climber
*


in .profile
QUOTE
export TERM=linux


in .vimrc
QUOTE
set syntax=on
Go to the top of the page
 
+Quote Post
climber
post Jan 20 2006, 02:58 AM
Post #9





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



Where do i find .profile to enter "export TERM=linux"? Please could you send me the link or mail me to get the same .vimrc as you have. Only to exclude my .vimrc as bad one.

eMail: WehrleT@gmx.de

Thanks,
climber
Go to the top of the page
 
+Quote Post
tml
post Jan 20 2006, 03:25 AM
Post #10





Group: Members
Posts: 105
Joined: 3-August 05
Member No.: 7,766



QUOTE(climber @ Jan 20 2006, 12:58 PM)
Where do i find .profile
*


It's a file in your home directory (/home/zaurus) that is read when using bash as a login shell. From the bash man page:

QUOTE
      When  bash is invoked as an interactive login shell, or as a non-inter-
      active shell with the --login option, it first reads and executes  com-
      mands  from  the file /etc/profile, if that file exists. After reading
      that file, it looks for ~/.bash_profile, ~/.bash_login, and ~/.profile,
      in  that order, and reads and executes commands from the first one that
      exists and is readable. The --noprofile option may be  used  when  the
      shell is started to inhibit this behavior.


If it's not there yet, simply create it.

HTH
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 10th July 2014 - 12:31 AM