OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Bluetooth, bluetooth set-up
keef
post Jun 5 2005, 03:24 AM
Post #1





Group: Members
Posts: 124
Joined: 31-January 04
Member No.: 1,634



Hi

i am trying to set up bluetooth connection between my slc860 and
motorola mobile and an imac.

I have managed to pair all the devices successfully.
Cannot seem to make a pan connection to the imac -
keeps saying connection refused. I have turned on sharing on the imac.

sdptool browse will see both the computer and the phones mac addresses
and services.

Trying to make a dial up connection to the phone seems to take ages trying to connect and then just quits.
I have followed instructions in the how to's but have no information of what to enter in the username,
password and phone fields in the dial-up applet.

Any help appreciated

keef


860/ motorola/imac sharp rom o2 phone
socket 'E' card
Go to the top of the page
 
+Quote Post
tumnus
post Jun 5 2005, 02:13 PM
Post #2





Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547



Don't know much about Macs so can't help with the PAN problem.

As for the phone dialup, the setup once you have your Zaurus and phone paired is no different from connecting via IR or serial. You will need to enter the correct modem init string for your phone and the username and password O2 requires, if any. It sounds like the Bluetooth connection to your phone is fine so it is simply these settings that you need to find for your phone and O2, which can usually be found with Google.
Go to the top of the page
 
+Quote Post
keef
post Jun 5 2005, 02:22 PM
Post #3





Group: Members
Posts: 124
Joined: 31-January 04
Member No.: 1,634



thanks for the reply.
I will try and find the settings


keef
Go to the top of the page
 
+Quote Post
keef
post Jun 11 2005, 06:39 AM
Post #4





Group: Members
Posts: 124
Joined: 31-January 04
Member No.: 1,634



OK

entered all the settings from O2 and still no joy.
If i enter my home phone number in the phone field I can get
the phone to ring this number by contacting from the Z.

Have confirmed that the data account is set up on the phone
so i dont know why it will not connect to GPRS- all the settings seem to be ok.

Any ideas appreciated



keef
Go to the top of the page
 
+Quote Post
tumnus
post Jun 11 2005, 03:44 PM
Post #5





Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547



You have to tell it to connect to a specific GPRS access point. The access point for internet is typically different to that used fo WAP by the phone itself. You specify this with a special number/string to dial, but the actual string differs from phone to phone.

I think you should see a log of what in going on when you dial in /tmp/qpe-ppp-log.
Go to the top of the page
 
+Quote Post
keef
post Jun 11 2005, 04:19 PM
Post #6





Group: Members
Posts: 124
Joined: 31-January 04
Member No.: 1,634



QUOTE(tumnus @ Jun 11 2005, 03:44 PM)
You have to tell it to connect to a specific GPRS access point. The access point for internet is typically different to that used fo WAP by the phone itself. You specify this with a special number/string to dial, but the actual string differs from phone to phone.

I think you should see a log of what in going on when you dial in /tmp/qpe-ppp-log.
*


Hi Tumnus

here is the-log:
abort on (NO CARRIER)
abort on (NO DIALTONE)
abort on (BUSY)
send (ATZ^M)
expect (OK)
ATZ^M^M
OK
-- got it

send (ATDT*99#^M)
expect (CONNECT)
^M
ATDT*99#^M^M
CONNECT
-- got it

Serial connection established.
using channel 22
Using interface ppp0
Connect: ppp0 <--> /dev/rfcomm0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xb6a3b1a9> <pcomp> <accomp>]
Timeout 0x20084bc:0x203b440 in 3 seconds.
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xb6a3b1a9> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0x1067ce1> <pcomp> <accomp>]
lcp_reqci: returning CONFREJ.
sent [LCP ConfRej id=0x1 <auth pap>]
rcvd [LCP ConfReq id=0x2 <asyncmap 0x0> <magic 0x1067d96> <pcomp> <accomp>]
lcp_reqci: returning CONFACK.
sent [LCP ConfAck id=0x2 <asyncmap 0x0> <magic 0x1067d96> <pcomp> <accomp>]
Untimeout 0x20084bc:0x203b440.
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Timeout 0x20084bc:0x203b6a0 in 3 seconds.
sent [CCP ConfReq id=0x1 <bsd v1 15>]
Timeout 0x20084bc:0x203b7a0 in 3 seconds.
rcvd [IPCP ConfRej id=0x1 <compress VJ 0f 01>]
Untimeout 0x20084bc:0x203b6a0.
sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Timeout 0x20084bc:0x203b6a0 in 3 seconds.
rcvd [LCP ProtRej id=0x1 80 fd 01 01 00 07 15 03 2f]
Untimeout 0x20084bc:0x203b7a0.
rcvd [LCP TermReq id=0x3 05 00 00 0a 00 00 00 00 00 00]
LCP terminated by peer (^E^@^@^J^@^@^@^@^@^@)
Untimeout 0x20084bc:0x203b6a0.
CCP: Down event in state 1!
Timeout 0x20084bc:0x203b440 in 3 seconds.
sent [LCP TermAck id=0x3]
rcvd [LCP TermAck id=0x3]
Untimeout 0x20084bc:0x203b440.
Connection terminated.

keef
Go to the top of the page
 
+Quote Post
marshmn
post Jun 25 2005, 01:01 AM
Post #7





Group: Members
Posts: 69
Joined: 18-November 04
From: Watford, UK
Member No.: 5,508



I don't know if you've already got this working, or if this helps, but here are the settings I use to connect to O2 using my Z with a Nokia 6230:

Account:
Username: o2wap
Password: password
Phone: *99#

Modem:
BT device /dev/rfcomm0
Init string: ate0v1
Speed: 115200
Flow control: enabled
Time out: 5 sec

Works for me at least, YMMV.

Matt
Go to the top of the page
 
+Quote Post
keef
post Jun 25 2005, 03:02 AM
Post #8





Group: Members
Posts: 124
Joined: 31-January 04
Member No.: 1,634



Hi

thanks for the reply

your settings are pretty much what I am using except for the init string

i have been using ATZ which seems to connect but just as quickly disconnect.

where did you get the init string from? is this specific to the make of phone?



thanks again

i will try your settings and see what happens
Go to the top of the page
 
+Quote Post
tecks
post Jun 27 2005, 07:26 AM
Post #9





Group: Members
Posts: 5
Joined: 13-May 05
Member No.: 7,123



Hi keef,
for me this
http://www.trisoft.de/bluetooth.htm
link was very useful.
just changed
/dev/ttyS0 -> /dev/rfcomm0 ######or your device
and
internet.t-d1.de > internet ######for O2-Germany with contract
and delete
remotename IRDA1062007291

And it works! Thanks to trisoft - once again...
Ulli
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st July 2014 - 07:47 PM