OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Ruby-sqlite3 Support?, Has anyone compiled ruby-sqlite for Z?
zmike
post Feb 2 2006, 09:44 AM
Post #1





Group: Members
Posts: 77
Joined: 15-January 04
Member No.: 1,206



Hi all,
I recently got the 1.8.3 release of ruby installed on my C860 which also let me put gem and install rails. I also have SQLITE3 working.

HOWEVER, the ruby-sqlite3 gem installation requires some native compiling. I suppose I could try to get that working but I wondered if anyone out there has already compiled support to bind the two together.

Failing that, does mysql work with rails on the Z?

TIA,
Mike
Go to the top of the page
 
+Quote Post
Sy Ali
post Jun 17 2006, 05:09 PM
Post #2





Group: Members
Posts: 120
Joined: 14-June 06
Member No.: 10,168



I wanted to follow up with this thread, as I am going to be interested in using Ruby natively on the Zaurus SL-C1000.

Please post if you've had experience using Ruby on the SL-Cx00 family and can help with advice and instructions.
Go to the top of the page
 
+Quote Post
Dobby
post Aug 18 2006, 06:22 PM
Post #3





Group: Members
Posts: 84
Joined: 20-July 06
Member No.: 10,467



Has anyone made any progress on this? I too am interested in getting Ruby/Rails/SQLite installed.

I got the latest 1.8.4 version of ruby installed but failed on gem as it needed some crypto library that I couldn't find a compatible version of for the Sharp ROM.

Obviously I can use the ZIP version of Rails (which I've downloaded but not got around to trying yet. Still new to the Z).

So I guess I'm going to get stuck on the Ruby SQLite bindings too then?
Go to the top of the page
 
+Quote Post
iamasmith
post Aug 19 2006, 02:29 AM
Post #4





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(Dobby @ Aug 19 2006, 02:22 AM)
Has anyone made any progress on this? I too am interested in getting Ruby/Rails/SQLite installed.

I got the latest 1.8.4 version of ruby installed but failed on gem as it needed some crypto library that I couldn't find a compatible version of for the Sharp ROM.

Obviously I can use the ZIP version of Rails (which I've downloaded but not got around to trying yet. Still new to the Z).

So I guess I'm going to get stuck on the Ruby SQLite bindings too then?
*


I recommend going that extra mile and getting gem running... it is so useful to have it available.

I'm using all of this stuff on OpenBSD on my Zaurus and of course because I'm essentially using the same OS as is installed on a Desktop or Server machine it has all of the required libraries.

Being able to run gem_server for convenience over pure rdoc is nice but doing quick update checks using gem is also great.

-Andy
Go to the top of the page
 
+Quote Post
Sy Ali
post Aug 19 2006, 04:37 AM
Post #5





Group: Members
Posts: 120
Joined: 14-June 06
Member No.: 10,168



The only working and complete Ruby that I know of is for pdaXrom. It wouldn't work for me on the Cacko ROM. =(
Go to the top of the page
 
+Quote Post
Dobby
post Sep 5 2006, 03:16 PM
Post #6





Group: Members
Posts: 84
Joined: 20-July 06
Member No.: 10,467



I'm now using pdaXrom but still have the issue of no gem support. Ideally I'd like ruby, rails, sqlite3 (+ bindings of course) and an editor.

Ruby installs (from Fabien) but no gem or rake support as far as I can tell. I've got sqlite3 installed but need the bindings.

Any help would be appreciated.
Go to the top of the page
 
+Quote Post
Sy Ali
post Sep 5 2006, 03:22 PM
Post #7





Group: Members
Posts: 120
Joined: 14-June 06
Member No.: 10,168



There is a complete Ruby + Gems package for pdaxrom.. I don't have a quick reference, but it's out there..
Go to the top of the page
 
+Quote Post
Dobby
post Sep 5 2006, 03:41 PM
Post #8





Group: Members
Posts: 84
Joined: 20-July 06
Member No.: 10,467



Well as I said I found Fabiens ipk which is supposed to include gem but it doesn't work (gem: command not found). I've seen attempts at trying to get it installed manually to be unsuccessful also.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st August 2014 - 05:58 PM