OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Swap Partition, Sharp Rom
tinfoil
post Jun 21 2007, 11:13 AM
Post #1





Group: Members
Posts: 11
Joined: 11-June 07
Member No.: 17,067



Hey folks,

I've recently put a swap partition on an SD card (/dev/mmcda2) in place and is perfectly functional when used with swapon from the console. However, it seems to disappear whenever the device is put into suspend or powered off. I have added a line in fstab, but still no lovin. I can't even get it to work if I run it from rc.local (nor can I get apache to run from within there or inetd as well, but it works fine from the commandline?)

Am I barking up the wrong tree here? There is a couple apps that I do need this for.
Go to the top of the page
 
+Quote Post
Meanie
post Jun 21 2007, 03:44 PM
Post #2





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(tinfoil @ Jun 22 2007, 05:13 AM)
Hey folks,

I've recently put a swap partition on an SD card (/dev/mmcda2) in place and is perfectly functional when used with swapon from the console. However, it seems to disappear whenever the device is put into suspend or powered off. I have added a line in fstab, but still no lovin. I can't even get it to work if I run it from rc.local (nor can I get apache to run from within there or inetd as well, but it works fine from the commandline?)

Am I barking up the wrong tree here? There is a couple apps that I do need this for.
*


rc.local is not used in Sharp ROM, its commented out in rc.sysinit
/etc/fstab won't be much use either since your SD device is activated after /etc/fstab is evaluated...
Go to the top of the page
 
+Quote Post
freizugheit
post Jun 21 2007, 06:57 PM
Post #3





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



I have been using swapfile stored in /dev/mmcda1 and it works fine.

The only thing that I need to activate the swapfile when I warm start my SL-5600.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th April 2014 - 05:16 AM