OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Usb Driver For Tiger, new version
dhns
post Apr 29 2005, 04:29 AM
Post #1





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



Dear all Mac users,

you will need a new version of the USB driver (AJZaurusUSB) for Tiger (10.4). The 0.28 version does not work and the new one will NOT work on Panther (10.3).

I will put it up as soon as our web service is working again.

As a preannouncement, ZMacSync-1.5 will basically work on Tiger for Contacts - but not for Events and Tasks (data structure has changed). Therefore, we work on a version which uses the new Tiger SyncServices and makes syncing much more reliable.

-- hns
http://www.dsitri.de
Go to the top of the page
 
+Quote Post
daemon1
post Apr 30 2005, 03:04 AM
Post #2





Group: Members
Posts: 86
Joined: 18-April 04
Member No.: 2,901



Fantastic! Looking forward to the new version.

Thank you for all the hard work and efforts in getting the Z talking to the mac smile.gif
Go to the top of the page
 
+Quote Post
dhns
post Apr 30 2005, 05:55 AM
Post #3





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(daemon1 @ Apr 30 2005, 12:04 PM)
Fantastic! Looking forward to the new version.

Thank you for all the hard work and efforts in getting the Z talking to the mac  smile.gif
*

Here it is:
http://www.dsitri.de/wiki.php?page=AJZaurusUSB

We did have a PHP attack which made our pages unaccessible. So, a side-note to everybody responsible for PHP based web servers: there are robots/scripts out there that try to break in through phpBB2 and insert trojan horse links etc. into <a href=xxx> and <form action=xxx> tags directly written into PHP code.

-- hns
Go to the top of the page
 
+Quote Post
chjones
post May 3 2005, 05:21 PM
Post #4





Group: Members
Posts: 2
Joined: 3-May 05
Member No.: 7,060



QUOTE(dhns @ Apr 29 2005, 05:29 AM)
you will need a new version of the USB driver (AJZaurusUSB) for Tiger (10.4). The 0.28 version does not work and the new one will NOT work on Panther (10.3).


0.2.8 works just fine for me on Tiger on my mini. What did you feel the need to change?
Go to the top of the page
 
+Quote Post
dhns
post May 4 2005, 01:34 AM
Post #5





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(chjones @ May 4 2005, 02:21 AM)
0.2.8 works just fine for me on Tiger on my mini.  What did you feel the need to change?
*

Interesting! Should try again. Perhaps there is some "compatibility mode" in the kernel which was not active on my system?

The changes made were:
* recompiled with Xcode 2.0/gcc 4.0 against the latest IOKit and USBKit
* added new header files since the new kernel required to use an additional kernel library to handle struct mbuf in a different (probably more future-proof i.e. 64 bit/G5 compatible) way
* there is no "official" support of the C1000/C3000 in the driver - but that is just cosmetics since they are recognized as a C760.

-- hns
Go to the top of the page
 
+Quote Post
chjones
post May 4 2005, 05:42 AM
Post #6





Group: Members
Posts: 2
Joined: 3-May 05
Member No.: 7,060



QUOTE(dhns @ May 4 2005, 02:34 AM)
Interesting! Should try again. Perhaps there is some "compatibility mode" in the kernel which was not active on my system?


Couldn't say for sure, but I did nothing special on mine. I installed Tiger (erase and install) on Saturday, have done some basic configuration but certainly no hacking. Installed AJZaurusUSB-0.2.8 according to the "official" instructions on Sunday; after a reboot, everything worked just as it was supposed to.

Maybe other machines will have problems, but I'm not seeing any reason to upgrade at the moment.
Go to the top of the page
 
+Quote Post
dhns
post May 4 2005, 06:21 AM
Post #7





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(chjones @ May 4 2005, 02:42 PM)
Maybe other machines will have problems, but I'm not seeing any reason to upgrade at the moment.
Fine! It might come from that I already had the predevelopment releases and did not do a complete fresh install.

So the 0.3.0 can be seen as an upgrade option if something goes wrong. Everybody can decide him/herself.

-- hns
Go to the top of the page
 
+Quote Post
samxiao
post May 13 2005, 07:56 AM
Post #8





Group: Members
Posts: 260
Joined: 7-March 04
From: Toronto
Member No.: 2,200



i might try to install Tiger (as upgrade from my Panther)

but it might cause a lot conflicts
anyone has problem with upgrade installation?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 02:13 PM