OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Running X In 5.6
TronDD
post Nov 10 2014, 06:17 PM
Post #1





Group: Members
Posts: 55
Joined: 6-January 05
Member No.: 6,137



So the fix for the X problem in 5.5 narrowly missed the 5.6 release. It is part of the 5.6 source, but it's not in the binary. I assume the build for the Z starts earlier than other platforms given that it's built natively on a Zaurus and must take quite a bit longer.

To get the fix, do your upgrade/install to 5.6
Grab the xenocara.tar.gz from your local mirror.
Cd to /usr
Extract the tarball.
Cd to /usr/xenocara/lib/libpciaccess
Build with:
make -f Makefile.bsd-wrapper obj
make -f Makefile.bsd-wrapper build

That will do the install as well. Fire up X and you're good to go.

Don't worry, the build for just this library doesn't take very long.

Tim.
Go to the top of the page
 
+Quote Post
ArchiMark
post Feb 4 2015, 08:41 PM
Post #2





Group: Members
Posts: 1,377
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Hi there,

Just curious if you've made any other progress with OBSD since your post......been awhile...

Thanks.
Go to the top of the page
 
+Quote Post
TheWalt
post May 4 2015, 04:05 AM
Post #3





Group: Members
Posts: 162
Joined: 11-August 05
Member No.: 7,836



Anyone try 5.7 and did this make it in?
Go to the top of the page
 
+Quote Post
ArchiMark
post May 4 2015, 04:48 AM
Post #4





Group: Members
Posts: 1,377
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Nope, haven't had time to play with my Z.....

Would be interesting to know though....
Go to the top of the page
 
+Quote Post
TronDD
post Jun 7 2015, 09:05 AM
Post #5





Group: Members
Posts: 55
Joined: 6-January 05
Member No.: 6,137



Should be in 5.7.

My Zaurus finally bit the dust, just before 5.7 released so I never got to try it.

They also stopped building packages for ARM, as the platform support was not up to standards. There is an unofficial effort to produce packages.

http://marc.info/?t=143223172200002&r=1&w=2

I've done the "build everything natively on my Zaurus myself" but packages sure help a lot. Compiling was the first thing to show signs of my Z failing. sad.gif

Tim.
Go to the top of the page
 
+Quote Post
ArchiMark
post Oct 1 2015, 05:33 AM
Post #6





Group: Members
Posts: 1,377
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks for that update, Tim.....

Been so dang busy with work this year...haven't had time to play with Z or even read your last post until now.....

But maybe 5.7 would be worth a try if I get some time...

Mark
Go to the top of the page
 
+Quote Post
danboid
post Oct 2 2015, 11:24 AM
Post #7





Group: Members
Posts: 886
Joined: 26-December 05
From: England
Member No.: 8,789



Hi TronDD

Sorry to hear about your Z biting the dust! I am surprised that my C3000 is still with us and that OBSD still supports the Z, or at least they still provide the base packages to get it installed!

I'm installing OBSD on my Z for the first time and ideally I'd like to remove any Linux partitions from my MD and have my Z boot directly into OBSD. MIght you know how I'd do that?

I've detailed my efforts so far here http://www.oesf.org/forum/index.php?showtopic=34386

Thanks!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 03:55 AM