OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> X Virtual Keyboard
samxiao
post Aug 7 2005, 02:53 PM
Post #1





Group: Members
Posts: 260
Joined: 7-March 04
From: Toronto
Member No.: 2,200



for whoever has problem inputting "/" in X/Qt

use apt-get install xvkbd
it will have a virtual keyboard
so you can input "/" from X
Go to the top of the page
 
+Quote Post
tovarish
post Aug 8 2005, 07:49 AM
Post #2





Group: Members
Posts: 299
Joined: 27-October 04
Member No.: 5,233



alternatively edit .xmodmaprc by looking at keycodes using xev

dont forget to run khctl stop before starting debian/xqt
Go to the top of the page
 
+Quote Post
freebird
post Sep 19 2005, 08:48 AM
Post #3





Group: Members
Posts: 104
Joined: 27-October 04
Member No.: 5,242



QUOTE(samxiao @ Aug 7 2005, 10:53 PM)
for whoever has problem inputting "/" in X/Qt

use apt-get install xvkbd
it will have a virtual keyboard
so you can input "/" from X
*


Samxiao

thanks for creating this topic, cause the debian keyboard is now my problem
using debian applications

also i typed your instruction but i had some errors
it seems that this instruction "apt-get" is to use if connected to the net
it is not my case
can you give mor details please
i am newby


Freebird
Go to the top of the page
 
+Quote Post
freebird
post Sep 19 2005, 08:51 AM
Post #4





Group: Members
Posts: 104
Joined: 27-October 04
Member No.: 5,242



QUOTE(tovarish @ Aug 8 2005, 03:49 PM)
alternatively edit .xmodmaprc by looking at keycodes using xev

dont forget to run khctl stop before starting debian/xqt
*


Tovarish

Can you please give some more details
where is located that file .xmodmaprc ???
run khctl stop means type #khctl stop or ??

thanks
Go to the top of the page
 
+Quote Post
samxiao
post Sep 19 2005, 10:15 AM
Post #5





Group: Members
Posts: 260
Joined: 7-March 04
From: Toronto
Member No.: 2,200



QUOTE(freebird @ Sep 19 2005, 11:48 AM)
QUOTE(samxiao @ Aug 7 2005, 10:53 PM)
for whoever has problem inputting "/" in X/Qt

use apt-get install xvkbd
it will have a virtual keyboard
so you can input "/" from X
*


Samxiao

thanks for creating this topic, cause the debian keyboard is now my problem
using debian applications

also i typed your instruction but i had some errors
it seems that this instruction "apt-get" is to use if connected to the net
it is not my case
can you give mor details please
i am newby


Freebird
*





ahhh... sad.gif

"apt-get" is only useful if you have the networked debian package

alternatively, you can just download the "xvkbd" from debian ARM package and install them by using ipkg
but most likely, you will be having a lot dependency problem (that's why apt-get is useful)

is there any way you can get hotspot in your area or use the USB cable connected to your PC/Mac/whatever, setup the internet for your Z, and get the internet that way?
Go to the top of the page
 
+Quote Post
xjqian
post Jan 30 2006, 01:31 AM
Post #6





Group: Members
Posts: 500
Joined: 17-January 04
From: St. Louis, USA
Member No.: 1,478



QUOTE(samxiao @ Aug 7 2005, 05:53 PM)
for whoever has problem inputting "/" in X/Qt

use apt-get install xvkbd
it will have a virtual keyboard
so you can input "/" from X
*


on 6000 x/qt debian with .xmodmaprc provided by smuelas smuelas key mapping backslash "/" is mapped to Shift+space. I guess it's not a problem for the 6000 user. However I am desperate to find a solution to input pipe "|". Thanks for the xvkbd tip.


QUOTE(tovarish @ Aug 8 2005, 10:49 AM)
alternatively edit .xmodmaprc by looking at keycodes using xev

dont forget to run khctl stop before starting debian/xqt
*


With that said, I'd still prefer this fixed in .xmodmaprc. Do you know how to fix this for 6k? Is the pipe "|" key called "bar" in the .xmodmaprc?

Edit: Nevermind, I found the 6000 Keymap and learned how to use xev. I managed to map the "bar" into one of the unused keycodes (i.e. what's left from smuelas .xmodmaprc): biggrin.gif

keycode
132 Fn+email

some other options: currently mapped to
86 Fn+righ end
87 Fn+up prior
88 Fn+down next
125 Fn+space will bring up the unicode
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 03:27 AM