OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Edgy Eft, Upstart, And Usbnet?, How to get usbnet to auto-run with upstr
doug-taylor
post Oct 30 2006, 06:30 AM
Post #1





Group: Members
Posts: 22
Joined: 11-October 05
Member No.: 8,291



Hi. I have a Zaurus SL-5500 running Opie 3.5.4, and I have been happily using the following script (/etc/hotplug/usb/usbnet) on my Ubuntu desktop to set up USB networking whenever my Z gets plugged in to the USB port:

#! /bin/bash
typeset -i num
num=`ifconfig | grep usb0 | wc -l`
if [ $num -eq 0 ] ; then
ifconfig usb0 192.168.129.1 netmask 255.255.255.255 up
route add -host 192.168.129.201 usb0
fi
iptables -t nat -F
iptables -t nat -A POSTROUTING -j SNAT -o eth0 --to <IP ADDRESS>
echo 1 > /proc/sys/net/ipv4/ip_forward

I recently upgraded Ubuntu from Dapper Drake to Edgy Eft, and all of a sudden, there's no /etc/hotplug directory. It looks like that functionality has been taken over by upstart. So my question is, how can I set up upstart (1) to recognize that the Z has plugged into the USB port and (2) to set up networking for it?

Thanks,

Doug
Go to the top of the page
 
+Quote Post
Ling
post Dec 30 2006, 09:29 PM
Post #2





Group: Members
Posts: 352
Joined: 3-June 04
From: Virginia, US
Member No.: 3,563



I believe that hotplug was replaced with udev. Looking at my Edgy box (upgraded from Dapper) I still have an /etc/hotplug directory, but the /etc/udev/ directory seems to have the current information. If you haven't already done so, I would post your question at the ubuntu/kubuntu forum. If I have time tomorrow, I will try your script with my 3200. Thanks.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 03:43 PM