OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> netfilter and wireless
cwalstad
post Jul 7 2004, 09:10 AM
Post #1





Group: Members
Posts: 9
Joined: 25-June 04
Member No.: 3,830



I found out that the zaurus kernel is not configured to support netfilter/iptables, so to get these things to work I reconfigured and recompiled the kernel to support them. The only changes I made (during menuconfig) were enabling iptables/netfilter. I installed the new kernel and everything went fine. There were no problems however after a couple hours my Zaurus started locking up and the wireless connection was always giving me the signal level is low message. I know it isn't low because my router is about 2 feet away from me. This same thing happened to my friend who installed the new kernel as well. Any ideas on why this is happening? Thanks for your help.

Chris
Go to the top of the page
 
+Quote Post
cwalstad
post Jul 9 2004, 12:49 PM
Post #2





Group: Members
Posts: 9
Joined: 25-June 04
Member No.: 3,830



So the solution to this problem turns out to be: just install the newest Sharp ROM (i.e. 1.32 for the 5600). This ROM has netfilter/iptable support configured into it. If you install the iptables and iptables-module packages from http://cmisip.home.insightbb.com/zaurus.htm it should work. I tested filtering by ip and mac address and these both worked.

Chris
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 11:22 AM