OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

4 Pages V  « < 2 3 4  
Reply to this topicStart new topic
> Corsair - Rss/podcast Aggregator
brashley46
post Nov 25 2006, 08:13 PM
Post #46





Group: Members
Posts: 277
Joined: 29-May 05
From: Toronto
Member No.: 7,227



QUOTE(tiny ogre @ Nov 25 2006, 07:32 PM)
I released an updated version (0.2.6) today.  It has the preferences dialog I mentioned months ago.  The only preferences right now are what programs to use for playing audio and video.  It also has a bug fix for redirect handling (If some feeds or their file downloads weren't working for you, this may have been the cause).  That's it, a pretty small update, but the preferences dialog should make life a little easier for Zaurus users.

The default players are still set up for the PMA, not the Zaurus.

I'm obviously not spending a lot of time working on this, but patches from others for anything you'd like to add are always welcome.

Downloads are here
*

Well, it works as well as 0.2.5 on my 860; I'll have to find the prefs dialogue.

cool.gif
Go to the top of the page
 
+Quote Post
tiny ogre
post Nov 26 2006, 02:22 AM
Post #47





Group: Members
Posts: 6
Joined: 29-August 05
Member No.: 7,988



QUOTE(brashley46 @ Nov 25 2006, 09:13 PM)
Well, it works as well as 0.2.5 on my 860; I'll have to find the prefs dialogue.


It's in the View menu. The menus are in the topmost button on the sidebar.
Go to the top of the page
 
+Quote Post
brashley46
post Nov 26 2006, 06:40 PM
Post #48





Group: Members
Posts: 277
Joined: 29-May 05
From: Toronto
Member No.: 7,227



QUOTE(tiny ogre @ Nov 26 2006, 05:22 AM)
QUOTE(brashley46 @ Nov 25 2006, 09:13 PM)
Well, it works as well as 0.2.5 on my 860; I'll have to find the prefs dialogue.


It's in the View menu. The menus are in the topmost button on the sidebar.
*


Got it, thanks, and enabled "Music Player" and "Kino2"; but I'm not subscribed to any podcasts ... just rss newsfeeds like LabourStart. Now I'll have to go find some, and see if they work this way!
Go to the top of the page
 
+Quote Post
eji
post Nov 26 2006, 11:58 PM
Post #49





Group: Members
Posts: 233
Joined: 29-November 04
From: Germany
Member No.: 5,659



"corsair: error while loading shared libraries: libqtopia.so.1: cannot load shared object file: No such file or directory"

I'm on a 6000 running the stock ROM (Qtopia 1.5.4). Corsair 0.2.4-1 worked fine.

Anyone got any suggestions?
Go to the top of the page
 
+Quote Post
tiny ogre
post Nov 27 2006, 06:21 PM
Post #50





Group: Members
Posts: 6
Joined: 29-August 05
Member No.: 7,988



QUOTE(eji @ Nov 27 2006, 12:58 AM)
"corsair: error while loading shared libraries: libqtopia.so.1: cannot load shared object file: No such file or directory"

I'm on a 6000 running the stock ROM (Qtopia 1.5.4). Corsair 0.2.4-1 worked fine.

Anyone got any suggestions?
*


Corsair 0.2.4-1 is not an official release, did you get a version from a different location than mine? Mine's the "official" version, but I'm really building it for the PMA400, not Zauruses at all. It's just a happy coincidence that it works for many Zaurus users.

I'd be happy to provide alternate builds if I knew how to build them or if someone else wanted to send them to me.
Go to the top of the page
 
+Quote Post
eji
post Nov 28 2006, 10:15 AM
Post #51





Group: Members
Posts: 233
Joined: 29-November 04
From: Germany
Member No.: 5,659



I have no idea where I found it, T_O. I do know, though, that 0.2.5 never worked for me, and I thought that 0.2.6 might be different. Looks like the "official" releases aren't playing well with the 6000, and I'll have to go back to 0.2.4. I'm not a developer, just a dilettante, so I can't give any compiling or building help.
Go to the top of the page
 
+Quote Post
nilch
post Dec 7 2006, 01:55 PM
Post #52





Group: Members
Posts: 668
Joined: 3-December 03
From: US
Member No.: 1,034



I have started depending on Corsair a lot these days and now also listen to Audio podcasts and subscribe thru Corsair (NPR being a favourite).

And having recently bought a 2 GB SD card, it would be great if the corsair feeds and audio files can be pointed to be stored on the SD instead on default internal memory location. Because the lasrge audio podcasts fill up the internal memory very fast.

I hope a prefernce dialog to set storage location is included in the never versions of corsair.

Thanks for the excellent application though.
Go to the top of the page
 
+Quote Post
tombraider
post Dec 30 2006, 12:46 PM
Post #53





Group: Members
Posts: 409
Joined: 23-November 04
From: Murphy, North Carolina USA
Member No.: 5,590



tiny:
I had an old version of Corsair working great...it automatically opened Kino, but this new version just goes to a black screen when I try to play ANYTHING. Help! I use this app every night.
I tried replacing "player" with "Music Player" in the prefs for audio but I STILL get a black screen.
sad.gif
The good news is that a feed works now that gave an "error" in the corsair_0.2.5_arm.ipk version - The Mile Malloy Show Podcast from Nova-M Radio!
Thanks for that...
Your work is very much appreciated...I had to go back to the corsair_0.2.4_arm.ipk version because of the other problem though, even corsair_0.2.5_arm.ipk does not work for me...does not bring up kino2 to play the audio. It's possible I changed some config file to get corsair_0.2.4_arm.ipk to work and the new versions overwrite it.
Where IS the config file for Corsair?

Nilch:
I made a symlink for "shows" to my sd card and so all the downloads go to my sd card not internal.

QUOTE(tiny ogre @ Jul 9 2006, 05:26 PM)
Contrary to popular belief, I'm still alive!

I added most of mistermix's patch to the main source and put out a new binary release, labelled 0.2.5, along with a source tarball release so that there will be an "official" reference point other than CVS.  However, it does NOT have the change to use "kino2" as the default player, as the old option is still correct for the PMA.  This is something that would be settable via preferences if only there were a preferences dialog.  All of his other changes are now in the main source.

I also did not integrate the QPE 1.5 patch, as that's not what I'm using to build it, and it would fail in my environment as given.

But hopefully everything's at least closer together now than it was.

There's one other change: if an enclosure has a video mime-type, then Corsair will attempt to launch a video player instead of an audio player.  This works for a very limited subset of video podcasts.  In fact I don't even have any public ones that have video that works on the PMA, but it was requested by someone who had a test feed set up, and it was easy enough to do.  This again would benefit greatly from a preferences dialog.

If it turns out I'm really not dead, a preferences dialog is obviously the next task that needs doing the most.  But no guarantees.  That would qualify for a 0.3.0 release.  Submissions from 3rd parties are welcome!

If you need to contact me, please use "corsair at rumsey dot org" as my address.
*
Go to the top of the page
 
+Quote Post
dwagelaar
post Feb 8 2007, 11:44 PM
Post #54





Group: Members
Posts: 46
Joined: 26-July 04
From: Brussels, Belgium
Member No.: 4,106



QUOTE(eji @ Nov 28 2006, 07:15 PM)
I have no idea where I found it, T_O. I do know, though, that 0.2.5 never worked for me, and I thought that 0.2.6 might be different. Looks like the "official" releases aren't playing well with the 6000, and I'll have to go back to 0.2.4. I'm not a developer, just a dilettante, so I can't give any compiling or building help.
*


Sorry for the late answer... You found that IPK on ELSI (www.elsix.org), since that's where I put them (ok, that links to my website). The reason it works directly on zaurus is that I used the zaurus toolchain to compile Corsair (Qtopia 1.5.0). I've made one update since, which is to include some hi-res icons for the VGA zauruses. I haven't taken the time to work on the code since, so the newer corsair codebase is not (yet) merged in.


Cheers,
Dennis
Go to the top of the page
 
+Quote Post
eji
post Feb 10 2007, 12:43 PM
Post #55





Group: Members
Posts: 233
Joined: 29-November 04
From: Germany
Member No.: 5,659



QUOTE(dwagelaar @ Feb 9 2007, 07:44 AM)
Sorry for the late answer... You found that IPK on ELSI (www.elsix.org), since that's where I put them (ok, that links to my website). The reason it works directly on zaurus is that I used the zaurus toolchain to compile Corsair (Qtopia 1.5.0). I've made one update since, which is to include some hi-res icons for the VGA zauruses. I haven't taken the time to work on the code since, so the newer corsair codebase is not (yet) merged in.
*


Actually, I installed two IPKs that were mentioned on this forum -- I forget which exactly -- and the latest Corsair was up and running! The buttons weren't scaled, of course, because the resolution on the 6000 is higher, so I added new PNGs and everything's fine. If I have time, I ought to post a screenshot. It works really well and looks nice.

... but I've actually been using the latest version of KeroPlayer for my podcasts. I like the interface much better. I made an English translation of the .rb Ruby file, if anyone wants it.

So now it's just Corsair and KeroPlayer. I've ditched dmBlogger entirely. Besides, it doesn't work with the new version of Ruby that KeroPlayer requires.
Go to the top of the page
 
+Quote Post
mscdex
post Mar 17 2007, 03:19 PM
Post #56





Group: Members
Posts: 55
Joined: 7-August 05
Member No.: 7,809



I installed cosair 0.2.6 along with the two libraries I was missing (mentioned in this thread) and it works, but it switches to 320x240 portrait mode when I run it. Is there a fix for this? I'm on a C1000 with Cacko 1.23 (full). I also tried one of the "home brewed" versions that was linked to here (0.2.4-1) and the same thing happens.
Go to the top of the page
 
+Quote Post
Jon_J
post Mar 17 2007, 03:25 PM
Post #57





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



QUOTE(mscdex @ Mar 17 2007, 06:19 PM)
I installed cosair 0.2.6 along with the two libraries I was missing (mentioned in this thread) and it works, but it switches to 320x240 portrait mode when I run it. Is there a fix for this? I'm on a C1000 with Cacko 1.23 (full). I also tried one of the "home brewed" versions that was linked to here (0.2.4-1) and the same thing happens.
*

Click and hold the stylus on the icon. A properties box will come up. Uncheck "run with magnified screen"
Go to the top of the page
 
+Quote Post
mscdex
post Mar 17 2007, 04:26 PM
Post #58





Group: Members
Posts: 55
Joined: 7-August 05
Member No.: 7,809



QUOTE(Jon_J @ Mar 17 2007, 07:25 PM)
QUOTE(mscdex @ Mar 17 2007, 06:19 PM)
I installed cosair 0.2.6 along with the two libraries I was missing (mentioned in this thread) and it works, but it switches to 320x240 portrait mode when I run it. Is there a fix for this? I'm on a C1000 with Cacko 1.23 (full). I also tried one of the "home brewed" versions that was linked to here (0.2.4-1) and the same thing happens.
*

Click and hold the stylus on the icon. A properties box will come up. Uncheck "run with magnified screen"
*



Thanks. I'm still getting used to a lot of this tongue.gif

Now if only it supported inline images in rss feeds, as I noticed it only shows gray boxes.
Go to the top of the page
 
+Quote Post
Madbot
post Oct 21 2007, 06:59 AM
Post #59





Group: Members
Posts: 4
Joined: 15-October 07
Member No.: 20,823



Hi there,

I installed Corsair on my 860 with 1.40J rom without any problem. However, the posts don't seem to include the images. The posts leaves a gray space where the images would have been but I'm unable to see the images.

One blog where there are a lot of images is the Gizmodo blog:

http://feeds.gawker.com/gizmodo/full

Does anyone know what I need to do in order to see the images? rolleyes.gif

Many thanks
Go to the top of the page
 
+Quote Post

4 Pages V  « < 2 3 4
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 03:37 AM