OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> link error while building QTE 2.3.7
murphytalk
post Jun 29 2004, 04:23 AM
Post #1





Group: Members
Posts: 9
Joined: 31-May 04
Member No.: 3,507



Hi everyone,

I got the following error while building QTE 2.3.7,in the phase of
building tutorial/t1:

libqte.so: undefined reference to 'QWizard::selected(QString const&)'

libqte.so is there in $QTDIR/lib

any hints? thank you in advance wink.gif
Go to the top of the page
 
+Quote Post
lpotter
post Jun 29 2004, 09:25 PM
Post #2





Group: Members
Posts: 451
Joined: 27-November 03
From: Brisbane, Australia
Member No.: 1,001



how did you configure it? You should use the qconfig-qpe.h thats in the qtopia/src/qt directory of Qtopia and configure qte with it:
./configure -qconfig qpe
Go to the top of the page
 
+Quote Post
murphytalk
post Jun 30 2004, 06:44 AM
Post #3





Group: Members
Posts: 9
Joined: 31-May 04
Member No.: 3,507



QUOTE(lpotter @ Jun 30 2004, 02:25 PM)
how did you configure it? You should use the qconfig-qpe.h thats in the qtopia/src/qt directory of Qtopia and configure qte with it:
./configure -qconfig qpe

Thank you.

I copied qconfig-qpe.h to qconfig-local.h and chose local configuration while configure,so I guess it should be same as use qconfig-qpe directly. Anyway I would follow your suggestion ,use ./configure -qconfig qpe to try again.

Thank you wink.gif
Go to the top of the page
 
+Quote Post
zautrix
post Jun 30 2004, 08:16 AM
Post #4





Group: Members
Posts: 437
Joined: 3-February 04
From: N54°22.5' E10°08.2'
Member No.: 1,678



Maybe the hint from lpotter helps.

I had the same problem, I had to link against libqtopia to get rid of the error.

But only for compiling for the destop and qvfb.

When I compile for Sharp, I do not need to link against it.
(libqtopia is not available on my 760, such that the linking would give a program, which does not run on the Zaurus )
Go to the top of the page
 
+Quote Post
murphytalk
post Jun 30 2004, 06:34 PM
Post #5





Group: Members
Posts: 9
Joined: 31-May 04
Member No.: 3,507



QUOTE(zautrix @ Jul 1 2004, 01:16 AM)
Maybe the hint from lpotter helps.

I had the same problem, I had to link against libqtopia to get rid of the error.

But only for compiling for the destop and qvfb.

When I compile for Sharp, I do not need to link against it.
(libqtopia is not available on my 760, such that the linking would give a program, which does not run on the Zaurus )

Yes,lpotter's hint DOES help, it's OK now.
but still don't understand which part of my approach goes wrong blink.gif
Go to the top of the page
 
+Quote Post
Ashitaka
post Jun 30 2004, 11:24 PM
Post #6





Group: Members
Posts: 58
Joined: 7-June 04
From: Tokyo
Member No.: 3,599



Tomorrow I'll release a complete package+script to install all the cross-compiling environment for the Zaurus (with the libraries). Just wait smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 12:39 PM