OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> One Application In Several Windows? Help!, Qtopia out-of-control
sdjf
post Jan 3 2006, 03:19 AM
Post #1





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



Qtopia 1.5.0 often seems to open the same application multiple times concurrently without keeping track of which has been modified most recently.

This seems to happen in ROM 2.38 for sure, reeking havoc because you can't tell which is the one it'll save if it's writing files.

Has anyone else noticed this? It's especially problematic in qtmail.

It does this with the text editor as well. But there, you can exit instead of saying okay, so you are still able to save the newer version.

But in qtmail, it's the _oldest_ rather than the newest versions of email drafts that are automatically saved. And qtmail forgets that it's already downloaded current emails I've left on the server, downloading additional copies the next time around.

I also have a hunch that the same faulty logic is at the root of some of my problems with Opera ignoring the networking/modem's actual status.

Does anyone know if this multiple hidden window issue (or whatever the common issue is) has been resolved in 3.xx?

Thanks,

sdjf
Go to the top of the page
 
+Quote Post
sdjf
post Jan 26 2006, 07:21 AM
Post #2





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



QUOTE(sdjf @ Jan 3 2006, 03:19 AM)
Qtopia 1.5.0 often seems to open the same application multiple times concurrently without keeping track of which has been modified most recently. 
This seems to happen in ROM 2.38 for sure, reeking havoc because you can't tell which is the one it'll save if it's writing files.

Does anyone know if this multiple hidden window issue (or whatever the common issue is) has been resolved in 3.xx?
*


My hunch is that when I tap hard on a GUI, which I have to do as my Z doesn't register light taps, that the Z registers it as two processes instead of one. And when the second one is completed, it reverts to the earlier one, totally ignoring the updated information and saving the wrong earlier files.

Again, has anybody seen this happening? It really screws up qtmail on my 2.38 and I'd appreciate some testing by someone with a 3.xx whose qtmail is in use often.

Do you ever notice it loading the same messages over and over? And no record of some of your sent emails?

I bet it won't happen if you open qtmail from the console, and never access the inbox with the same session as you write/send one.

Session 1...get messages..then exit

Session 2...ONLY after the previous session's process is done do you then do another qtmail session for writing.

bash-2.05# ps
PID TTY TIME CMD
4629 ttya0 00:00:00 bash
4770 ttya0 00:01:36 qtmail
4835 ttya0 00:00:00 ps
bash-2.05#
[1]+ Done qtmail

Shouldn't have to do this from command line but routine prevents the problem in 2.38 qtmail. qtopia 1.5.0

Is it necessary on 3.xx versions? I'm having some issues with other apps but not sure yet if or how they're really related.

The simplest way to recognize it may be if you flip from one screen display to a second, and then when you go back to the first, your earlier work has disappeared. If you exited screen 2 that work may be gone forever.

Comments, anyone?

sdjf
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st August 2014 - 08:01 PM