OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Apt-get Errors, Resolved (with a few kinks, but working)!
dkm
post Apr 30 2008, 09:35 AM
Post #1





Group: Members
Posts: 15
Joined: 26-August 06
From: Iowa, USA
Member No.: 10,994



I've been running into a couple of problems trying to install or upgrade software that I'm hoping you all can help with. First, I'm using the EABI-armel with a yonggun kernel (2.6.24.3) on an SL-C3200, and have set up to run sid/unstable in my sources (main, contrib, & non-free), plus the repository for some of the debs posted in this forum. And, yes, I've run apt-get update (w/ no error messages), apt-get upgrade, and apt-get dist-upgrade with these repositories in the source.list file.

Problem #1: libts-0.0-0 error
A couple programs I am trying to install have a dependency for version >=1.0 (e.g., XFCE4, which depends on libdirectfb-1.0-0, which in turn depends on libts* >=1.0). When I try to install the appropriate package (libts-0.0-0_1.0-4_armel.deb), either on its own or as a dependency of one of these other programs, I get an error that it is trying to overwrite /usr/lib/ts/collie.so. The error is as follows:

dpkg: error processing /var/cache/apt/archives/libts-0.0-0_1.0-4_armel.deb (--upack):
trying to overwrite '/usr/lib/ts/collie.so', which is also in package libts-1.-0
Errors were encountered while processing:
/var/cache/apt/archives/libts-0.0-0_1.04_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I can try to apt-get -f install (with no package name), but I'm hesitant to do this (seems unsafe) without advice from some more knowledgeable apt/debian folks. The Apt How-to on Debian's site doesn't really address using -f well to relieve my anxiety about running it without indicating a specific package. I've run apt-get -f install libts-0.0-0, but get the same error that I do when I run without the -f flag.

Problem #2: 5 packages that seem to be unable to upgrade without removing some packages I don't think I want removed
There are a number of packages that have available upgrades (e.g., claws-mail, libpng12-0, & pciutils), that don't want to upgrade without removing the following packages: libdirectftb-1.0-0 [interesting given connection to problem #1], libsdl1.2debian, libsdl1.2debian-alsa
links2, & mplayer. I haven't followed the chain of interlocking dependencies to see why this is, but it seems odd that these packages need removed rather than possibly upgraded themselves. Anybody run into something like this? Any advice?

Thanks in advance.
Go to the top of the page
 
+Quote Post
urkden
post May 1 2008, 11:04 AM
Post #2





Group: Members
Posts: 63
Joined: 24-December 06
Member No.: 13,382



QUOTE(dkm @ Apr 30 2008, 07:35 PM) *
I've been running into a couple of problems trying to install or upgrade software that I'm hoping you all can help with. First, I'm using the EABI-armel with a yonggun kernel (2.6.24.3) on an SL-C3200, and have set up to run sid/unstable in my sources (main, contrib, & non-free), plus the repository for some of the debs posted in this forum. And, yes, I've run apt-get update (w/ no error messages), apt-get upgrade, and apt-get dist-upgrade with these repositories in the source.list file.

Problem #1: libts-0.0-0 error
A couple programs I am trying to install have a dependency for version >=1.0 (e.g., XFCE4, which depends on libdirectfb-1.0-0, which in turn depends on libts* >=1.0). When I try to install the appropriate package (libts-0.0-0_1.0-4_armel.deb), either on its own or as a dependency of one of these other programs, I get an error that it is trying to overwrite /usr/lib/ts/collie.so. The error is as follows:

dpkg: error processing /var/cache/apt/archives/libts-0.0-0_1.0-4_armel.deb (--upack):
trying to overwrite '/usr/lib/ts/collie.so', which is also in package libts-1.-0
Errors were encountered while processing:
/var/cache/apt/archives/libts-0.0-0_1.04_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I can try to apt-get -f install (with no package name), but I'm hesitant to do this (seems unsafe) without advice from some more knowledgeable apt/debian folks. The Apt How-to on Debian's site doesn't really address using -f well to relieve my anxiety about running it without indicating a specific package. I've run apt-get -f install libts-0.0-0, but get the same error that I do when I run without the -f flag.

Problem #2: 5 packages that seem to be unable to upgrade without removing some packages I don't think I want removed
There are a number of packages that have available upgrades (e.g., claws-mail, libpng12-0, & pciutils), that don't want to upgrade without removing the following packages: libdirectftb-1.0-0 [interesting given connection to problem #1], libsdl1.2debian, libsdl1.2debian-alsa
links2, & mplayer. I haven't followed the chain of interlocking dependencies to see why this is, but it seems odd that these packages need removed rather than possibly upgraded themselves. Anybody run into something like this? Any advice?

Thanks in advance.


#1 'm almost sure that there's a post a little bit under this with a package to solve this problem with libdirectfb and libts.

#2 It should a matter of trying after solving libdirectfb and libts issues.

P.D.: I'm planning a fresh install soon from tarball, I've mesed up lots of things trying to understand how things work. I've delayed it waiting for the new tarball ZDevil was preparingbut my Z is almost unusable right now, If i get to overpass this situations I'll try to post it here asap.
Go to the top of the page
 
+Quote Post
dkm
post May 1 2008, 03:51 PM
Post #3





Group: Members
Posts: 15
Joined: 26-August 06
From: Iowa, USA
Member No.: 10,994



QUOTE(urkden @ May 1 2008, 02:04 PM) *
#1 'm almost sure that there's a post a little bit under this with a package to solve this problem with libdirectfb and libts.

Found it (it is here for anyone else who finds this first). There appear to be some issues with the solution (I get the "error while loading shared libraries: libts-1.0.so.0: cannot open shared object file: No such file or directory", although it appears to be a problem only if you need to recalibrate, e.g., if you try to use XFCE4 after installing), but hopefully the incredibly hardworking Zdevil will figure out a solution that is escaping us mere mortals.

QUOTE
#2 It should a matter of trying after solving libdirectfb and libts issues.

P.D.: I'm planning a fresh install soon from tarball, I've mesed up lots of things trying to understand how things work. I've delayed it waiting for the new tarball ZDevil was preparingbut my Z is almost unusable right now, If i get to overpass this situations I'll try to post it here asap.


#2 is as you say- solve #1, and #2 is resolved.

I've re-installed several times now after making a mess tinkering. Each time I learn a bit more, including how to dig a deeper hole for myself. wink.gif

Thanks for your help!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd September 2014 - 08:28 PM