OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Apt Pinning, A must for using mixed repos
ZDevil
post Dec 15 2007, 11:16 PM
Post #1





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Found a nice newbie-friendly article on apt pinning, which enables the user to prioritize the repos in /etc/apt/sources.list instead of installing/upgrading things simply based on the versioning of the packages:

http://jaqque.sbih.org/kplug/apt-pinning.html

One immediate use I thought of is to assign the highest priority to jpmatrix's custom repo, so that 2or0's mplayer won't get replaced by apt-get dist-upgrade. smile.gif
Go to the top of the page
 
+Quote Post
scottlfa
post Dec 16 2007, 08:19 AM
Post #2





Group: Members
Posts: 283
Joined: 1-October 07
From: Blacksburg, SC, USA
Member No.: 20,773



VERY Helpful, helps with gnumeric too which is broken in armel.

Whats the soure entry for 2or0's custom repo? I have jpmatrix one mentioned in your signature, noticed mplayer wasn't in there.
Go to the top of the page
 
+Quote Post
cal
post Jan 26 2010, 12:41 PM
Post #3





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



QUOTE(ZDevil @ Dec 16 2007, 02:16 AM) *
Found a nice newbie-friendly article on apt pinning, which enables the user to prioritize the repos in /etc/apt/sources.list instead of installing/upgrading things simply based on the versioning of the packages:

http://jaqque.sbih.org/kplug/apt-pinning.html

One immediate use I thought of is to assign the highest priority to jpmatrix's custom repo, so that 2or0's mplayer won't get replaced by apt-get dist-upgrade. smile.gif



My /etc/apt/preferences is pretty much exactly whats on that link plus a line to keep udev from upgrading. Any others? Maybe we should keep a list of potential apt pit falls.

CODE
Package: udev
Pin: version 0.114-2
Pin-Priority: 1001

Package: *
Pin: release a=stable
Pin-Priority: 700

Package: *
Pin: release a=testing
Pin-Priority: 650

Package: *
Pin: release a=unstable
Pin-Priority: 600


Cal
PS my udev pin might not be at the highest possible version, but it hasn't caused a problem yet.
Go to the top of the page
 
+Quote Post
axeTail
post Jan 27 2010, 11:11 AM
Post #4





Group: Members
Posts: 76
Joined: 14-December 07
Member No.: 21,073



QUOTE(cal @ Jan 26 2010, 10:41 PM) *
QUOTE(ZDevil @ Dec 16 2007, 02:16 AM) *
Found a nice newbie-friendly article on apt pinning, which enables the user to prioritize the repos in /etc/apt/sources.list instead of installing/upgrading things simply based on the versioning of the packages:

http://jaqque.sbih.org/kplug/apt-pinning.html

One immediate use I thought of is to assign the highest priority to jpmatrix's custom repo, so that 2or0's mplayer won't get replaced by apt-get dist-upgrade. smile.gif



My /etc/apt/preferences is pretty much exactly whats on that link plus a line to keep udev from upgrading. Any others? Maybe we should keep a list of potential apt pit falls.

CODE
Package: udev
Pin: version 0.114-2
Pin-Priority: 1001

Package: *
Pin: release a=stable
Pin-Priority: 700

Package: *
Pin: release a=testing
Pin-Priority: 650

Package: *
Pin: release a=unstable
Pin-Priority: 600


Cal
PS my udev pin might not be at the highest possible version, but it hasn't caused a problem yet.



Thanks for the info, my udev is broken....any ideas on how to fix it?
Go to the top of the page
 
+Quote Post
cal
post Jan 27 2010, 06:09 PM
Post #5





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



QUOTE(axeTail @ Jan 27 2010, 02:11 PM) *
QUOTE(cal @ Jan 26 2010, 10:41 PM) *
QUOTE(ZDevil @ Dec 16 2007, 02:16 AM) *
Found a nice newbie-friendly article on apt pinning, which enables the user to prioritize the repos in /etc/apt/sources.list instead of installing/upgrading things simply based on the versioning of the packages:

http://jaqque.sbih.org/kplug/apt-pinning.html

One immediate use I thought of is to assign the highest priority to jpmatrix's custom repo, so that 2or0's mplayer won't get replaced by apt-get dist-upgrade. smile.gif



My /etc/apt/preferences is pretty much exactly whats on that link plus a line to keep udev from upgrading. Any others? Maybe we should keep a list of potential apt pit falls.

CODE
Package: udev
Pin: version 0.114-2
Pin-Priority: 1001

Package: *
Pin: release a=stable
Pin-Priority: 700

Package: *
Pin: release a=testing
Pin-Priority: 650

Package: *
Pin: release a=unstable
Pin-Priority: 600


Cal
PS my udev pin might not be at the highest possible version, but it hasn't caused a problem yet.



Thanks for the info, my udev is broken....any ideas on how to fix it?



Sorry, I don't really.
Maybe you can roll back with sudo aptitude install <pkgname>=<version>
Go to the top of the page
 
+Quote Post
HRH_H_Crab
post Feb 26 2010, 07:22 AM
Post #6





Group: Members
Posts: 36
Joined: 29-August 06
Member No.: 11,035



QUOTE(axeTail @ Jan 27 2010, 07:11 PM) *
Thanks for the info, my udev is broken....any ideas on how to fix it?


Look at my post in the Udev and Kernel thread.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 08:57 PM