OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Spectrum24 On 3.5.4.2 Rc2 (poodle), a.k.a the driver that wouldn't load
wayne
post Apr 20 2007, 03:32 PM
Post #1





Group: Members
Posts: 42
Joined: 2-April 05
Member No.: 6,775



In the discussions of the 3.5.4.2 release page (in the wiki), I asked months ago why my Symbol Low Power Spectrum24 LA-4137 card wouldn't load in OZ 3.5.4.2 while it does in Watapon Rom.

Someone responded with something along the lines of "You need to install prism3 support"

So I grabbed prism3-firmware and prism3-support from the feed browser, uploaded to SD card, then flashed to openzaurus. Once up and running, i basically ran "ipkg install prism3-firmware..." and it worked. Then I try to "ipkg install prism3-support..." and it reports an error, stating this package depends on hostap-utils.

I then tried to download hostap-utils from the feed browser, copy to SD, and install that. It worked (as in, it installed), so then i installed prism3-support. After all of that (and a reboot to be sure), the same problem happens: Whenever I plug the card in, "dmesg" reports errors regarding the fact that firmware sp24-fw couldn't be located.

Does anyone here have any pointers for me to try and find the cause of this?

I have a friend that has the exact same wifi card that runs 3.5.4.1 I beleive on a clamshell unit. He said he uses hostap as a driver, not spectrum/orinoco/hermes because he uses kismet, which works. Evidently, this would be my ultimate goal, I would rather have the hostap driver work with my card.

Regardless of the driver, I understand I still need to resolve my firmware problem, which is probably the only reason why the refault spectrum/orinoco/hermes drivers are not functioning.

Any help would be greatly appreciated. I have searched quite a lot on these forums, the wiki and googling, to no avail. Perhaps I am not expert enough to resolve this issue, but I would be very happy if someone could help me out a bit.

Even though opie on the poodle has a few glitches, I would be so happy to finally get openzaurus on my unit smile.gif
Go to the top of the page
 
+Quote Post
wayne
post Apr 22 2007, 08:02 PM
Post #2





Group: Members
Posts: 42
Joined: 2-April 05
Member No.: 6,775



As a reference for future use, the solution was found in this thread http://www.oesf.org/forums/index.php?showtopic=23521

Also, the generated firmware files are to be placed in /lib/firmware
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2014 - 11:13 AM