OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> A Nice Surprise, reasonable NIC performance over USB
iamasmith
post Feb 20 2006, 11:19 AM
Post #1





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



I just bought a Sitecom LN-029 USB2 NIC having struck out on buying a CF based 10/100 NIC locally and deciding to spend the grand total of £24 at Maplins (uk electronic buff store) on a USB NIC. hehe.. even managed to persuate the guy at the store to open the box so I could see if OpenBSD recognised it as I had intended to get a CF NIC and didn't have the USB supported list with me.

Anyway, I though USB, it's got to be really slow and I certainly aren't going to get USB2 speeds out of it, however, here's the results of 2 transfers.

andrews@aslinhome ~ $ time scp pak1.pak mungo:quake/id1
pak1.pak 100% 33MB 423.5KB/s 01:19

real 1m21.767s
user 0m1.024s
sys 0m0.200s
andrews@aslinhome ~ $ time scp pak1.pak mungo:quake/id1
pak1.pak 100% 33MB 548.4KB/s 01:01

real 1m4.063s
user 0m1.064s
sys 0m0.180s
andrews@aslinhome ~ $

The first transfer was over my NL2511-CF WLAN CF card and the second one was over the USB NIC, it's actually pretty reasonable... certainly just cutting the overhead of the WLAN stuff from the transmission increases throughput quite a bit.

it's got me wondering what a CF based 10/100 card would be like though now tongue.gif

anyway I think I will be using this a lot for those long compiles now, certainly if nothing else my Zaurus should stay a little cooler than it was with the Wifi card in all that time.

- Andy
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 21 2006, 07:23 AM
Post #2





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



*sigh*

Ah well the NIC wasn't quite as good as I thought it was.

As soon as I started using NFS over it I started to get unresponsive server messages.

Suspecting that I was getting packet drop because it was full duplex I configured it to 10BaseT without the mediaopts to set it to full-duplex.

And I still got unresponsive messages sad.gif

Then I noticed that the LEDs on the thing were still saying 100Mbs so checking with ifconfig I got...

media : 10BaseT (100BaseTX full-duplex)

damn, ah well it's getting retired until I see some driver updates.

(and no my crummy Wifi Access Point which doubles as a switch doesn't have an option to fix the port rate either sad.gif)

- Andy
Go to the top of the page
 
+Quote Post
albertr
post Feb 21 2006, 07:52 AM
Post #3





Group: Members
Posts: 535
Joined: 7-March 04
Member No.: 2,195



I know that you're using obsd, but under Linux 2.4 I had to tweak the driver for realtek8150-based usb nic to work reasonably well on my Z.
-albertr
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 21 2006, 09:15 AM
Post #4





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(albertr @ Feb 21 2006, 03:52 PM)
I know that you're using obsd, but under Linux 2.4 I had to tweak the driver for realtek8150-based usb nic to work reasonably well on my Z.
-albertr
*


This isn't a realtek device it's a ASIX Electronics AX88172 controller and it's supposed to be well supported in OpenBSD... apparently tongue.gif

Actually I just managed to get this 'heap' of a WLAN router to switch to 10Mbit Half Duplex so I will see if this works better. The strange thing is that it goes to 100Mbit if I set 10BaseT immediately but if I switch to 100BaseTX it switches to 10BaseT (very strange), I can then switch the port to 10BaseT and both the router and the NIC agree 10BaseT.... (methinks time to scrap this router at some point).

- Andy
Go to the top of the page
 
+Quote Post
Sequethin
post Feb 26 2006, 12:22 PM
Post #5





Group: Members
Posts: 72
Joined: 12-December 04
Member No.: 5,903



Im using a linksys card, seen as axe0. Works fine through usb, never had a problem with nfs or otherwise.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 09:09 PM