OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Sl_c3200 Sleeps And Won't Wake Back Up
band-aid
post Aug 25 2007, 09:28 AM
Post #1





Group: Members
Posts: 37
Joined: 30-July 07
Member No.: 18,631



If I leave my SL_C3200 on for a while it sleeps, as it should. But when I try to wake it back up the screen will not come back on. The battery reports 40% at this time. I know that it is in fact awake because the Ambicom wireless card I have begins blinking. I am running Angstrom test-20070814. Thanks for the help.
Go to the top of the page
 
+Quote Post
speculatrix
post Aug 28 2007, 02:33 PM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(band-aid @ Aug 25 2007, 06:28 PM)
If I leave my SL_C3200 on for a while it sleeps, as it should. But when I try to wake it back up the screen will not come back on. The battery reports 40% at this time. I know that it is in fact awake because the Ambicom wireless card I have begins blinking. I am running Angstrom test-20070814. Thanks for the help.
*


I found this problem could be cured by creating scripts in the APM dirs so that when the zaurus unsuspends, the hinge opens or is rotated, it will restore the screen state - brightness and LCD on.

So, when I unsuspend, sometimes the display flashes on then goes out, and I simply close the lid and open it, and the Z is back.

I posted the scripts to the angstrom mailing list a while back.
Go to the top of the page
 
+Quote Post
band-aid
post Sep 3 2007, 12:12 PM
Post #3





Group: Members
Posts: 37
Joined: 30-July 07
Member No.: 18,631



QUOTE(speculatrix @ Aug 28 2007, 05:33 PM)
QUOTE(band-aid @ Aug 25 2007, 06:28 PM)
If I leave my SL_C3200 on for a while it sleeps, as it should. But when I try to wake it back up the screen will not come back on. The battery reports 40% at this time. I know that it is in fact awake because the Ambicom wireless card I have begins blinking. I am running Angstrom test-20070814. Thanks for the help.
*


I found this problem could be cured by creating scripts in the APM dirs so that when the zaurus unsuspends, the hinge opens or is rotated, it will restore the screen state - brightness and LCD on.

So, when I unsuspend, sometimes the display flashes on then goes out, and I simply close the lid and open it, and the Z is back.

I posted the scripts to the angstrom mailing list a while back.
*



Any chance you could paste in an example of one of these scripts here? Knowing my luck I'd screw something up and end up with a script that turns the brightness to zero whenever the screen is opened or rotated.
Go to the top of the page
 
+Quote Post
speculatrix
post Sep 3 2007, 01:52 PM
Post #4





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



http://lists.linuxtogo.org/pipermail/angst...une/000312.html
Go to the top of the page
 
+Quote Post
speculatrix
post Sep 4 2007, 01:07 PM
Post #5





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



I also added my backlight recovery and screen on code to the zaurusd resume script as I too sometimes find it will not resume cleanly - it seems to help, otherwise I'd have to close and reopen the lid to trigger the other scripts!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th August 2014 - 07:07 AM