OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> My (bad) Experience With Oz 3.5.1, Trying to help new versions to be better
dipnlik
post Nov 29 2004, 09:24 AM
Post #1





Group: Members
Posts: 13
Joined: 16-November 04
Member No.: 5,485



Hi all.

My problems with OZ 3.5.1 (or: what I expected to do with a basic OZ and couldn't figure out how to do it):

1) Can't beam or receive contacts or images to or from my Sony-E T300.
2) Can't install software properly. At least embedded-konsole worked, but xmms, opie-mpegplayer, mp3blaster, qplot, opera, korganizer, lightapplet, subapplet, all were nowhere to be found (not installed?) or non-functional.
3) Can't rename/move/delete icons from the Launcher. Shouldn't a tap-and-hold popup a context menu?
4) What's the language indicator (that appears left of the clock) about? Changed it from EN to PT but didn't notice a thing. No context help available on that. If it is supposed to make accented characters with the thumbboard then please explain me how that works, cause it would be a very welcome addiction.

Don't know if this list is complete, but probably not. Butthings will be added here, you just wait. :^)

My opinion: OZ is good (like a lot of other Linux related stuff), but just like a lot of other Linux related stuff, it lacks some usability.

Suggestions (at least for now -- more to come, probably, in the case I stay with OZ):
- Context menus should be more disseminated, and should not take too long to appear (maybe user configurable time). I have old shortcuts on the DocTab and don't know how to delete them. Expecting tap-and-hold, delete the link, not the file.
- System should be able to do more from scratch, just in case people have bad times configuring their PCs and Zs to talk to each other, and internet and stuff. It would be better for everyone to have more software and uninstall the unneeded than the other way around.
- Trying to add a feed on Package Manager (AKPkg too), the form fields are available. I fill them, press update and nothing. Took some time to figure out that I needed to press New (and reset the form =\ ) before filling the (already enabled) form. Solution: disable the form if New is not pressed, or "press the button automatically" when entering the configure screen.

I'm not a Linux expert, and this is a palmtop. I really expect to do things using the GUI, mainly. On PalmOS and Windows Mobile everything is nice and GUI-oriented, and that's very good. OZ should be that way, it would make things easier for everyone. And I really have high hopes on OZ, that's why I complain -- to try to make it better.

Hope the developers hear my suggestions, and everyone else to coment about these and try to help me to not switch back to Sharp's again, if possible. :^)

Thanks in advance.
Go to the top of the page
 
+Quote Post
lardman
post Nov 29 2004, 09:32 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
2) Can't install software properly. At least embedded-konsole worked, but xmms, opie-mpegplayer, mp3blaster, qplot, opera, korganizer, lightapplet, subapplet, all were nowhere to be found (not installed?) or non-functional.


What did you do? Did you ipkg-link? Did you re-start opie?

QUOTE
3) Can't rename/move/delete icons from the Launcher. Shouldn't a tap-and-hold popup a context menu?


This is possibly a good idea; that said, you can't use this method to remove/rename stuff with the Sharp ROMs (iirc) so I wouldn't necessarily expect it to work with Opie.


Si
Go to the top of the page
 
+Quote Post
dipnlik
post Nov 29 2004, 10:18 AM
Post #3





Group: Members
Posts: 13
Joined: 16-November 04
Member No.: 5,485



Yes, I ipkg-linked them manually (o.O), and yes I restarted Opie. Even rebooted. XMMS, Opera and Media Player Icons appeared, but tapping them didn't open them. Running fro console gave all kind of errors. XMMS gave me segmentation faults, something about _7Q and Symbols on Opera (can't remember now, sorry), and missing libraries on Media Player. If i install software with all "Force" options enabled, shouldn't it just work, assuming it is properly linked? (By the package manager or by hand, but preferably by the package manager -- that's its function)

On Sharp ROM, you can edit the menu using an already installed app. Tab Settings, IIRC. That's not perfect, but makes the needed customization job. Something at least like this could be delivered with the basic OZ software (and could be removed to make room for better software to make the same job).
In fact, I got used to context menus from desktop OS's and PalmOS.
Go to the top of the page
 
+Quote Post
dipnlik
post Nov 29 2004, 10:41 AM
Post #4





Group: Members
Posts: 13
Joined: 16-November 04
Member No.: 5,485



Found two more problems on ToDo.

- Trying to add a Category, it does not accept the name on the first OK. You have to add one, press OK (don't bother to change the name before the OK, it doesn't work), then edit categories again, rename the "New Category" category, and then you have your category.

- When I add an alarm, it defaults to "silent". o.O

Just weird.
Go to the top of the page
 
+Quote Post
Mickeyl
post Nov 29 2004, 11:04 AM
Post #5





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



4) That's probably the multikeyapplet which controls the layout of the on-screen keyboard.

The thing is, all your points are valid Opie problems - most are even known and acknowledged - but not OpenZaurus problems. You can use OpenZaurus w/ X or E or other GUI environments, too, btw.

Unfortunately, I don't see things improving Opie wise anytime soon either, since Opie itself constantly struggles against insignificance due to lack of developers - there is only a handful of caring people left. One would think, developers are running to the one and only truly Open Source Palmtop Environment based on Qt/Embedded to shape it like they want to, but alas it isn't so. I wish I had better news, but that's the way it is.
Go to the top of the page
 
+Quote Post
dipnlik
post Nov 29 2004, 01:46 PM
Post #6





Group: Members
Posts: 13
Joined: 16-November 04
Member No.: 5,485



Ok, Mickeyl, I understand you. Sorry for the mistake then. Just needed to tell that altough ppl tell lots of good things about the OZ ROM, it is (at least for me) quite challenging to make work. Or maybe i'm just unlucky that some of the software I wanted is problematic. Don't know. I'll try 3.5.1 for a while, and test 3.5.2 to see the improvements. And try not to get (too much) angry at Opie.
Go to the top of the page
 
+Quote Post
Mickeyl
post Nov 29 2004, 02:43 PM
Post #7





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



Thanks. Don't worry, the days where I took Opie's problems personally are over.

I will contribute as long as I think the developer team can achieve anything. If it dies, I'll just let it die and find something else to contribute to (actually, one project less on my shoulders would be quite a relief wink.gif )
Go to the top of the page
 
+Quote Post
lardman
post Nov 30 2004, 04:05 AM
Post #8





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
something about _7Q and Symbols on Opera


You need to install and use the compat libs on Opera.

QUOTE
and missing libraries on Media Player. If i install software with all "Force" options enabled, shouldn't it just work, assuming it is properly linked?


Hmm, no. You should be able to install things without adding any extra command line switches, if you've added something like --force-depends, then any dependency errors will be ignored - hence your missing lib problem.

That said, iirc opie-mediaplayer2 segfaults, but xmms does work (at least it does on my C750); there was a relatively recent thread about xmms in the OZ part of the forum.


Si
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 01:01 AM