OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> New Konqueror (or Other Browser For Opie)
Mr. Sinister
post Apr 19 2005, 03:08 PM
Post #1





Group: Members
Posts: 9
Joined: 14-March 05
Member No.: 6,630



The version of konqueror embedded that I have (from the official source) dates from 2003. Is there a more recent version available? Or a decent alternative browser for Opie?
Go to the top of the page
 
+Quote Post
lardman
post Apr 19 2005, 03:11 PM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Opera with the sharp-compat-libs should work.


Si
Go to the top of the page
 
+Quote Post
adf
post Apr 19 2005, 07:00 PM
Post #3





Group: Members
Posts: 2,821
Joined: 13-September 04
From: Wasilla Ak.
Member No.: 4,572



that konqueror works pertty well these days, though.....
Go to the top of the page
 
+Quote Post
Mr. Sinister
post Apr 22 2005, 09:36 AM
Post #4





Group: Members
Posts: 9
Joined: 14-March 05
Member No.: 6,630



But where can I get a modern konqueror?
Go to the top of the page
 
+Quote Post
drw
post Apr 22 2005, 11:30 AM
Post #5





Group: Members
Posts: 10
Joined: 4-February 05
Member No.: 6,411



Konq/E is built upon Qt/E 2.3.x, and back when KDE was using Qt 2.x, it was fairly easy to support both the KDE and Qtopia/Opie versions from a single code base. However, KDE has moved on to newer versions of Qt and newer versions of Konqueror no longer compile against Qt/E 2.3.x. So while there have been bug fixes made to Konq/E, newer features have not been back ported to the older code base, and I don't see that happening any time soon.

So next you will probably ask why Opie still uses an ancient version of Qt/E? Well, TrollTech itself has admitted that Qt/E 3.x is not really suited to use in limited resource devices such as PDA's. And though Qt/E 4.0 is supposed to be much better, we are still waiting for a pre-release version which compiles/works.
Go to the top of the page
 
+Quote Post
Greg2
post Apr 22 2005, 11:37 AM
Post #6





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(Mr. Sinister @ Apr 22 2005, 01:36 PM)
But where can I get a modern konqueror?

Here are the latest snapshots created by Luciano... now all you have to do is build it and they need Qt/E v3.1.x or above. The current OE/OZ build is using Qt/E v2.3.x and the latest snapshots are 2003. I'm guessing that if or when OE would use Qt/E v3.1.x or above they could use these... but I think I remember reading about another problem with that.

Then there is the possibility that I'm wrong about the whole thing!

http://www.cirulla.net/kdenox-snapshots/

Edit:
In the time it took me to find that link drw has already explained it better than I could.

Greg smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th September 2014 - 05:37 AM