OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Web Development On Z, can i get an up to date mysql version
adax
post Jan 12 2006, 07:07 AM
Post #1





Group: Members
Posts: 19
Joined: 9-January 05
From: sheffield
Member No.: 6,165



Hi all.

I'm a web developer and have managed to do some work on my Z860 in the past using the apache1.3 & mysql 3.2 software installed on cacko 1.22

Times move on and i've upgraded to cacko 1.23 lite and was looking to continue developing sites on my Z. I have found apache2-php5-mysqlclient in the package feed and installed it, that works fine.
So I set off to look for a recent version of mysql (4.1 but preferably 5)..

I managed to find an ipk for mysql 4.1 for pdaxrom, and being the rash kind of guy, installed it. smile.gif
(you can tell there is a problem coming)
Unfortunately when i tried to run the mysql daemon it complains that it cant find libstdc++.so.5
Once again i did the random hack thing and created a link from libstdc++.so to libstdc++.so.5

Obviously this didn't work but did respond with an error about GCC 3. From what i've read Cacko is using gcc 2.95 ? so this installation is never going to work.

So I was wondering whether anyone knew of an ipk for mysql that will install and run under cacko? Like I said I'm a web developer by profession so my compiling skills end just after
./configure
make
make install

Is it possible to compile mysql5 for the Z or is it one of those things that is never going to happen?
As a last resort I may consider switching to pdaXrom, but I've had my 860 for 1 year now (well, 362 days) and as soon as I got it I chose cacko because of Maslovsky's great work and skill. smile.gif

any help you can give me, even if it's "switch to pdaxrom" will be very much appreciated.
Thanks,
Adam.
Go to the top of the page
 
+Quote Post
rohanoberoi
post Jan 30 2006, 12:11 AM
Post #2





Group: Members
Posts: 22
Joined: 30-December 04
Member No.: 6,065



I'd also be interested to know if anyone has MySQL running under Cacko or Sharp ROMs. Searches of the internet and forums haven't turned up anything obvious.

Thanks




QUOTE(adax @ Jan 12 2006, 03:07 PM)
Hi all.

I'm a web developer and have managed to do some work on my Z860 in the past using the apache1.3 & mysql 3.2 software installed on cacko 1.22

Times move on and i've upgraded to cacko 1.23 lite and was looking to continue developing sites on my Z. I have found apache2-php5-mysqlclient in the package feed and installed it, that works fine.
So I set off to look for a recent version of mysql (4.1 but preferably 5)..

I managed to find an ipk for mysql 4.1 for pdaxrom, and being the rash kind of guy, installed it. smile.gif
(you can tell there is a problem coming)
Unfortunately when i tried to run the mysql daemon it complains that it cant find libstdc++.so.5
Once again i did the random hack thing and created a link from libstdc++.so to libstdc++.so.5

Obviously this didn't work but did respond with an error about GCC 3. From what i've read Cacko is using gcc 2.95 ? so this installation is never going to work.

So I was wondering whether anyone knew of an ipk for mysql that will install and run under cacko? Like I said I'm a web developer by profession so my compiling skills end just after
./configure
make
make install

Is it possible to compile mysql5 for the Z or is it one of those things that is never going to happen?
As a last resort I may consider switching to pdaXrom, but I've had my 860 for 1 year now (well, 362 days) and as soon as I got it I chose cacko because of Maslovsky's great work and skill. smile.gif

any help you can give me, even if it's "switch to pdaxrom" will be very much appreciated.
Thanks,
Adam.
*
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th March 2015 - 05:16 AM