OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> weird Samba problem
w14
post Mar 23 2004, 03:39 PM
Post #1





Group: Members
Posts: 180
Joined: 7-December 03
Member No.: 1,049



I work for a fund management company in London. We look after $4bn or so. We trade in all financial markets in the world and our trading decisions are made by a clever piece of real time software, developed in house, which takes data from Reuters, Bloomy and whatnot, processes it based on our trading strategies, and chucks out trades which are executed by our traders.

When it throws out a ticket to the traders, they have to try and fill that order as best they can. Once the order is filled, they use another app to record the prices that they actually traded at. This app saves this info to a trade file to disk named in the format YYYYmmdd-tradenumber.

So at the end of the day, a few hundred or thousand trades later, depending on the day, the trading system knows what should have been traded, and the trade files contain what was actually traded, and all this info has to be processed and reconciled.

We have other apps, again developed inhouse, to do this. These apps run on Linux boxes (IBM blades) and access the share where the trade files are kept (Win2k share) via smb.

Or, they would be on a Linux blade if Samba worked ...

We have come up against the annoying problem that when smb is used to mount a filesystem, and a directory listing is taken, random files "disappear" from the listing. They may or may not come back again if a second listing is taken, but maybe other files disappear this time.

Its kind of important to us that all the trade files get processed, so reliable directory listings are essential.

So I'm just wondering if anyone on this forum has ever come across this problem or is aware of a solution? I suspect there isn't a fix ... we have googled this one to death. This is just a wild stab in the dark in case.

Our temporary fix is to run these apps on Windows instead. Yuck. Another option which I will begin investigating tomorrow is services for unix, which I believe is now a free download from MS. Maybe an NFS mount is more reliable.

Be nicer if there was a fix for this, though ...

Anyone?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th December 2014 - 09:51 PM