OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

3 Pages V   1 2 3 >  
Reply to this topicStart new topic
> Working Packages On Eabi, what is not broken ?
Chero
post Nov 6 2007, 01:12 PM
Post #1





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



I keep on reading about broken eabi packages, but I can install most I want, so this thread is to report what works !

xfce4 + goodies (mousepad, Terminal, thunar)
icewm and icewm-experimental
evolution
dates - contacts - tasks (pimlico)
leafpad
python and python apps (TaskCoach)
sylpheed-claws
iceweasel
galeon
dillo
wireless-tools
gtodo
nano
nautilus
gftp
gnumeric
homebank
QCad
gnome-system-monitor

Thanks to the-never-sleeping-ZDevil :
portabase
notecase
tuxcards

That's all I can think of right now,
Chero.
Go to the top of the page
 
+Quote Post
scottlfa
post Nov 6 2007, 07:40 PM
Post #2





Group: Members
Posts: 283
Joined: 1-October 07
From: Blacksburg, SC, USA
Member No.: 20,773



After getting the right source.list I got the following to install;

gnumeric
abiword
nano
gnome-session (running gnome as my wm atm)
gnome-nettools
gnome-utils
gnome-system-tools
xfce4
evolution
homebank
dillo
python etc ...
synaptic
gftp
nautilus
gps
iceweasel
alsa stuff
Thunar
pcman file
pidgin (though I get a FATAL: Module snd_seq_oss not found )
... testing others atm.

Go to the top of the page
 
+Quote Post
jpmatrix
post Nov 6 2007, 11:48 PM
Post #3





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



updated my sources.list,
then apt-get install iceweasel,
but when i launch it, it takes 100% cpu for one minute then it segfaults...... any idea ?
Go to the top of the page
 
+Quote Post
Chero
post Nov 7 2007, 12:56 AM
Post #4





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



QUOTE(jpmatrix @ Nov 7 2007, 08:48 AM) *
updated my sources.list,
then apt-get install iceweasel,
but when i launch it, it takes 100% cpu for one minute then it segfaults...... any idea ?


adding memory / swap ?
Go to the top of the page
 
+Quote Post
jpmatrix
post Nov 7 2007, 01:21 AM
Post #5





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(Chero @ Nov 7 2007, 09:56 AM) *
QUOTE(jpmatrix @ Nov 7 2007, 08:48 AM) *
updated my sources.list,
then apt-get install iceweasel,
but when i launch it, it takes 100% cpu for one minute then it segfaults...... any idea ?


adding memory / swap ?


i've 480mb on /dev/hda2.........
Go to the top of the page
 
+Quote Post
jpmatrix
post Nov 7 2007, 05:52 AM
Post #6





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(scottlfa @ Nov 7 2007, 04:40 AM) *
After getting the right source.list I got the following to install;

iceweasel
pidgin (though I get a FATAL: Module snd_seq_oss not found )
... testing others atm.


-still cannot launch iceweasel....
trying nautilus right now

-pidgin is ok ! although i preffer a litgher multi im :
psi which works great
Go to the top of the page
 
+Quote Post
scottlfa
post Nov 7 2007, 08:02 AM
Post #7





Group: Members
Posts: 283
Joined: 1-October 07
From: Blacksburg, SC, USA
Member No.: 20,773



segfault on iceweasel too, using dillo atm to browse the web.

I have 64 swap, haven't seen it use nearly half of that at the moment.
Go to the top of the page
 
+Quote Post
jpmatrix
post Nov 7 2007, 08:05 AM
Post #8





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



in my quest for an advanced browser :

-epiphany (apt-get install epiphany-browser) : this one works!
Go to the top of the page
 
+Quote Post
scottlfa
post Nov 7 2007, 09:47 AM
Post #9





Group: Members
Posts: 283
Joined: 1-October 07
From: Blacksburg, SC, USA
Member No.: 20,773



any way to get the package locales installed? keep getting locale related errors from perl during installs, just warnings.
Go to the top of the page
 
+Quote Post
dlj0
post Nov 7 2007, 10:21 AM
Post #10





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(Chero @ Nov 7 2007, 03:56 AM) *
QUOTE(jpmatrix @ Nov 7 2007, 08:48 AM) *
updated my sources.list,
then apt-get install iceweasel,
but when i launch it, it takes 100% cpu for one minute then it segfaults...... any idea ?


adding memory / swap ?

I got this behavior with 384M swap. How much do you think we should have? Aa far as I know there is no way to add memory to these things. If that's not true, I'd love to hear how it can be done.

BTW, I also get a segfault with icedove. These were a big reason I tried to go back to titchy using my backup. This did not work.... So, I am really interested in fixing these problems.
Go to the top of the page
 
+Quote Post
dlj0
post Nov 7 2007, 10:25 AM
Post #11





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(scottlfa @ Nov 7 2007, 12:47 PM) *
any way to get the package locales installed? keep getting locale related errors from perl during installs, just warnings.

I tried adding locales packages, with no improvement. There should be a locale configuration step that seems to be missing.
Go to the top of the page
 
+Quote Post
scottlfa
post Nov 7 2007, 11:28 AM
Post #12





Group: Members
Posts: 283
Joined: 1-October 07
From: Blacksburg, SC, USA
Member No.: 20,773



typing- export LC_ALL=C
seems to fix the locale issue, so I am adding it to the profile.
Go to the top of the page
 
+Quote Post
scottlfa
post Nov 11 2007, 09:51 PM
Post #13





Group: Members
Posts: 283
Joined: 1-October 07
From: Blacksburg, SC, USA
Member No.: 20,773



Did a fresh install of Debian EABI, steps work reasonably well ... repo's seem to have some major issue's

Zaurus:~# apt-get install xfce4
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xfce4: Depends: xfwm4 (>= 4.4.1) but it is not going to be installed
Depends: xfwm4-themes (>= 4.4.1) but it is not going to be installed
Depends: xfce4-mcs-plugins (>= 4.4.1) but it is not going to be installed
Depends: xfce4-panel (>= 4.4.1) but it is not going to be installed
Depends: xfdesktop4 (>= 4.4.1) but it is not going to be installed
Depends: thunar (>= 0.8.0) but it is not going to be installed
Depends: xfce4-utils (>= 4.4.1) but it is not going to be installed
Depends: gtk2-engines-xfce (>= 2.4.1) but it is not going to be installed
Depends: xfce4-session (>= 4.4.1) but it is not going to be installed
Recommends: xfce4-mixer but it is not going to be installed
Recommends: xfprint4 but it is not going to be installed
Recommends: orage but it is not going to be installed
Recommends: xfce4-terminal but it is not going to be installed
Recommends: xfmedia but it is not going to be installed
Recommends: desktop-base but it is not going to be installed
E: Broken packages
Zaurus:~#

Just trying to install xfce4.

Useing the following in my sources.list
deb http://ftp.easynet.be/ftp/gnuab/debian sid main
deb http://ftp.easynet.be/ftp/gnuab/debian unreleased main
deb http://ftp.easynet.be/ftp/gnuab/debian unstable main
deb http://ftp.easynet.be/ftp/gnuab/debian experimental main

No love with this. Edit - Whats odd is these are the same repo's I installed from last time and this wasn't an issue.
Go to the top of the page
 
+Quote Post
Chero
post Nov 11 2007, 11:02 PM
Post #14





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



QUOTE(scottlfa @ Nov 12 2007, 06:51 AM) *
Did a fresh install of Debian EABI, steps work reasonably well ... repo's seem to have some major issue's

Zaurus:~# apt-get install xfce4
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
xfce4: Depends: xfwm4 (>= 4.4.1) but it is not going to be installed
Depends: xfwm4-themes (>= 4.4.1) but it is not going to be installed
Depends: xfce4-mcs-plugins (>= 4.4.1) but it is not going to be installed
Depends: xfce4-panel (>= 4.4.1) but it is not going to be installed
Depends: xfdesktop4 (>= 4.4.1) but it is not going to be installed
Depends: thunar (>= 0.8.0) but it is not going to be installed
Depends: xfce4-utils (>= 4.4.1) but it is not going to be installed
Depends: gtk2-engines-xfce (>= 2.4.1) but it is not going to be installed
Depends: xfce4-session (>= 4.4.1) but it is not going to be installed
Recommends: xfce4-mixer but it is not going to be installed
Recommends: xfprint4 but it is not going to be installed
Recommends: orage but it is not going to be installed
Recommends: xfce4-terminal but it is not going to be installed
Recommends: xfmedia but it is not going to be installed
Recommends: desktop-base but it is not going to be installed
E: Broken packages
Zaurus:~#

Just trying to install xfce4.

Useing the following in my sources.list
deb http://ftp.easynet.be/ftp/gnuab/debian sid main
deb http://ftp.easynet.be/ftp/gnuab/debian unreleased main
deb http://ftp.easynet.be/ftp/gnuab/debian unstable main
deb http://ftp.easynet.be/ftp/gnuab/debian experimental main

No love with this. Edit - Whats odd is these are the same repo's I installed from last time and this wasn't an issue.


what does "apt-get dist-upgrade" or "apt-get upgrade" give you ?
It can help to do one of both before installing apps.

Chero.
Go to the top of the page
 
+Quote Post
scottlfa
post Nov 11 2007, 11:12 PM
Post #15





Group: Members
Posts: 283
Joined: 1-October 07
From: Blacksburg, SC, USA
Member No.: 20,773



Zaurus:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
module-init-tools mplayer
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Zaurus:~#
Go to the top of the page
 
+Quote Post

3 Pages V   1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2014 - 03:50 PM