OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Bluetooth Cellphone Modem, Help needed, please
walts
post Sep 11 2007, 06:51 AM
Post #1





Group: Members
Posts: 57
Joined: 20-April 04
From: Florida, USA
Member No.: 2,933



I've gotten pdaXii13 running on my C3200 and everything is great! This is the best RO
M implementation I have seen on many Zaurii over the years!

Thanks to all who have helped me to get this installed and running.

Now I have a new challenge - I'd like to use my cell phone as a modem via Bluetooth. So far the only thing I can find on the subject is on Hluc's excellent page on pdaXii13:
QUOTE
GPRS network connection via Bluetooth also works. Make sure /etc/bluetooth/pin contains your PIN and then use the PPP config tool to configure the preconfigure GPRS profile to look for your phone. Then use the PPP dialer to connect to the phone to enable the GPRS connection.


I've done that, entering my Cingular information into the PPP config tool, and when I try to connect wiht the PPP dialer, it gives
"Failed to open /dev/rfcomm0: No such device"

/dev/rfcomm0 is specified as the device on the Modem tab of the PPP config tool, and was already filled in. It's just a plain text field, no other choices offered.

Based on some other threads (not for pdaXrom) it looks like hciconfig is to Bluetooth as ifconfig is to Wi-Fi, but when I run it it returns nothing.

The Bluetooth card is an AmbiCom BT2000-CF and cardctl ident says

product info: "Compact Flash", "Bluetooth Card", "", ""
manfid: 0x0319, 0x0000
function: 2 (serial)

I'm not sure where to go from here, I'd appreciate any help or advice.

TIA

Walt
Go to the top of the page
 
+Quote Post
andrewwoods
post Sep 11 2007, 09:15 AM
Post #2





Group: Members
Posts: 49
Joined: 2-August 04
Member No.: 4,184



QUOTE(walts @ Sep 11 2007, 02:51 PM)
I've gotten pdaXii13 running on my C3200 and everything is great!  This is the best RO
M implementation I have seen on many Zaurii over the years! 

Thanks to all who have helped me to get this installed and running.

Now I have a new challenge - I'd like to use my cell phone as a modem via Bluetooth.  So far the only thing I can find on the subject is on Hluc's excellent page on pdaXii13:
QUOTE
GPRS network connection via Bluetooth also works. Make sure /etc/bluetooth/pin contains your PIN and then use the PPP config tool to configure the preconfigure GPRS profile to look for your phone. Then use the PPP dialer to connect to the phone to enable the GPRS connection.


I've done that, entering my Cingular information into the PPP config tool, and when I try to connect wiht the PPP dialer, it gives
"Failed to open /dev/rfcomm0: No such device"

/dev/rfcomm0 is specified as the device on the Modem tab of the PPP config tool, and was already filled in. It's just a plain text field, no other choices offered.

Based on some other threads (not for pdaXrom) it looks like hciconfig is to Bluetooth as ifconfig is to Wi-Fi, but when I run it it returns nothing.

The Bluetooth card is an AmbiCom BT2000-CF and cardctl ident says

product info: "Compact Flash", "Bluetooth Card", "", ""
manfid: 0x0319, 0x0000
function: 2 (serial)

I'm not sure where to go from here, I'd appreciate any help or advice.

TIA

Walt
*




I have this working on Beta3, so I'm not sure how helpful my comments will be.

Firstly make sure you have searched for the phone using BT DUN on the PPP Modem dialog.

Then I found that at least one reboot of both the phone and the Zaurus was required.

HTH
Andrew
Go to the top of the page
 
+Quote Post
walts
post Sep 11 2007, 10:18 AM
Post #3





Group: Members
Posts: 57
Joined: 20-April 04
From: Florida, USA
Member No.: 2,933



QUOTE(andrewwoods @ Sep 11 2007, 12:15 PM)
I have this working on Beta3, so I'm not sure how helpful my comments will be.

Firstly make sure you have searched for the phone using BT DUN on the PPP Modem dialog.

Then I found that at least one reboot of both the phone and the Zaurus was required.

HTH
Andrew
*


Thanks, Andrew

Since pdaXii13 is derived from beta3, I think it would work.

That said, I think the issue is deeper than that. The search turns up "Can't get DUN info". The Zaurus is not discoverable either by the phone or my laptop, so I think I need a way to turn on the Bluetooth card. (The LED is blinking, which is how my Wi-Fi card behaves when it is first inserted, before it connects to the network).

I found a posting in another forum that looked like it would be helpful, but Google's Japanese translator leaves a bit to be desired -- "It is to think as the kana where is my report, my pdaXrom, (1.1rc8 deteriorates and) with can use that with the standard ...."

Amusing but not very useful biggrin.gif

Walt
Go to the top of the page
 
+Quote Post
tesla_cubed
post Sep 11 2007, 12:03 PM
Post #4





Group: Members
Posts: 28
Joined: 28-April 05
From: Joplin, Missouri USA
Member No.: 7,018



Using PadXii13 and Sprint fusic works great hope this is close enuff to help. It seems like your phone and Z aren't pared up so the phone is ignoring the Z. Here are the steps I took

1st on phone set bluetooth to on
2nd set phone to be visiable on a bluetooth scan
3rd on Z in PPP settings Click the serch button
4th the phone shows a paring request tell it OK and give it the pin "1234" unless you edited the pin to something else [the file is /etc/bluetooth/pin I think]
5th on phone set the Z as a "trusted device" then you don't have to par every time
They will the rember each other now
6ht setup PPP for yor provider
7th enjoy

Its a different provider so but i thing bluetooth paring is the same all around ymmv smile.gif

PS: oops I didnt see that the Z wasn't showing up my BT card is a diffrent brand (blekin) so I don't know if thats normal or not mine blinks when paring the light is on when in standby and off when working laugh.gif the exact inverse of my WiFi Card
Go to the top of the page
 
+Quote Post
walts
post Sep 12 2007, 02:59 AM
Post #5





Group: Members
Posts: 57
Joined: 20-April 04
From: Florida, USA
Member No.: 2,933



QUOTE(tesla_cubed @ Sep 11 2007, 03:03 PM)
Using PadXii13 and Sprint fusic works great hope this is close enuff to help. It seems like your phone and Z aren't pared up so the phone is ignoring the Z. Here are the steps I took

1st on phone set bluetooth to on
2nd set phone to be visiable on a bluetooth scan
3rd on Z in PPP settings Click the serch button
4th the phone shows a paring request tell it OK and give it the pin "1234" unless you edited the pin to something else [the file is /etc/bluetooth/pin I think]
5th on phone set the Z as a "trusted device" then you don't have to par every time
They will the rember each other now
6ht setup PPP for yor provider
7th enjoy

Its a different provider so but i thing bluetooth paring is the same all around ymmv  smile.gif

PS: oops I didnt see that the Z wasn't showing up my BT card is a diffrent brand (blekin) so I don't know if thats normal or not mine blinks when paring the light is on when in standby and off when  working  laugh.gif the exact inverse of my WiFi Card
*


Thanks, I'll try that again in the morning.

The problem I had is that at step 3, I get the message , "Can't get DUN info".

It seems like the card is not getting turned on. The hciconfig command just comes back with a shell prompt, as if there was no card in the slot, but cardctl ident gives correct results.

I'm pretty sure the hardware is OK, it worked with Cacko.

thanks for the help

Walt
Go to the top of the page
 
+Quote Post
jpmatrix
post Sep 12 2007, 05:34 AM
Post #6





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(walts @ Sep 12 2007, 12:59 PM)
QUOTE(tesla_cubed @ Sep 11 2007, 03:03 PM)
Using PadXii13 and Sprint fusic works great hope this is close enuff to help. It seems like your phone and Z aren't pared up so the phone is ignoring the Z. Here are the steps I took

1st on phone set bluetooth to on
2nd set phone to be visiable on a bluetooth scan
3rd on Z in PPP settings Click the serch button
4th the phone shows a paring request tell it OK and give it the pin "1234" unless you edited the pin to something else [the file is /etc/bluetooth/pin I think]
5th on phone set the Z as a "trusted device" then you don't have to par every time
They will the rember each other now
6ht setup PPP for yor provider
7th enjoy

Its a different provider so but i thing bluetooth paring is the same all around ymmv   smile.gif

PS: oops I didnt see that the Z wasn't showing up my BT card is a diffrent brand (blekin) so I don't know if thats normal or not mine blinks when paring the light is on when in standby and off when  working  laugh.gif the exact inverse of my WiFi Card
*


Thanks, I'll try that again in the morning.

The problem I had is that at step 3, I get the message , "Can't get DUN info".

It seems like the card is not getting turned on. The hciconfig command just comes back with a shell prompt, as if there was no card in the slot, but cardctl ident gives correct results.

I'm pretty sure the hardware is OK, it worked with Cacko.

thanks for the help

Walt
*



type: sdptool browse
to have all bluetooth services available. you'll have dialup networking channel.

are you sure of your rfcomm.conf setup ?

did you type ?
rfcomm bind rfcomm0

what does rfcomm gives you ?
Go to the top of the page
 
+Quote Post
louigi600
post Sep 12 2007, 05:45 AM
Post #7





Group: Members
Posts: 474
Joined: 21-May 06
Member No.: 9,928



I posted on some bluetooth thread here ... and I have some guides on ppp over bluetooth on my home page. Hope these can be helpfull.
Go to the top of the page
 
+Quote Post
walts
post Sep 12 2007, 07:01 AM
Post #8





Group: Members
Posts: 57
Joined: 20-April 04
From: Florida, USA
Member No.: 2,933



QUOTE(jpmatrix @ Sep 12 2007, 08:34 AM)
type: sdptool browse
to have all bluetooth services available. you'll have dialup networking channel.

are you sure of your rfcomm.conf setup ?

did you type ?
rfcomm bind rfcomm0

what does rfcomm gives you ?
*


Thanks!

From another thread I learned to do:
#setserial /dev/ttyS3 baud-base 921600
#hciattach -s 921600 /dev/ttyS3 bcsp

That seems to have activated the card.

Now, to your comments:

I have NO idea how to set up rfcomm.conf.
right now it has
CODE
rfcomm0 {
  bind yes;
  device {null};
  channel {null};
  comment "Generated by BT dial-up network applet"
}


Based on that last line, I have refrained from fiddling with it, although, honestly, I'm more at home with the command line than with some of the GUI front-ends.

#sdptool browse
appears to find my phone - it gives a lot of information, but the Service Name is Bluetooth-PDA-Sync. (That's not what I want to do, I want to use the PDA/Phone as a modem.)

CODE
#rfcomm bind rfcomm0
parse error line 3
Can't find a config entry for rfcomm0


and
#rfcomm
just returns immediately to the command prompt.


Walt
Go to the top of the page
 
+Quote Post
jpmatrix
post Sep 12 2007, 07:38 AM
Post #9





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



well,

i don't know if latest distros don't use it (or fill it themselves) but i alway do that :

1) rfcomm.conf should contain :
bind yes;
device xx:xx:xx:xx:xx:xx;
channel 1;
comment "gsm";

instead of xx:xx.. put the mac address of your gsm
you can have it with:
hcitool scan

2a) rfcomm bind rfcomm0 should now work

2b) rfcomm shoud say something like:
rfcomm0: xx:xx:xx:xx:xx:xx channel 1 clean

3) sdptool browse|more should give you a service called Dial-Up Networking (it is called like that with my Nokia...). i don't think it is the same than pda-sync. on previous bluez i had to manually fill rfcomm.conf with the same channel but i think it is not necessary now.

anyway now,
pppd call provider should now work smile.gif
Go to the top of the page
 
+Quote Post
walts
post Sep 12 2007, 12:30 PM
Post #10





Group: Members
Posts: 57
Joined: 20-April 04
From: Florida, USA
Member No.: 2,933



That's a big help, especially the information about rfcomm.conf. Apparantly that file is written by the PPP Modem applet in system tools. Once I edited it by hand it was fine.

After following your instructions I was able to "wake up" my PDA, but not connect to the network. The problems from here out appeat to be on the PDA, not the Zaurus.

Thanks for the help biggrin.gif

Walt
Go to the top of the page
 
+Quote Post
louigi600
post Sep 16 2007, 12:40 PM
Post #11





Group: Members
Posts: 474
Joined: 21-May 06
Member No.: 9,928



If you still have'nt got it working you could have a peep on my home page ... I've tcp and ppp over bluetooth guides (that should be applicable to any flavour distro) on the Zaurus Documentation section.
Go to the top of the page
 
+Quote Post
ratki
post Oct 20 2007, 01:06 PM
Post #12





Group: Members
Posts: 22
Joined: 13-January 06
From: Hungary, Budapest
Member No.: 8,922



Hi,

I had a similar 3 week long "project". I couldn't connect my new Nokia 6120 Classic to my Z.

The problem was, that all earlier used phones had the DUN (dial-up network) channel on the 1st rfcomm channel.
QUOTE(jpmatrix @ Sep 12 2007, 05:38 PM) *
well,

i don't know if latest distros don't use it (or fill it themselves) but i alway do that :

1) rfcomm.conf should contain :
bind yes;
device xx:xx:xx:xx:xx:xx;
channel 1;
comment "gsm";
...


Please check it with
CODE
sdptool search DUN


It was in my case channel 4.

BTW: May be the graphical PPP setup program makes so, but I tried to set up manually, because this program deletes the other rfcomm entries. Like my GPS.

Best wishes,

Tamas
Go to the top of the page
 
+Quote Post
mrmg
post Nov 19 2007, 08:47 AM
Post #13





Group: Members
Posts: 2
Joined: 19-November 07
Member No.: 20,960



Hi guys, hope I'm not hijacking a thread as I seem to have a very similar issue to this.

I got my Z (3100) on Friday and have been having a good play with it over the weekend. I've settled on PdaXrom as this gives a nice desktop experience and quite a bit of speed from what I've seen so far.

I managed to get DUN working fine under Cacko with very little configuration. So far in pdaxrom I've tried pairing using the gui's (PPP Modem) but the search fails with my phone (nokia e65), however I am able to pair it by using sdptool and rfcomm mentioned above and editing the files by hand.

The issue I currently have is that when using PPP Dialer the Z connects to my phone but never seems to make an actually connection out. I'm using all the defaults but have set the user/pass in PPP Modem and have set the number in the same app. The output is:

CODE
abort on (NO CARRIER)
abort on (NO DIALTONE)
abort on (BUSY)
send (^M)
expect (OK)
/* PAUSES HERE FOR A WHILE */
alarm
Failed
Connect script failed


Does anyone have any idea about how I might fix this as I'm so close to getting the bluetooth connection to work, it just doesn't seem to want to dial after connecting!

Thanks,

--
mg
Go to the top of the page
 
+Quote Post
mrmg
post Nov 19 2007, 09:36 AM
Post #14





Group: Members
Posts: 2
Joined: 19-November 07
Member No.: 20,960



Ok, solved my own problem! I'm sure I tried this a million times yesterday. I reinstalled everything today, edited rfcomm by hand, had the problem above. I went just needed to at "ATZ" as the dial prefix and now all is working. Looking forward to installing some apps now! smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th November 2014 - 03:02 PM