OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Cacko Security Hole
gazik21
post Nov 12 2008, 09:39 PM
Post #1





Group: Members
Posts: 9
Joined: 25-November 07
Member No.: 20,985



I have my Zaurus running Cacko 1.23 with my Mac Book connected to the same Wi-Fi network.
On my Mac Book in Shared I see Zaurus as a PC Server and I can browse and change the content of the SD card and HDD on it freely without any password.
I knew about this hole before, just didnt know it is so easy to see it on Mac.

Does anybody know how to close this hole?
Go to the top of the page
 
+Quote Post
tux
post Nov 13 2008, 12:36 AM
Post #2





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



QUOTE(gazik21 @ Nov 13 2008, 05:39 AM) *
I have my Zaurus running Cacko 1.23 with my Mac Book connected to the same Wi-Fi network.
On my Mac Book in Shared I see Zaurus as a PC Server and I can browse and change the content of the SD card and HDD on it freely without any password.
I knew about this hole before, just didnt know it is so easy to see it on Mac.

Does anybody know how to close this hole?

cool.gif It's all to do with Samba. smile.gif You'll need to study up on the samba documentation. I believe that you can password protect the shares. wink.gif Sorry to be vague but I have never needed to bother. This has appeared in the forums before.If you search the Security and Networking forum you might find some specific suggestions. wink.gif

This post has been edited by tux: Nov 13 2008, 12:39 AM
Go to the top of the page
 
+Quote Post
speculatrix
post Nov 15 2008, 03:34 PM
Post #3





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



take a look at /etc/samba/smb.conf and you'll be able to tweak the settings there...

very very briefly: create a username/password in the smbpasswd file for the standard non-privileged user ("smbpasswd -a username"). you can restrict then the shares to that username.
Go to the top of the page
 
+Quote Post
gazik21
post Nov 20 2008, 03:14 PM
Post #4





Group: Members
Posts: 9
Joined: 25-November 07
Member No.: 20,985



fixed it:

- installed smbpasswd - [smbpasswd_0.1-1_arm.ipk] from meanie's feed

- Once you installed smbpasswd, you will need to do the following to get it working:
# su
# ln -s /usr/local/samba/lib/codepages /usr/lib/samba/codepages
# rm /usr/local/samba/lib/smb.conf
# ln -s /usr/local/samba/lib/smb.conf /usr/lib/samba/smb.conf
# ln -s /usr/local/samba/private/smbpasswd /etc/smbpasswd

- then create user zaurus with password of your choice
sudo smbpasswd -a zaurus a

- to connect now: smb://zaurus then user:zaurus and your password

Go to the top of the page
 
+Quote Post
speculatrix
post Nov 20 2008, 03:39 PM
Post #5





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(gazik21 @ Nov 20 2008, 11:14 PM) *
fixed it:

- installed smbpasswd - [smbpasswd_0.1-1_arm.ipk] from meanie's feed

- Once you installed smbpasswd, you will need to do the following to get it working:
# su
# ln -s /usr/local/samba/lib/codepages /usr/lib/samba/codepages
# rm /usr/local/samba/lib/smb.conf
# ln -s /usr/local/samba/lib/smb.conf /usr/lib/samba/smb.conf
# ln -s /usr/local/samba/private/smbpasswd /etc/smbpasswd

- then create user zaurus with password of your choice
sudo smbpasswd -a zaurus a

- to connect now: smb://zaurus then user:zaurus and your password



thanks for letting us know.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th April 2014 - 03:42 PM