OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> .bashrc And .profile Query, .bashrc and .profile query on TKC Rom
sentinel
post Dec 8 2005, 05:22 AM
Post #1





Group: Members
Posts: 41
Joined: 23-November 05
Member No.: 8,601



Hi,

This problem has probably been asked in different ways at different times, but looking through the all posts, I could'nt seem to nail it down.

I have been trying to insert a number of shell aliases. I edited /etc/passwd to change the shell to bash, then created a .bashrc file which contained the aliases.

I rebooted, but it would'nt register the aliases, whether I insert them in .profile or .bashrc

If I issue the command alias d='ls' on the command line, then it works.

I may have missed something really obvious, as I have always used tcsh as my shell in the past.


Anyway, I can't seem to figure out the problem.

Any suggestions ?

Rgds
Neil.
Go to the top of the page
 
+Quote Post
climber
post Jun 19 2006, 11:38 PM
Post #2





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



I have the same problem as you! I want to set alias permanent like " alias ll=`ls -la`"

Where do I have to entry this data? I did the same entries like Neil but with no success too. Did someone get this problem solved?


Thanks,
climber
Go to the top of the page
 
+Quote Post
climber
post Jun 19 2006, 11:42 PM
Post #3





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



I forgott to day ......

my Device "SL-C3100" with Cacko 1.23

Regards,
climber
Go to the top of the page
 
+Quote Post
Meanie
post Jun 19 2006, 11:47 PM
Post #4





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(climber @ Jun 20 2006, 05:42 PM)
I forgott to day ......

my Device "SL-C3100" with Cacko 1.23

Regards,
climber
*


put it into /home/zaurus/.profile

create it if it doesnt exist
Go to the top of the page
 
+Quote Post
freizugheit
post Jun 20 2006, 12:50 AM
Post #5





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



QUOTE(Meanie @ Jun 19 2006, 11:47 PM)
QUOTE(climber @ Jun 20 2006, 05:42 PM)
I forgott to day ......

my Device "SL-C3100" with Cacko 1.23

Regards,
climber
*


put it into /home/zaurus/.profile

create it if it doesnt exist
*



Meanie,

Thanks for the pointer. It works on my SL-5600
Go to the top of the page
 
+Quote Post
climber
post Jun 20 2006, 01:25 AM
Post #6





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



Meanie,

thanks for your quick help :-) now it works!

Maybe you can help me with a similar problem? I use vim very often and the syntax highlighting is very smart. But everytime I start the shell I have to execute the command "export TERM=linux" to activate the syntax highlighting! I put this command to the .profile but with no success.

Do you have a idea how I get this working.


Thanks
climber
Go to the top of the page
 
+Quote Post
bam
post Jun 20 2006, 11:37 AM
Post #7





Group: Members
Posts: 1,213
Joined: 9-June 05
From: Gobi Desert, Mongolia
Member No.: 7,306



you have a /home/root/.profile? perhaps there? or maybe create a /home/zaurus/.bash_login, that way you can execute whatever during the login? also since your playing you can create a .bash_logout as well to execute scripts on logout, I use it for a script I wrote in python to sort/remove-duplicates in my .bash_history file. Also anyone know how to get the history to work while in the sh shell?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2014 - 01:02 PM