OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Google Android On Debian Eabi, with yonggun's kernel
2or0
post Jan 3 2008, 03:32 PM
Post #1





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



I tested the google android on my Z. It was successful and promising, but still has a long way to go. If anyone is interested in it, give a try. Now android works on C3100/3200.

The kernel and modules with android system were uploaded on the following place.
http://yonggun.tistory.com/61

Enjoy,
Yonggun
Go to the top of the page
 
+Quote Post
jpmatrix
post Jan 4 2008, 03:44 AM
Post #2





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



yeah it looks promising!
and as we can chroot it, it can be executed besides other debian session:)
we should even be able to swap from X to Android,not?

what seems great at first sight is the browser which seems to have builtin java support!
Go to the top of the page
 
+Quote Post
adf
post Jan 4 2008, 06:28 PM
Post #3





Group: Members
Posts: 2,821
Joined: 13-September 04
From: Wasilla Ak.
Member No.: 4,572



this would be exactly the sort od dual laptop/mobile setup we've been talking about for years.....excellent
Go to the top of the page
 
+Quote Post
jpmatrix
post Jan 5 2008, 06:10 AM
Post #4





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



tried so far:

-RotateView applet (must have!) : http://androidzaurus.seesaa.net/article/76612103.html
-google maps ! (OMG ! i could see my house !)
-androitter : http://www.adamrocker.com/blog/174/android...er_client2.html

Go to the top of the page
 
+Quote Post
ZDevil
post Jan 7 2008, 07:04 AM
Post #5





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Thanks again, 2or0! wink.gif

I followed your instructions but start-android ends up with the famous bouncing red ball (the disk LED doesn't flash). Any success story here?

Go to the top of the page
 
+Quote Post
ZDevil
post Jan 7 2008, 07:43 AM
Post #6





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



I run into a problem with this Android-patched kernel: the Z refuses to power off. Pressing the power button throws out a lot of messages (going too fast, can't see what they are) and then returns to the prompt. I downloaded and installed the kernel twice and it's the same. Using "shutdown -h now" is fine, though.
Go to the top of the page
 
+Quote Post
2or0
post Jan 8 2008, 09:03 AM
Post #7





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



QUOTE(ZDevil @ Jan 7 2008, 07:43 AM) *
I run into a problem with this Android-patched kernel: the Z refuses to power off. Pressing the power button throws out a lot of messages (going too fast, can't see what they are) and then returns to the prompt. I downloaded and installed the kernel twice and it's the same. Using "shutdown -h now" is fine, though.


Now I fixed this problem. You can reflash the kernel which is in my blog.
Go to the top of the page
 
+Quote Post
same
post Jan 9 2008, 02:43 AM
Post #8





Group: Members
Posts: 51
Joined: 29-October 07
From: barcelona
Member No.: 20,873



i also see the red ball bounce and nothing more, any fix zdevil? saw you could solve it

thnx
Go to the top of the page
 
+Quote Post
2or0
post Jan 9 2008, 02:50 AM
Post #9





Group: Members
Posts: 217
Joined: 6-June 04
Member No.: 3,590



QUOTE(same @ Jan 9 2008, 02:43 AM) *
i also see the red ball bounce and nothing more, any fix zdevil? saw you could solve it

thnx


In my case, I unloaded the ohci_hcd module when I run android. Please check this is loaded.
Go to the top of the page
 
+Quote Post
same
post Jan 9 2008, 02:59 AM
Post #10





Group: Members
Posts: 51
Joined: 29-October 07
From: barcelona
Member No.: 20,873



1st of all, thanx for ur work 2oro =)

i'll try that because i see
CODE
Zaurus:~# lsmod | grep ohci_hcd
ohci_hcd               21252  0
usbcore               123296  2 ohci_hcd


i'm doing apt-get upgrade, when it finishes i'll try removing that smile.gif

EDIT: rmmod ohci_hcd && start-android
it works! thx!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st November 2014 - 05:22 AM