OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Restore Japanese To English Only With Reflashing?
theo
post Nov 13 2007, 11:02 AM
Post #1





Group: Members
Posts: 3
Joined: 8-November 07
Member No.: 20,915



I just bought a SL-6000W used, and although or because being a Linux user, already in trouble. After trying to install MidnightCommander, I lost the terminal. All I have is a non-working icon of MC and no terminal. I then tried a reboot. It came back just as it was (still no terminal), but all in Japanese, and I can't find an easy way to get the English back, also not on this forum. Using the "Reset" feature does the same. The behaviour is really weird: some stuff is in English, but as soon as it is used, turns into Japanese.

Does this mean I have to reflash the ROM? If so can can anyone link me to SL-6000 specific instructions? The manuals I've found on this site don't cover this. I've also seen in the section NAND backups that it is easy to ruin the Zaurus. Is there a better way?

I have no CD or SD-card with software, but can easily download stuff and put it onto SD. Would this be a good oportunity to switch to the 2.6 kernel, some newer ROM image, or indeed to OpenZaurus instead of the original Sharp SW?
Go to the top of the page
 
+Quote Post
jfv
post Nov 13 2007, 01:26 PM
Post #2





Group: Members
Posts: 438
Joined: 24-June 03
Member No.: 202



For a quick fix, download an ipk of the terminal, put it on a card and put it on the Zaurus. To install it, either go to the documents tab and and navigate to the card and click on the ipk or guess which icon is the add/remove programs and click on that. You should then have a terminal program and from it you can edit /etc/locale.conf and change the language from japanese (ja) to english (en).
Go to the top of the page
 
+Quote Post
theo
post Nov 14 2007, 02:05 AM
Post #3





Group: Members
Posts: 3
Joined: 8-November 07
Member No.: 20,915



QUOTE(jfv @ Nov 13 2007, 10:26 PM) *
For a quick fix, download an ipk of the terminal, put it on a card and put it on the Zaurus [...] and from it you can edit /etc/locale.conf and change the language from japanese (ja) to english (en).


Thank you! I got the terminal back and thanks to the hardware keyboard can use it. The file was actually in /home/zaurus/Settings/ as I have since found in this same thread at http://www.oesf.org/forum/index.php?showto...mp;#entry160933

I wasn't able to use vi or any of the relevant command properly because of missing characters on the keyboard and had to install nano and libncurses.

Having changed locale.conf and rebooted, I now have mostly English back, thanks! However the virtual keyboard is now nearly useless, still half Japanese and often prints spurious characters. Any ideas on how to fix this and purge the Japanese things completely?

--------------------
SL-6000W
ROM v1.11 JP (Sharp)
Linux Kernel 2.4.18-rmk7-pxa3-embedix
Qtopia for OpenPDA Version 1.5.4
Metrowerks OpenPDA Version 1.0
Opera Version 7.25
Go to the top of the page
 
+Quote Post
jfv
post Nov 14 2007, 05:08 AM
Post #4





Group: Members
Posts: 438
Joined: 24-June 03
Member No.: 202



One of the keys on the top left of the virtual keyboard switches it from japanese to english, just poke around a bit.
Go to the top of the page
 
+Quote Post
theo
post Nov 14 2007, 06:13 AM
Post #5





Group: Members
Posts: 3
Joined: 8-November 07
Member No.: 20,915



Thank you!

It's a bit like playing Myst: There are three Japanese buttons to the left and three to the right of the qwerty keyboard. Also the Space-bar is labeled in Japanese, as well as one key to the left (i.e. between Space and Alt), and two keys to the right of Space, also one to the left of Backspace. Poking these does different things and I can more or less get most English characters, but can't get the special keys labeled properly. Also, the freehand board and the character pick-board are still Japanese.

There must be another language setting besides the one in locale.conf somewhere, as several applications show some Japanese instead of English characters, or phonetic Japanese representations in English characters. Anybody know where another language setting might be located?

--------------------
SL-6000W
ROM v1.11 JP (Sharp)
Linux Kernel 2.4.18-rmk7-pxa3-embedix
Qtopia for OpenPDA Version 1.5.4
Metrowerks OpenPDA Version 1.0
Opera Version 7.25
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd November 2014 - 01:27 PM