OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Vim And .vimrc
climber
post Jan 17 2006, 12:45 AM
Post #1





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



I´ve flashed my SL-C3100 with the actuall Cacko 1.23 ROM. Up to now everythink works good. For editing data I installed the following version of vim "vim_6.1_arm.ipk". The installation wasn´t a problem. Now, i want to enable the syntax hightlighting and for that i heard that i have to copy the .vimrc to my home directory. I cant´t find a .vimrc anywhere on my zaurus. Another guy sayd that you have to run vimtutor and one of this process involves coppying a sample .vimrc file to your home directory. Where and how should i run vimtutor. I execute this on the shell, but with no effect.

Could anybody help me to solve this problem!?

Thanks,
climber
Go to the top of the page
 
+Quote Post
grog
post Jan 17 2006, 03:59 AM
Post #2





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



I'm curently usinig OZ, not Cacko, but I downloaded the latest vim from the ZUG's Cacko feed (6.3, not sure where you got yours). There's a sample vimrc in the file /usr/share/vim/vim63/vimrc_example.vim, so I'd imagine there should be the same file in the verision directory of your package. Copy this file to ~/.vimrc & you should be good to go (other than what's below).

I noticed that this file (in 6.3) has a special check to turn syntax highlighting on only if you have a color terminal, but I'm not sure if the terminal in cancko supports that. Give it a try (there's a lot more than just syntax'ing in there), but if it doesn't work (or if you don't have a vimrc sample in your share directory), you can just create a ~/.virmc file yourself and enter whatever settings you want. Here's a few that I use to get you started:

CODE
syntax on
set hlsearch
set autoindent
set ruler
set ignorecase
set smartcase
set backspace=2
set laststatus=2


To find out what each setting does, just enter the command ':help command' (for example, ':help ruler') to get a description of it.

HAPPY VIM'ING! smile.gif
Go to the top of the page
 
+Quote Post
climber
post Jan 18 2006, 12:40 AM
Post #3





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



Uninstall my vim version and installing the 6.3 version wasn´t no problem. Then I copied the vimrc_example.vim from this folder /usr/share/vim/vim63/ to /home/zaurus/ and renamed it to .vimrc.

Opening a html-file with vim no syntaxhighlighting was viewable. I´m not sure but needn´t i to do a symbol link to the vim63 folder or something other?

Could someone give me a link to download a working .vimrc [with syntaxhighlighting on] to exclude this as a error source.


Thanks,
Tom
Go to the top of the page
 
+Quote Post
grog
post Jan 18 2006, 03:42 AM
Post #4





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



As someone else just suggested in this thread, try setting your TERM variable before starting vim (export TERM=linux). Does that work? If not, then remove your .vimrc & replace it with the simple example I gave you previously & try it again. Does that work?
Go to the top of the page
 
+Quote Post
climber
post Jan 25 2006, 01:03 AM
Post #5





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



"Export TERM=linux" doesn`t solve the problem. I can't believe that no SL-C3xx user with the new Cacko-ROM has vim without syntaxhighlighting. I´m sure that anyone has managed syntaxhightlighting with his SL-C3xx and Cacko. Please write me a few lines if someone ohter has the same problems and maybe fixed it successfully.

Maybe the newest vim version 6.3 makes problem with syntaxhighlighting?


Thanks,
climber
Go to the top of the page
 
+Quote Post
terryleung83
post Jan 25 2006, 02:01 AM
Post #6





Group: Members
Posts: 68
Joined: 1-August 05
Member No.: 7,753



in .profile
CODE
export TERM=linux


in .vimrc
CODE
set syntax=on


for syntax highlighting, you need to have the correct file extension like .cpp or .h
also i am using kconsole which is the default console come from cacko
Go to the top of the page
 
+Quote Post
climber
post Jan 25 2006, 02:09 AM
Post #7





Group: Members
Posts: 193
Joined: 21-November 05
Member No.: 8,574



Sure that´s the requirement that vim hightlights the syntax. For testing i type "vim test.html" and enter some html code. No syntaxhighlighting...
Go to the top of the page
 
+Quote Post
grog
post Jan 25 2006, 03:49 AM
Post #8





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



Try this specifically on the command line:

export TERM=linux
vim file.html

and then from within vim:

:set syntax=on

Does this work? If so, there's a problem with your .profile and/or .vimrc files. If not, then ... ?
Go to the top of the page
 
+Quote Post
gsgmx
post Nov 13 2006, 07:51 AM
Post #9





Group: Members
Posts: 32
Joined: 25-September 05
Member No.: 8,188



QUOTE(grog @ Jan 17 2006, 01:59 PM)
I'm curently usinig OZ, not Cacko, but I downloaded the latest vim from the ZUG's Cacko feed (6.3, not sure where you got yours). There's a sample vimrc in the file /usr/share/vim/vim63/vimrc_example.vim, so I'd imagine there should be the same file in the verision directory of your package. Copy this file to ~/.vimrc & you should be good to go (other than what's below).

I noticed that this file (in 6.3) has a special check to turn syntax highlighting on only if you have a color terminal, but I'm not sure if the terminal in cancko supports that. Give it a try (there's a lot more than just syntax'ing in there), but if it doesn't work (or if you don't have a vimrc sample in your share directory), you can just create a ~/.virmc file yourself and enter whatever settings you want. Here's a few that I use to get you started:

CODE
syntax on
set hlsearch
set autoindent
set ruler
set ignorecase
set smartcase
set backspace=2
set laststatus=2


To find out what each setting does, just enter the command ':help command' (for example, ':help ruler') to get a description of it.

HAPPY VIM'ING! smile.gif
*


Hi,

i'm looking for vim 7.0 for SharpRom/Cacko 1.23, could not find it anywhere. Consolemode only would be fine.
Does anyone know whether it is available?

If not vailable as binary, is it difficult to compile?

George
Go to the top of the page
 
+Quote Post
zogs
post Nov 14 2006, 12:33 AM
Post #10





Group: Members
Posts: 106
Joined: 17-December 04
Member No.: 5,953



QUOTE(climber @ Jan 25 2006, 09:03 AM)
"Export TERM=linux" doesn`t solve the problem. I can't believe that no SL-C3xx user with the new Cacko-ROM has vim without syntaxhighlighting. I´m sure that anyone has managed syntaxhightlighting with his SL-C3xx and Cacko. Please write me a few lines if someone ohter has the same problems and maybe fixed it successfully.

Maybe the newest vim version 6.3 makes problem with syntaxhighlighting?

*

for default cacko 1.23 have this .profile:

CODE
[...]

export COLORTERM=0
#export TERM=linux

[...]

if [ "'env | grep SSH_TTY'" == " ]; then
      export TERM=vt100
fi

[...]


ok now you can try to change like this:
CODE
[...]
export COLORTERM=0
#export TERM=linux

[...]
if [ "'env | grep SSH_TTY'" == " ]; then
      export TERM=linux
fi
[...]

or like this:
CODE
export COLORTERM=0
export TERM=linux

[...]
#if [ "'env | grep SSH_TTY'" == " ]; then
#       export TERM=vt100
#fi
[...]
Go to the top of the page
 
+Quote Post
Optogeek
post Nov 16 2006, 10:59 AM
Post #11





Group: Members
Posts: 48
Joined: 3-February 04
From: Edinburgh, Scotland
Member No.: 1,681



HI,

Try this. This works on my c860 on Cacko. You might need to change the term line to match your set-up.
Attached File(s)
Attached File  vimrc.txt ( 304bytes ) Number of downloads: 25
 
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 04:12 PM