OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Oe Build Problem, cant compile pkgconfig-native
radioz
post Mar 14 2005, 06:04 PM
Post #1





Group: Members
Posts: 102
Joined: 11-October 04
Member No.: 4,962



I'm having trouble trying to build oe for Opie. I think I've got everything installed properly based on the Wiki, but when I issue the 'bitbake opie-image' the build fails when trying to run do_configure on 'pkgconfig-native-0.15.0-r1'. The error is:

NOTE: Executing autoreconf --verbose --install --force --exclude=autopoint -I . -I /home/keithg/Zaurus/oe/tmp/staging/i686-linux/share/aclocal
Usage: autoreconf [-f] [-h] [--help] [-m dir] [--macrodir=dir]
[-l dir] [--localdir=dir] [--force] [--verbose] [--version]
[--cygnus] [--foreign] [--gnits] [--gnu] [-i] [--include-deps]
FATAL: autoreconf execution failed.
~

The puzzling thing about the autoreconf command is that the man page does not list the '--exclude' argument. What version of autoreconf am I supposed to have? I recently installed the latest package I could find for my Manrake 10.0 machine (2.59) with no luck. Does anyone have any suggestions?

Radioz
Go to the top of the page
 
+Quote Post
Mickeyl
post Mar 15 2005, 01:23 AM
Post #2





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



Install the autotools in their latest versions on your host. For non-native packages, OE builds their own autotools and uses them. For a couple of native packages, your host tools are used.
Go to the top of the page
 
+Quote Post
radioz
post Mar 15 2005, 09:54 PM
Post #3





Group: Members
Posts: 102
Joined: 11-October 04
Member No.: 4,962



QUOTE
Install the autotools in their latest versions on your host. For non-native packages, OE builds their own autotools and uses them. For a couple of native packages, your host tools are used.


Do you mean the autoconf package? I've installed the latest I could find (V2.59).

Or do you mean autotools? All I could find for autotools is autotools-0.4.0-3sfnet.i586.rpm which seems pretty old (2003). Any suggestions here?

p.s. Which mailing list can I post questions like this too? I've tried posting to comp.handhelds.openembedded but none of my messages get on the list.

thanks for the help

radioz
Go to the top of the page
 
+Quote Post
lardman
post Mar 16 2005, 02:09 AM
Post #4





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
p.s. Which mailing list can I post questions like this too? I've tried posting to comp.handhelds.openembedded but none of my messages get on the list.


Contact info in this thread: http://www.oesf.org/forums/index.php?showtopic=11231


Si
Go to the top of the page
 
+Quote Post
lixiaosan
post Mar 20 2005, 07:51 PM
Post #5





Group: Members
Posts: 4
Joined: 20-March 05
Member No.: 6,682



I have got this error too.

In classes/autotools.bbclass, you can find "EXTRA_AUTORECONF = "--exclude=autopoint"" at line 24.
I set it to "" .

"EXTRA_AUTORECONF = ""

U can try .
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd July 2014 - 09:50 PM