OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Bluetooth Help, Please!, f8t020 (and inexperience) problems
Capn_Fish
post Jan 3 2009, 07:44 PM
Post #1





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



OK, so I've been through all of my old threads on this, and I'm trying to get a Wiimote working with Ubuntu (Using XWii, compiled by me, Angstrom kernel, so there should be all of the bluetooth stuff I need). I've got BlueZ and stuff installed, but I'm really lost here. Can anybody give me some easy-to-follow-and-tell-if-they're working steps to getting my bluetooth working?

I've got Wiimotes, the F8T020 card, and a BT mouse to play/test with.

Thanks.
Go to the top of the page
 
+Quote Post
speculatrix
post Jan 10 2009, 03:37 PM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



does "hciconfig -a" tell you anything?

you might need to use hciattach, something like this:

hciattach ttyS4 socket 230400

where you specify the protocol to be used with the card; you should then be able to /etc/init.d/bluetooth restart or something

Go to the top of the page
 
+Quote Post
Capn_Fish
post Jan 10 2009, 09:02 PM
Post #3





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



"hciconfig -a" gives me nothing.

When running the hciattach command, I get "BCSP initialization timed out"

Dmesg doesn't say anything about BT (some stuff about ttyS4, ttyS0, and serial stuff). I can post the whole thing if it's useful.
Go to the top of the page
 
+Quote Post
speculatrix
post Jan 11 2009, 02:13 PM
Post #4





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



you'll have to try a different protocol, e.g.

man hciattach tells me
CODE
              any    Unspecified HCI_UART interface, no vendor specific options

              ericsson
                     Ericsson based modules

              digi   Digianswer based cards

              xircom Xircom PCMCIA cards: Credit Card Adapter and Real Port Adapter

              csr    CSR Casira serial adapter or BrainBoxes serial dongle (BL642)

              bboxes BrainBoxes PCMCIA card (BL620)

              swave  Silicon Wave kits

              bcsp   Serial adapters using CSR chips with BCSP serial protocol
Go to the top of the page
 
+Quote Post
Capn_Fish
post Jan 11 2009, 06:36 PM
Post #5





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



CODE
hciattach ttyS4 bcsp


worked for me. I'm having fun with a Wiimote now. smile.gif

Thanks a bunch!
Go to the top of the page
 
+Quote Post
speculatrix
post Jan 12 2009, 05:54 AM
Post #6





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



I've been thinking about buying a wiimote for a while, for both my zaurus and tablet.

how's the Z handling it, does it behave like a mouse as you'd expect?
Go to the top of the page
 
+Quote Post
Capn_Fish
post Jan 12 2009, 02:19 PM
Post #7





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Well, not so far as I can tell, even with the "tilt mouse" setting. My BT mouse works, though. If I use the "IR mouse" setting (without any IR sources to aid it), it will constantly put the cursor in the upper left-hand corner.

I'm guessing it's an issue of telling the Z where the mouse is (I've got it set up as /dev/input/mice, but I suppose it could appear as /dev/input/inputN or something instead). Clicking works fine, as do the arrow keys and stuff.
Go to the top of the page
 
+Quote Post
speculatrix
post Jan 12 2009, 03:35 PM
Post #8





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(Capn_Fish @ Jan 12 2009, 10:19 PM) *
Well, not so far as I can tell, even with the "tilt mouse" setting. My BT mouse works, though. If I use the "IR mouse" setting (without any IR sources to aid it), it will constantly put the cursor in the upper left-hand corner.

I'm guessing it's an issue of telling the Z where the mouse is (I've got it set up as /dev/input/mice, but I suppose it could appear as /dev/input/inputN or something instead). Clicking works fine, as do the arrow keys and stuff.


might want to search the internettablettalk forum for wiimote as someone had it running, and demonstrated with doom.
Go to the top of the page
 
+Quote Post
Capn_Fish
post Jan 12 2009, 05:15 PM
Post #9





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



I'll do that (eventually).

Has there ever been a fix for the "inverted" mouse issue (eg, L-R mouse movement causes U-D cursor movement)?
Go to the top of the page
 
+Quote Post
speculatrix
post Jan 13 2009, 03:19 PM
Post #10





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(Capn_Fish @ Jan 13 2009, 01:15 AM) *
I'll do that (eventually).

Has there ever been a fix for the "inverted" mouse issue (eg, L-R mouse movement causes U-D cursor movement)?


turn mouse round?
blink.gif
Go to the top of the page
 
+Quote Post
HRH_H_Crab
post Apr 1 2009, 11:05 PM
Post #11





Group: Members
Posts: 36
Joined: 29-August 06
Member No.: 11,035



Did you have to "pair" your devices?
I want to be able to use my phone as a gprs modem, but I can't figure out how to pair my phone to the Z!
I used to hardcode a pin in /etc/bluetooth/hcid.conf but that file is missing under newer versions of bluez, which uses bluetoothd.conf - this doesn't seem to have any scope for hardcoding a pin.
To make my question a bit more zubuntu specific, can anyone suggest a gui tool for pairing?
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 2 2009, 04:00 AM
Post #12





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



I think what I ended up doing was "hcid --attach MAC_ADDRESS" or something similar. I wasn't using a PIN.

I can't really say more than that.

HTH
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th December 2014 - 06:17 PM