OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Almost there with bluetooth, but need some help.
markb
post Mar 26 2004, 05:49 PM
Post #1





Group: Members
Posts: 54
Joined: 28-February 04
From: Birmingham, UK
Member No.: 2,080



I've had a Bluemonkey Bluetooth card for over a week, but haven't had any luck getting on the net through my mobile, using GPRS.

I don't think it's a hardware or driver problem.
I'm pretty sure it's to do with my config files and/or dialup scripts.
I haven't played with ppp before, so I could be doing something obviously wrong, but don't realise it.

I'm using a Sony Ericsson P800 phone, on the UK Orange network.
C860 with standard Sharp ROM.

I can pair up the devices OK. My c860 shows up as "Zaurus" on my phone. The phone asks me for the PIN that I set up. After I enter it it says "Bonding complete". So I think that part is working OK.

I can run sdptool browse on my Z and it discovers my phone:
(Part of MAC address replaced by XX - just to be on the safe side)

CODE
# sdptool browse

Inquiring ...

Browsing 00:XX:XX:XX:9A:12 ...

Service Name: Voice gateway

Service Description: Voice gateway

Service Provider: Sony Ericsson

Service RecHandle: 0x10000

Service Class ID List:

 "Headset Audio Gateway" (0x1112)

 "Generic Audio" (0x1203)

Protocol Descriptor List:

 "L2CAP" (0x0100)

 "RFCOMM" (0x0003)

   Channel: 8

Language Base Attr List:

 code_ISO639: 0x656e

 encoding:    0x6a

 base_offset: 0x100

Profile Descriptor List:

 "Headset" (0x1108)

   Version: 0x0100



Service Name: Dial-up Networking

Service Description: Dial-up Networking

Service Provider: Sony Ericsson

Service RecHandle: 0x10008

Service Class ID List:

 "Dialup Networking" (0x1103)

Protocol Descriptor List:

 "L2CAP" (0x0100)

 "RFCOMM" (0x0003)

   Channel: 2

Language Base Attr List:

 code_ISO639: 0x656e

 encoding:    0x6a

 base_offset: 0x100

Profile Descriptor List:

 "Dialup Networking" (0x1103)

   Version: 0x0100



Service Name: OBEX Object Push

Service RecHandle: 0x10009

Service Class ID List:

 "OBEX Object Push" (0x1105)

Protocol Descriptor List:

 "L2CAP" (0x0100)

 "RFCOMM" (0x0003)

   Channel: 3

 "OBEX" (0x0008)

Profile Descriptor List:

 "OBEX Object Push" (0x1105)

   Version: 0x0100



Service Name: Bluetooth Serial Port

Service Description: Bluetooth Serial Port

Service Provider: Symbian Ltd.

Service RecHandle: 0x1000a

Service Class ID List:

 "Serial Port" (0x1101)

Protocol Descriptor List:

 "L2CAP" (0x0100)

 "RFCOMM" (0x0003)

   Channel: 1

Language Base Attr List:

 code_ISO639: 0x656e

 encoding:    0x6a

 base_offset: 0x100


My /etc/bluetooth/rfcomm.conf file looks like this:

CODE
rfcomm0 {

       # Automatically bind the device at startup

       bind yes;



       # Bluetooth address of the device

       device 00:XX:XX:XX:9A:12;



       # RFCOMM channel for the connection

       channel 1;



       # Description of the connection

       comment "P800 DUN";

}


In /etc/ppp/peers I have a file called IRDA1079225237
(The file was originally named & created by the Network app on the Z, but I've edited the contents.)
CODE
# cat IRDA1079225237

debug debug debug

/dev/rfcomm0

noipdefault

115200

connect '/usr/sbin/chat -s -v -t 60 ABORT "NO CARRIER" ABORT "NO DIALTONE" ABORT "BUSY" "" "AT+CGDCONT=1,"IP","orangeinternet"" OK "ATDT*99#" CONNECT "dd"'

crtscts

lock

modem

usepeerdns

defaultroute

mtu 576

mru 576

connect-delay 1000

remotename IRDA1079225237


I then try to connect using
pppd call IRDA1079225237

My phone then asks me if I want to accept or reject the connection. I accept! :-)

But I don't seem to have a network connection on my Z. :-(
If I look at my /var/log/messages file I get this:
CODE
Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #[device name] keyword=value,keyword=value,... > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo # > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #Keywords > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #BaudRate^I:max baud rate(- 115200bps) > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #MaxTurn^I:max turn time(- 500ms) > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #MinTurn^I:min turn time(- 10000us) > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #DataSize^I:max data size(- 2048bytes) > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost pppd[3158]: pppd 2.4.0 started by root, uid 0

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #WindowSize^I:max window size(- 7) > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #BOFS^I^I:additional bofs(- 48bytes) > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo #DiscTime^I:disconnect time(- 40secs) > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo   > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: +

Mar 21 23:46:37 localhost irattach: executing: 'echo [NM207] BaudRate=57600 > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: executing: 'echo [sharp pdaMI-500] BaudRate=57600 > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:37 localhost irattach: executing: 'echo [sharp pdaMI-100] BaudRate=57600 > /proc/sys/net/irda/specific_dev'

Mar 21 23:46:45 localhost chat[3169]: abort on (NO CARRIER)

Mar 21 23:46:45 localhost chat[3169]: abort on (NO DIALTONE)

Mar 21 23:46:45 localhost chat[3169]: abort on (BUSY)

Mar 21 23:46:45 localhost chat[3169]: send (AT+CGDCONT=1,IP,orangeinternet^M)

Mar 21 23:46:45 localhost pppd[3158]: Hangup (SIGHUP)

Mar 21 23:46:45 localhost pppd[3158]: Connect script failed

Mar 21 23:46:45 localhost chat[3169]: SIGHUP

Mar 21 23:46:45 localhost chat[3169]: Can't restore terminal parameters: Input/output error

Mar 21 23:46:46 localhost pppd[3158]: Exit.

Mar 21 23:46:47 localhost exiting on signal 15


I feel that I'm close to getting it working, and it might just need a bit of tweaking.
I'm hoping someone here can tell me what I'm doing wrong.

Thanks in advance for any help.
Sorry for the long post, but I wanted to provide as much info as possible.

- Mark
Go to the top of the page
 
+Quote Post
Foxdie
post Mar 27 2004, 02:58 AM
Post #2





Group: Admin
Posts: 465
Joined: 8-November 03
From: Birmingham, United Kingdom
Member No.: 875



There's 2 reasons for that, either you're using the wrong init string or you're connected to the wrong channel. Try using Channel 2 and the init string AT&FE0V1&D2S0=0S7=10

When my Zaurus was working (it's currently bricked) that worked fine for me with Orange GPRS and my Nokia 6310i
Go to the top of the page
 
+Quote Post
markb
post Mar 27 2004, 08:11 AM
Post #3





Group: Members
Posts: 54
Joined: 28-February 04
From: Birmingham, UK
Member No.: 2,080



Thanks for the suggestion foxdie.

I tried changing channel to 2 first.
No luck.

Then I changed the init string.
I'm not familiar with these chat script and modem commands.
I hope I changed the right thing.

I created a new script as follows:

CODE
# cat foxdie

debug debug debug

/dev/rfcomm0

noipdefault

115200

connect '/usr/sbin/chat -s -v -t 60 ABORT "NO CARRIER" ABORT "NO DIALTONE" ABORT "BUSY" "" "AT&FE0V1&D2S0=0S7=10" OK "ATDT*99#" CONNECT "dd"'

crtscts

lock

modem

usepeerdns

defaultroute

mtu 576

mru 576

connect-delay 1000

remotename zaurus


Then I did "pppd call foxdie".

I had to do a few restarts, and fix a typo.
But it now seems to be getting further, but still no net connection:

The log gives me this:



CODE
Mar 27 16:01:44 localhost pppd[7503]: pppd 2.4.0 started by root, uid 0

Mar 27 16:01:47 localhost hcid[7476]: link_key_request (sba=D8:0B:05:02:90:00, dba=12:9A:14:D9:0A:00)

Mar 27 16:01:48 localhost chat[7505]: abort on (NO CARRIER)

Mar 27 16:01:48 localhost chat[7505]: abort on (NO DIALTONE)

Mar 27 16:01:48 localhost chat[7505]: abort on (BUSY)

Mar 27 16:01:48 localhost chat[7505]: send (AT&FE0V1&D2S0=0S7=10^M)

Mar 27 16:01:48 localhost chat[7505]: expect (OK)

Mar 27 16:01:48 localhost chat[7505]: AT&FE0V1&D2S0=0S7=10^M^M

Mar 27 16:01:48 localhost chat[7505]: OK

Mar 27 16:01:48 localhost chat[7505]:  -- got it

Mar 27 16:01:48 localhost chat[7505]: send (ATDT*99#^M)

Mar 27 16:01:49 localhost chat[7505]: expect (CONNECT)

Mar 27 16:01:49 localhost chat[7505]: ^M

Mar 27 16:01:50 localhost chat[7505]: ^M

Mar 27 16:01:50 localhost chat[7505]: CONNECT

Mar 27 16:01:50 localhost chat[7505]:  -- got it

Mar 27 16:01:50 localhost chat[7505]: send (dd^M)

Mar 27 16:01:52 localhost pppd[7503]: Serial connection established.

Mar 27 16:01:52 localhost pppd[7503]: Using interface ppp0

Mar 27 16:01:52 localhost pppd[7503]: Connect: ppp0 <--> /dev/rfcomm0

Mar 27 16:01:54 localhost modprobe: modprobe: Can't locate module ppp-compress-26

Mar 27 16:01:54 localhost modprobe: modprobe: Can't locate module ppp-compress-24

Mar 27 16:01:54 localhost modprobe: modprobe: Can't locate module ppp-compress-26

Mar 27 16:01:54 localhost modprobe: modprobe: Can't locate module ppp-compress-24

Mar 27 16:01:54 localhost pppd[7503]: Could not determine local IP address

Mar 27 16:02:06 localhost pppd[7503]: Connection terminated.


To test to see if I get a net connection I just try pinging a known IP address. That fails. If I try to view a web page in NetFront it says there's no connection.

Thanks again for your help.
I think I'm definitely getting closer!

- Mark
Go to the top of the page
 
+Quote Post
Foxdie
post Mar 27 2004, 08:51 AM
Post #4





Group: Admin
Posts: 465
Joined: 8-November 03
From: Birmingham, United Kingdom
Member No.: 875



It looks like the ROM you have doesn't support Orange GPRS's compression. I recommend you try the latest Cacko Qtopia ROM, it should increase your chances for a successful connect. It's the one I use and it was the simplest to set up to dial up with bluetooth / orange gprs.
Go to the top of the page
 
+Quote Post
markb
post Mar 27 2004, 02:04 PM
Post #5





Group: Members
Posts: 54
Joined: 28-February 04
From: Birmingham, UK
Member No.: 2,080



Thanks for the info Foxdie.

Not the news I was hoping for though :-(
Looks I'll have to try a new ROM.

- Mark
Go to the top of the page
 
+Quote Post
Foxdie
post Mar 27 2004, 02:27 PM
Post #6





Group: Admin
Posts: 465
Joined: 8-November 03
From: Birmingham, United Kingdom
Member No.: 875



The Cacko Qtopia ROM is near-identical to the old ROM, it's got a few interface tweaks and updates, you won't really notice the difference (unless you want to keep the japanese elements, in which case you shouldn't change the ROM).
Go to the top of the page
 
+Quote Post
tumnus
post Mar 28 2004, 08:20 AM
Post #7





Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547



I don't think it's the ROM. I connect to Orange UK GPRS via a Nokia 6600 using the standard Sharp ROM on a 5600 and get the same messages about the compression modules. I wouldn't have thought that the 5600 and C860 ROMs were all that different anyway.

All I have in my peers file is this:

CODE
/dev/rfcomm0

115200

connect '/usr/sbin/chat -s -v -t 60 ABORT "NO CARRIER" ABORT "NO DIALTONE" ABORT "BUSY" "" "ATZ" OK "ATDT*99#" CONNECT'

crtscts

noipdefault

modem

user "user"

usepeerdns

defaultroute

connect-delay 5000

remotename DialupBluetooth1067815189

(The Nokia phones don't require anything other than ATZ for the initialisation string when you set the default GPRS access point on the phone itself)

Try it without the mru and mtu settings.
Go to the top of the page
 
+Quote Post
markb
post Mar 28 2004, 09:47 AM
Post #8





Group: Members
Posts: 54
Joined: 28-February 04
From: Birmingham, UK
Member No.: 2,080



Thanks for the reply Tumnus.
I gave that a go as well. Unfortunately I get the same results. :-(
This is what I get in my log file:
CODE
Mar 28 17:38:01 localhost pppd[8152]: pppd 2.4.0 started by root, uid 0

Mar 28 17:38:01 localhost hcid[8111]: link_key_request (sba=D8:0B:05:02:90:00, dba=12:9A:14:D9:0A:00)

Mar 28 17:38:02 localhost chat[8154]: abort on (NO CARRIER)

Mar 28 17:38:02 localhost chat[8154]: abort on (NO DIALTONE)

Mar 28 17:38:02 localhost chat[8154]: abort on (BUSY)

Mar 28 17:38:02 localhost chat[8154]: send (ATZ^M)

Mar 28 17:38:03 localhost chat[8154]: expect (OK)

Mar 28 17:38:03 localhost chat[8154]: ATZ^M^M

Mar 28 17:38:03 localhost chat[8154]: OK

Mar 28 17:38:03 localhost chat[8154]:  -- got it

Mar 28 17:38:03 localhost chat[8154]: send (ATDT*99#^M)

Mar 28 17:38:03 localhost chat[8154]: expect (CONNECT)

Mar 28 17:38:03 localhost chat[8154]: ^M

Mar 28 17:38:05 localhost chat[8154]: ATDT*99#^M^M

Mar 28 17:38:05 localhost chat[8154]: CONNECT

Mar 28 17:38:05 localhost chat[8154]:  -- got it

Mar 28 17:38:05 localhost pppd[8152]: Serial connection established.

Mar 28 17:38:05 localhost pppd[8152]: Using interface ppp0

Mar 28 17:38:05 localhost pppd[8152]: Connect: ppp0 <--> /dev/rfcomm0

Mar 28 17:38:10 localhost modprobe: modprobe: Can't locate module ppp-compress-26

Mar 28 17:38:10 localhost modprobe: modprobe: Can't locate module ppp-compress-24

Mar 28 17:38:10 localhost modprobe: modprobe: Can't locate module ppp-compress-26

Mar 28 17:38:10 localhost modprobe: modprobe: Can't locate module ppp-compress-24

Mar 28 17:38:11 localhost pppd[8152]: Could not determine local IP address

Mar 28 17:38:14 localhost pppd[8152]: Connection terminated.

Mar 28 17:38:14 localhost pppd[8152]: Connect time 0.1 minutes.

Mar 28 17:38:14 localhost pppd[8152]: Sent 77 bytes, received 64 bytes.

Mar 28 17:38:15 localhost pppd[8152]: Exit.


- Mark
Go to the top of the page
 
+Quote Post
tumnus
post Mar 28 2004, 12:31 PM
Post #9





Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547



The ATZ initialisation string will almost definitely not work with the Sony P800 given all other Sony Ericsons require a different initialisation string. It's possible that your problem is that you didn't get the initialisation string quite right in the first place.

Are you sure you have GPRS enabled on your Orange account for internet access as well as WAP? Can you browse the web (not WAP) directly via GPRS on your phone?

You might want to contact Orange Support. If you are persistent enough you may get through to second level support. When I last got through to them over a year ago they had a linux expert who was getting a Zaurus. He could still be there.
Go to the top of the page
 
+Quote Post
markb
post Mar 28 2004, 12:52 PM
Post #10





Group: Members
Posts: 54
Joined: 28-February 04
From: Birmingham, UK
Member No.: 2,080



Yep, my p800 has been happily surfing the web and handling email for the past year (almost time to upgrade to a P900!).
Maybe I should upgrade to a Nokia instead.

I wouldn't be surprised if I got the initialisation string wrong, as I don't really know what I'm doing. :-)
I've tried different scripts that I've found on the web.
Lots of people have got bluetooth working, and have published their config files. But they don't seem to work for me.

I'll try talking to Orange and see if I can get through to a linux expert.

Thanks for your help.

- Mark
Go to the top of the page
 
+Quote Post
Foxdie
post Mar 29 2004, 03:20 AM
Post #11





Group: Admin
Posts: 465
Joined: 8-November 03
From: Birmingham, United Kingdom
Member No.: 875



Now that I re-read your post, I'm guessing the init string is wrong, both those init strings (your original one and the one I specified) were for Nokia's with GPRS.

Try dialling up the old fashioned way to a regular POP, try the following:

username: uk2
password: uk2
telephone: 0845 6653000

That's a free ISP that's charged at local rate and you don't require an account with them.

If that works then it's the init string that's incorrect, else it's a PPPD or kernel/module problem.


Ps. Orange don't have linux experts on their staff, they only cater for windoze users. They could have changed that policy since I last asked them for linux support 6 months ago but I very much doubt it wink.gif
Go to the top of the page
 
+Quote Post
pakman
post Mar 29 2004, 06:17 AM
Post #12





Group: Members
Posts: 41
Joined: 8-March 04
From: UK
Member No.: 2,204



Hi markb,

My guess about your problem, is that when you are connecting to the internet through your phone, the ppp script is selecting a WAP access point (with an access point name 'orangewap') rather than a general-purpose GPRS one (with the access point name 'orangeinternet'). Presumbably, the phone's built-in web browser is choosing the correct access point, but the Z isn't when you dial in. (A well-maintained list of Internet APN's is here)

There are normally two ways to select the correct access point. Your phone may have a setting to specify the default access point. Or, your phone may assign CID numbers to the access points. These are just numbers from 1 upwards in which case you should use the dialling code *99***x#, where x is the CID.

There is a third way, which I have read about at a few places (for example here) where you can specify the service name directly. In your case, you would dial like this: *99*orangeinternet# . I have never tried this, though.

I may have a chance to have a look at a friend's P800 in a day or two. If I can be more specific, and you haven't cracked it by then, I'll post again.

Good luck,
P.
Go to the top of the page
 
+Quote Post
tumnus
post Mar 29 2004, 06:18 AM
Post #13





Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547



QUOTE
Ps. Orange don't have linux experts on their staff, they only cater for windoze users. They could have changed that policy since I last asked them for linux support 6 months ago but I very much doubt it wink.gif


They don't officially support it, but they do have quite a few geeks/techies at 2nd level support and so you could be lucky and get to speak to one who uses Linux themselves, like I did.
Go to the top of the page
 
+Quote Post
markb
post Mar 30 2004, 03:00 PM
Post #14





Group: Members
Posts: 54
Joined: 28-February 04
From: Birmingham, UK
Member No.: 2,080



I haven't had much of a chance to play with bluetooth, but I wanted to thank everyone for their suggestions.
I'll post back if I make any progress.
Hopefully I'll have time to play tomorrow evening.

As far as tech support goes I think it just depends on who you're lucky (or unlucky) enough to get through to.
I had a problem with my broadband connection ages ago and phoned up blueyonder tech support. When he asked about my setup I was reluctant to say I was using Linux.
I expected him to say "Sorry we only do windows". But he said he used linux himself, and he was able to investigate my problem through the linux command line.
But that was "unofficial & unsupported". I was just lucky.

Sometimes we're unlucky. I'm sure we've all experienced bad tech support.
I won't mention any names. But if I give a hint you could probably fill in the blank: DE_L :-)

- Mark
Go to the top of the page
 
+Quote Post
pakman
post Mar 31 2004, 02:35 AM
Post #15





Group: Members
Posts: 41
Joined: 8-March 04
From: UK
Member No.: 2,204



Hi again,

Followup to my previous post:

(1) The *99*orangeinternet# form will not work - in my enthusiasm I hadn't read to the bottom of the post that I quoted above, where the original poster explaind that he mis-understood the syntax of the GPRS diallup string. There is a way of associating "orangeinternet" with a CID using modem commands something like AT +CGDCONT=1, "IP", "orangeinternet"; followed by ATD*99***1# . I won't quote a single reference, but if you Google on "AT+CGDCONT" APN you will find lots of hints.

(2) Probably simpler, is to figure out the CID for the correct GPRS connection that is already set up and working on your phone, and use ATD*99***x#. You could try the brute force approach, and just try 1,2,3,4 ... for x until you find one that works, or get fed up. However, I have found a hint here that you can query the phone to find out the CID numbers of the GPRS connections that are set up on it, by sending AT+CGDCONT? to the phone. I'm not sure how to do this from the console, but presumably if you put this string in the correct file in /etc/ppp/peers instead of ATD*99# and then use it to pretend to dial up, the phone's response will appear in a file like /var/log/messages or /tmp/qpe-pppd-log (depending on your ROM).

(3) The P800 (unlike my own Nokia 7650) does not have a way of specifying the default GPRS APN to be used when dialling in with *99# - it looks like you have to get the CID right.

My gut feeling is that since you got as far as

QUOTE
Mar 27 16:01:49 localhost chat[7505]: expect (CONNECT)
Mar 27 16:01:49 localhost chat[7505]: ^M
Mar 27 16:01:50 localhost chat[7505]: ^M
Mar 27 16:01:50 localhost chat[7505]: CONNECT
Mar 27 16:01:50 localhost chat[7505]:  -- got it
Mar 27 16:01:50 localhost chat[7505]: send (dd^M)
Mar 27 16:01:52 localhost pppd[7503]: Serial connection established.
Mar 27 16:01:52 localhost pppd[7503]: Using interface ppp0
Mar 27 16:01:52 localhost pppd[7503]: Connect: ppp0 <--> /dev/rfcomm0


and that you have been accessing the full internet from applications on your phone already, the only issue is making sure that the ppp connection from your Z is picking the correct GPRS connection on your phone.

Good luck,
P.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 10:19 AM