OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Replace usbdnet with usbnet
gregkedro
post Oct 24 2003, 03:09 AM
Post #1





Group: Members
Posts: 29
Joined: 19-October 03
From: San Jose, Costa Rica
Member No.: 674



I patched my RH8 kernel with the usbdnet driver and installed it as a module. It didn't work to sync my Z, so (as per my last thread) I want to try to sync with usbnet.

I did rmmod usbdnet and now usbdnet does not show up in lsmod.

make && make install of usbnet returned errors.

When I put my Z in the cradle and watch /var/log/messages, it's still registering usbdnet (that it's looking for to make the connection).

Does anyone know how to clean usbdnet off my system so that usbnet is sought for instead?

I'm trying to hunt down an rpm for usbnet to see if I can get that installed with no errors.

-Greg
Go to the top of the page
 
+Quote Post
lardman
post Oct 27 2003, 04:26 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



It that because it's still aliased in /etc/modules.conf?
Go to the top of the page
 
+Quote Post
gregkedro
post Oct 27 2003, 05:01 AM
Post #3





Group: Members
Posts: 29
Joined: 19-October 03
From: San Jose, Costa Rica
Member No.: 674



QUOTE
It that because it's still aliased in /etc/modules.conf?


No. I commented it out. But, don't sweat it. I give up on this thing.

I have a copy of Slackware 9.1 on the way in. It runs the 2.4.22 kernel that has pda support built in - experimental. I'm going to do a clean install on a spare partition with it to see if it will work. I've heard from guys that have the new kernel, and it's not any better for syncing the 5600.

It's really a slap in the face to Linux geeks that Sharp would make a handheld with Linux and then not provide the proper interface and drivers for a Linux desktop. They make a Linux pda that only syncs with Windows.

I am also planning on getting a CompactFlash Card (ethernet, wired) to see if I can at least ftp into my unit and do file transfers. I use lots of small text files to keep track of information. I'd like to be able to write them on my desktop and then transfer to the Z. FTP should do that for me. And, the qtopia desktop shows support for syncing via a "normal" ip address on a LAN (something I'll try later).

Thanks to all for the help. I'll probably be back on this site later to check out the howtos, tips and tricks, etc. Seems like a wealth of info here, even though I was pretty disappointed that the info didn't get me hooked up how I wanted. I guess it's still too much of "bleeding edge" technology and it'll take a while for the Linux drivers to get built and unbugged.

-Greg
Go to the top of the page
 
+Quote Post
cmoman
post Dec 12 2003, 01:17 PM
Post #4





Group: Members
Posts: 7
Joined: 13-June 03
Member No.: 126



Hello,

As root just modprobe usbnet
This little script should get you going. run as root

#!/bin/bash
modprobe usbnet
ifconfig usb0 192.168.129.1 netmask 255.255.255.0 up
route add -host 192.168.129.201 usb0
Go to the top of the page
 
+Quote Post
cmoman
post Dec 12 2003, 01:21 PM
Post #5





Group: Members
Posts: 7
Joined: 13-June 03
Member No.: 126



Perhaps I was a bit quick

make sure
CDEther
acm
usbdnet

are not loaded
rmmod CDEther
rmmod acm
rmmoc usbdnet

BTW what kernel does RH 8 run? I am using Suse8.2 2.4.20 so no kernel patching is required.
Your Slackware kernel sounds fine.

Chris
Go to the top of the page
 
+Quote Post
tiptone
post Dec 12 2003, 02:44 PM
Post #6





Group: Members
Posts: 8
Joined: 7-December 03
Member No.: 1,053



hope you haven't given up totally yet, try blacklisting the undesired modules:

echo CDCEther >> /etc/hotplug/blacklist
echo acm >> /etc/hotplug/blacklist

i run RedHat only (Fedora now) and have built and connected several boxes with my Z, let us know if you have further problems/issues.

brian
Go to the top of the page
 
+Quote Post
summer00
post Jun 4 2004, 02:08 AM
Post #7





Group: Members
Posts: 42
Joined: 2-June 04
Member No.: 3,547



QUOTE
Hello,

As root just modprobe usbnet
This little script should get you going. run as root

#!/bin/bash
modprobe usbnet
ifconfig usb0 192.168.129.1 netmask 255.255.255.0 up
route add -host 192.168.129.201 usb0


HI , i have tried these ....it gave error messages :


SIOCSIFADDR: No such device
usb0: unknown interface: No such device
SIOCSIFNETMASK: No such device
usb0: unknown interface: No such device

im using redhat kernel 2.4.26, any ideas on this? thanks a lot
Go to the top of the page
 
+Quote Post
oninitdialog
post Jun 4 2004, 04:21 AM
Post #8





Group: Members
Posts: 39
Joined: 27-April 04
From: Blackpool UK
Member No.: 2,969



I too have seen these errors on my SuSE 9.0 box. This usually happens when the Zaurus has not been detected by the usb port. Use USBVIEW to make sure the device is connected. I have also found in SuSE 9.0 you have to first create the USB network device and then the script will run.
Go to the top of the page
 
+Quote Post
zenyatta
post Oct 31 2004, 01:48 PM
Post #9





Group: Members
Posts: 366
Joined: 4-November 03
From: Slovakia
Member No.: 850



I've just moved from RedHat 9 to Fedora Core 2. As usbnet comes with the distro, I'd like to use it (rather than compiling usbdnet). Present state:

- no trace of CDCEther, acm or usbdnet
- lsusb lists the Zaurus
- modprobe usbnet says (in /var/log/messages):
usb0: register usbnet at usb-0000:00:11.2-2, Sharp Zaurus SL-5x00
usbcore: registered new driver usbnet
- ifconfig only lists lo and eth0

I'm sure I need to set up an ifup-usb0 script somewhere under /etc. It's been so long... does anyone have a sample script I could use? Thx.

z.
Go to the top of the page
 
+Quote Post
zenyatta
post Oct 31 2004, 02:11 PM
Post #10





Group: Members
Posts: 366
Joined: 4-November 03
From: Slovakia
Member No.: 850



OK, solved it. Found some of my old docs, I edited /etc/modprobe.conf ("alias usb0 usbnet") and created /etc/sysconfig/network-scripts/ifcfg-usb0 which looks like this:
CODE
DEVICE=usb0
BOOTPROTO=static
BROADCAST=192.168.129.255
IPADDR=192.168.129.1
NETMASK=255.255.255.0
NETWORK=192.168.129.0
ONBOOT=no

However, when I ran "ifconfig usb0 up" and then "ifconfig usb0" it was listed as UP but had no IP address! It did have an IPv6 address which is completely useless to me. So I read up on ifconfig and ran "ifconfig usb0 inet 192.168.192.1 netmask 255.255.255.0". Now I can ping the Zaurus and I can even ssh into it. Hopefully I'll soon figure out how to make all this happen automatically when I insert the Z into the cradle...
Go to the top of the page
 
+Quote Post
dz
post Oct 31 2004, 03:06 PM
Post #11


~


Group: Admin
Posts: 596
Joined: 2-February 04
From: Cape Canaveral, FL
Member No.: 1,667



I still think you should go to Slackware smile.gif
Go to the top of the page
 
+Quote Post
zenyatta
post Oct 31 2004, 10:43 PM
Post #12





Group: Members
Posts: 366
Joined: 4-November 03
From: Slovakia
Member No.: 850



Well, if I could multi-boot to Debian, Suse, Slackware, Linspire, Gentoo, Fedora, OpenBSD and FreeBSD with all of them sharing the same preferences & data... I think I might even find my ideal desktop OS smile.gif I have no doubt it is indeed possible but it'll have to wait until I'm retired...
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th September 2014 - 05:51 PM