OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Cannot connect to Bluetooth Device
lwong
post Jun 1 2004, 06:55 PM
Post #1





Group: Members
Posts: 53
Joined: 18-March 04
From: USA
Member No.: 2,388



I have a strange problem connecting to bluetooth device for the past two days: When I type sdptool browse or spdtool search SP, my newly acquired Pharos BT GPS will return:

Failed to connect to SDP server on 11:22:33:44:55:66: Permission denied

where 11:22... is the MA address of the GPS. /etc/bluetooth/givepin has the correct PIN for the GPS. I tried different combinations inside hcid.conf, restarted blueZ, cardctl, cardresume, reboot but nothing works. Z has no problem seeing my BT cellphone though.

I am using old Ambicom BT2000 CF card on SL6000L with BlueZ. Running as root has the same Permission Denied message.

What can be wrong? The strange thing is that it also happened two days ago but suddenly worked fine but return again today.

Oh, the GPS unit pairs with the same card when I use it in my laptop so it's unlikely the culprit.

Thanks in advance for your help

FW
Go to the top of the page
 
+Quote Post
lwong
post Jun 5 2004, 06:01 AM
Post #2





Group: Members
Posts: 53
Joined: 18-March 04
From: USA
Member No.: 2,388



Ok, I reformatted the Z this morning to start from scratch.

After the refomatting, I installed Qkonsole first, then BlueZ package. Nothing else

Tried "sdptool browse":

>sdptool browse
Inquiring...
Failed to connect to SDP server on 11:22:33:44:55:66: Permission denied
>sdptool browse
Inquiring...
Failed to connect to SDP server on 11:22:33:44:55:66: Protocol error
>sdptool browse
Inquiring...
Failed to connect to SDP server on 11:22:33:44:55:66: Too many level of symbolic links

What on earth is wrong with the connection!!! The GPS is freshly charged, in range and tested find using the same Ambicom BT2000E CF card in my Windows XP laptop. It can;t be the PIN in /etc/bluetooth/givepin, could it? I am just looking for a Serial Profile, not trying to pair with it(yet). "sdptool searh SP" returns the same set of results. I have searched high and low on the internet but no one seems to have encountered this strange error meaasge. Can anyone help?

SL6000L
Default Sharp ROM
Ambicom BT2000E CF card
Bluez

Thanks

FW
Go to the top of the page
 
+Quote Post
tumnus
post Jun 5 2004, 12:39 PM
Post #3





Group: Members
Posts: 1,176
Joined: 3-October 03
From: UK
Member No.: 547



You might want to try contacting Marcel Holtman on the BlueZ mailing lists with info like your zaurus, CF BT card, GPS model and syslog output when you try a sdptool browse. It looks like an incompatibility between the BlueZ drivers and your GPS since you have got the connection with your mobile phone working fine.
Go to the top of the page
 
+Quote Post
lwong
post Jun 8 2004, 06:21 AM
Post #4





Group: Members
Posts: 53
Joined: 18-March 04
From: USA
Member No.: 2,388



Thanks for the advice Tumnus.

The strangest thing happened the other day: after I reformatted the Z and still couldn;t get it to connect to GPS, I gave up and restored to the previous setting. Since then, everything works again!!! It's a really strange thing becasue the restoration point was when sdptool gave me the "permission denied" message. I just ended up buying a D-link bluetooth dongle to use on my laptop and just keep the Ambicom CF exclusively (for now) for the Z. Hopefully I don;t have to see that message again...

BTW, since SL6000 has teh USB host feature, is there a way for your BlueZ package to work with dongle instead?

Thanks

FW
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd July 2014 - 01:17 AM